# Table of Contents

## The Fundamentals

<table>
<thead>
<tr>
<th>The Fundamentals</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to Databases</td>
<td>9</td>
</tr>
<tr>
<td>Starting Access 2010</td>
<td>10</td>
</tr>
<tr>
<td>Opening a Database</td>
<td>12</td>
</tr>
<tr>
<td>What's New in Access 2010</td>
<td>13</td>
</tr>
<tr>
<td>Understanding the Access Program Screen</td>
<td>14</td>
</tr>
<tr>
<td>Giving Commands</td>
<td>15</td>
</tr>
<tr>
<td>Using Command Shortcuts</td>
<td>16</td>
</tr>
<tr>
<td>Using Help</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>21</td>
</tr>
</tbody>
</table>

## The Fundamentals Review

<table>
<thead>
<tr>
<th>The Fundamentals Review</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Basics</td>
<td>23</td>
</tr>
<tr>
<td>Working with Database Objects</td>
<td>25</td>
</tr>
<tr>
<td>Tour of a Table</td>
<td>26</td>
</tr>
<tr>
<td>Adding, Editing and Deleting Records</td>
<td>28</td>
</tr>
<tr>
<td>Tour of a Form</td>
<td>30</td>
</tr>
<tr>
<td>Tour of a Query</td>
<td>31</td>
</tr>
<tr>
<td>Tour of a Report</td>
<td>33</td>
</tr>
<tr>
<td>Previewing and Printing a Database Object</td>
<td>34</td>
</tr>
<tr>
<td>Selecting Data</td>
<td>35</td>
</tr>
<tr>
<td>Cutting, Copying and Pasting Data</td>
<td>36</td>
</tr>
<tr>
<td>Using Undo and Redo</td>
<td>37</td>
</tr>
<tr>
<td>Checking Your Spelling</td>
<td>39</td>
</tr>
<tr>
<td>Using the Zoom Box</td>
<td>41</td>
</tr>
<tr>
<td>Exiting Access 2010</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td>44</td>
</tr>
</tbody>
</table>

## Database Basics Review

<table>
<thead>
<tr>
<th>Database Basics Review</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating and Working with a Database</td>
<td>45</td>
</tr>
<tr>
<td>Planning a Database</td>
<td>47</td>
</tr>
<tr>
<td>Creating a New Database</td>
<td>48</td>
</tr>
<tr>
<td>Creating a Table</td>
<td>50</td>
</tr>
<tr>
<td>Modifying a Table</td>
<td>52</td>
</tr>
<tr>
<td>Creating a Query</td>
<td>54</td>
</tr>
<tr>
<td>Sorting a Query</td>
<td>56</td>
</tr>
<tr>
<td>Using AND and OR Operators in a Query</td>
<td>58</td>
</tr>
<tr>
<td>Creating a Form with the Form Wizard</td>
<td>59</td>
</tr>
<tr>
<td>Creating a Report with the Report Wizard</td>
<td>60</td>
</tr>
<tr>
<td>Creating Mailing Labels with the Label Wizard</td>
<td>62</td>
</tr>
<tr>
<td>Converting an Access Database</td>
<td>64</td>
</tr>
<tr>
<td></td>
<td>66</td>
</tr>
</tbody>
</table>

## Creating and Working with a Database Review

<table>
<thead>
<tr>
<th>Creating and Working with a Database Review</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finding, Filtering, and Formatting Data</td>
<td>68</td>
</tr>
<tr>
<td>Finding and Replacing Data</td>
<td>70</td>
</tr>
<tr>
<td>Sorting Records</td>
<td>71</td>
</tr>
<tr>
<td>Using Common Filters</td>
<td>73</td>
</tr>
<tr>
<td>Filtering by Selection</td>
<td>74</td>
</tr>
<tr>
<td>Filtering by Form</td>
<td>76</td>
</tr>
<tr>
<td>Creating an Advanced Filter</td>
<td>77</td>
</tr>
<tr>
<td>Adjusting and Rearranging Rows and Columns</td>
<td>78</td>
</tr>
<tr>
<td>Changing Gridline and Cell Effects</td>
<td>80</td>
</tr>
<tr>
<td>Changing the Datasheet Font</td>
<td>82</td>
</tr>
<tr>
<td></td>
<td>84</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Freezing a Column</td>
<td>85</td>
</tr>
<tr>
<td>Hiding a Column</td>
<td>86</td>
</tr>
<tr>
<td>Finding, Filtering, and Formatting Data Review</td>
<td>87</td>
</tr>
<tr>
<td>Working with Tables and Fields</td>
<td>89</td>
</tr>
<tr>
<td>Understanding Field Properties</td>
<td>90</td>
</tr>
<tr>
<td>Indexing a Field</td>
<td>92</td>
</tr>
<tr>
<td>Adding a Primary Key to a Table</td>
<td>94</td>
</tr>
<tr>
<td>Inserting, Deleting, and Reordering Fields</td>
<td>96</td>
</tr>
<tr>
<td>Adding Field Descriptions and Captions</td>
<td>98</td>
</tr>
<tr>
<td>Changing the Field Size</td>
<td>99</td>
</tr>
<tr>
<td>Formatting Number, Currency, and Date/Time Fields</td>
<td>101</td>
</tr>
<tr>
<td>Formatting Number, Currency, and Date/Time Fields by Hand</td>
<td>103</td>
</tr>
<tr>
<td>Formatting Text Fields</td>
<td>105</td>
</tr>
<tr>
<td>Requiring Data Entry</td>
<td>106</td>
</tr>
<tr>
<td>Validating Data</td>
<td>108</td>
</tr>
<tr>
<td>Creating an Input Mask</td>
<td>110</td>
</tr>
<tr>
<td>Creating a Lookup Field</td>
<td>112</td>
</tr>
<tr>
<td>Creating a Value List</td>
<td>114</td>
</tr>
<tr>
<td>Modifying a Lookup List</td>
<td>116</td>
</tr>
<tr>
<td>Working with Tables and Fields Review</td>
<td>118</td>
</tr>
<tr>
<td>Creating Relational Databases</td>
<td>121</td>
</tr>
<tr>
<td>Understanding Table Relationships</td>
<td>122</td>
</tr>
<tr>
<td>Creating Relationships Between Tables</td>
<td>124</td>
</tr>
<tr>
<td>Enforcing Referential Integrity</td>
<td>126</td>
</tr>
<tr>
<td>Printing and Deleting Relationships</td>
<td>128</td>
</tr>
<tr>
<td>Understanding Relationship Types</td>
<td>130</td>
</tr>
<tr>
<td>Creating Relational Databases Review</td>
<td>131</td>
</tr>
<tr>
<td>Working with Queries</td>
<td>132</td>
</tr>
<tr>
<td>Understanding Different Types of Queries</td>
<td>133</td>
</tr>
<tr>
<td>Creating a Multiple Table Query</td>
<td>134</td>
</tr>
<tr>
<td>Creating a Calculated Field</td>
<td>136</td>
</tr>
<tr>
<td>Working with Expressions and the Expression Builder</td>
<td>138</td>
</tr>
<tr>
<td>Using an If Function</td>
<td>140</td>
</tr>
<tr>
<td>Summarizing Groups of Records</td>
<td>142</td>
</tr>
<tr>
<td>Display Top or Bottom Values</td>
<td>144</td>
</tr>
<tr>
<td>Parameter Queries</td>
<td>145</td>
</tr>
<tr>
<td>Finding Duplicate Records</td>
<td>147</td>
</tr>
<tr>
<td>Finding Unmatched Records</td>
<td>148</td>
</tr>
<tr>
<td>Crosstab Queries</td>
<td>150</td>
</tr>
<tr>
<td>Delete Queries</td>
<td>152</td>
</tr>
<tr>
<td>Append Queries</td>
<td>154</td>
</tr>
<tr>
<td>Make-Table Queries</td>
<td>156</td>
</tr>
<tr>
<td>Update Queries</td>
<td>158</td>
</tr>
<tr>
<td>Working with Queries Review</td>
<td>160</td>
</tr>
<tr>
<td>Working with Forms</td>
<td>162</td>
</tr>
<tr>
<td>Creating and Using a Form</td>
<td>163</td>
</tr>
<tr>
<td>Understanding Form Views</td>
<td>165</td>
</tr>
<tr>
<td>Modifying a Form in Layout View</td>
<td>166</td>
</tr>
<tr>
<td>Form Design View Basics</td>
<td>168</td>
</tr>
<tr>
<td>Changing Tab Order</td>
<td>170</td>
</tr>
<tr>
<td>Working with Control Properties</td>
<td>171</td>
</tr>
</tbody>
</table>

Introducing
CustomGuide
Courseware

Thank you for choosing CustomGuide courseware as the solution to your training needs. A proven leader in the computer training industry, CustomGuide has been the key to successful training for thousands of students and instructors across the globe.

This manual is designed for computer users of all experience levels, from novices to advanced users.

All this information is quickly accessible. Lessons are broken down into basic step-by-step instructions that answer “how-to” questions in minutes. You can print a complete 300-page training manual or a single page of instructions.

Here’s how a CustomGuide manual is organized:

Chapters
Each manual is divided into several chapters. Aren’t sure if you’re ready for a chapter? Look at the table of contents that appears at the beginning of each chapter. It will tell you the name of each lesson and subtopic included in the chapter.

Lessons
Each chapter contains lessons on related topics. Each lesson explains a new skill or topic and contains an exercise and exercise file to give you hands-on-experience. These skills can also be practiced using CustomGuide Online Learning.

Review
A review is included at the end of the manual. Use these quiz questions and answers to assess how much you’ve learned.
How It Works

1. **Open Microsoft Word**
   Our customizable courseware is provided as simple-to-use, editable Microsoft Word documents—if you can use Microsoft Word you can create your own training materials in minutes!

2. **Select Your Topics**
   Select the content you need from our award-winning courseware library. You can even mix and match topics between titles, such as Microsoft Outlook and Microsoft Word.

3. **Customize**
   Arrange topics in the order you want—the courseware automatically updates to reflect your changes. Add your organization’s name and logo for a professional “in-house” look.

4. **Print and Distribute**
   Print as many copies as you need at your site, without paying any per-unit royalties or maintaining physical inventories. You can print single-page handouts, a group of related lessons, or a complete manual. It’s fast, convenient, and very affordable.

5. **Teach and Learn**
   You’ll love having your own customized training materials, and your users will appreciate the colorful illustrations, down-to-earth writing style, and the convenience of having a reference guide that they can use in or out of the classroom.

**3rd Generation Courseware: What’s New?**

CustomGuide is pleased to introduce 3rd generation courseware. Completely redesigned from years of customer feedback, 3rd generation courseware features a streamlined design that is easier to customize and use as a reference tool. Take a look at the table below for more information regarding these features.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Streamlined design</strong></td>
<td>Featuring a professional-looking, easy-to-read design, 3rd generation courseware appeals to instructors, students and individual users alike.</td>
</tr>
<tr>
<td><strong>Exercise Notes</strong></td>
<td>A new Exercise Notes section appears at the top of each lesson. Rather than practicing the topic step by step through the lesson as in 2nd generation courseware, the topic can be practiced using the exercise file and exercise described here.</td>
</tr>
<tr>
<td><strong>Table of Contents</strong></td>
<td>In addition to the Table of Contents found at the beginning of each courseware title, 3rd generation courseware includes a Table of Contents at the beginning of each chapter, making it even easier to locate the lessons you need.</td>
</tr>
<tr>
<td><strong>Smart Quizzes</strong></td>
<td>The Quiz section, located at the back of the book, automatically updates itself when the manual is customized. For example, if you remove a lesson regarding cutting and pasting text, there will be no questions in the Quiz section that relate to cutting and pasting text.</td>
</tr>
<tr>
<td><strong>Easier customization</strong></td>
<td>The design of 3rd generation is simplified, which makes it easier to customize. All you have to do is click and drag or copy and paste, or press the &lt;Delete&gt; key to remove a lesson, and voila; you’re done!</td>
</tr>
<tr>
<td><strong>Use as a reference tool</strong></td>
<td>3rd generation courseware breaks tasks down into basic step-by-step instructions and can be used as a virtual help desk, answering “how-to” questions in minutes.</td>
</tr>
</tbody>
</table>
Courseware Features

Working with Shapes and Pictures

Positioning Pictures

Whenever you insert a graphic into a document, it is inserted inline with text by default. This means that the text in the document moves in order to accommodate the graphic. This lesson will show you how to adjust text wrapping and how to use the grid to position objects.

Tips
✓ If you want to use a graphic with other graphics or objects, they must be on a drawing canvas. See the lesson on Inserting Shapes for more information.

Adjust text wrapping

To adjust how text reacts to the objects in your documents, change the object’s text wrapping:

1. Double-click the object whose text wrapping you wish to adjust.
   The Format contextual tab appears on the Ribbon.
2. Click the Text Wrapping button in the Arrange group.
   A list of text wrapping styles appears. Take a look at the Text Wrapping Styles table for a description of each style.
3. Select a text wrapping style from the list.
   The text wrapping style is applied to the image.

Other Ways to Adjust Text Wrapping:
Right-click the image, point to Text Wrapping in the contextual menu, and select an option from the submenu.

To display/hide the grid

1. Click the View tab on the Ribbon.
2. Click the Gridlines check box in the Show/Hide group.
   Horizontal and vertical gridlines appear on the page.

Other Ways to Display the Grid:
Press <Shift> + <F9>, or click the Format contextual tab on the Ribbon, click the Align button in the Arrange group, and select View Gridlines from the list.

Tip: Gridlines do NOT appear in the printed document.

Lessons are presented on one or two pages, so you can follow along without wondering when a lesson ends and a new one begins.

Each lesson includes a hands-on exercise and practice file so users can practice the topic of the lesson.

Clear step-by-step instructions answer “how-to” questions. Anything you need to click appears like this.

Tips let you know more information about a specific step or topic as a whole.

Whenever there is more than one way to do something, the most common method is presented in the numbered step, while the alternate methods appear beneath.

Tables provide summaries of the terms, toolbar buttons, and options covered in the lesson.

The table of contents, index, tables, figures, and quiz questions automatically update to reflect any changes you make to the courseware.

Icons and pictures show you what to look for as you follow the instructions.
The Fundamentals

Introduction to Databases ........................................ 10
    Database objects ........................................... 10
Starting Access 2010 ............................................ 12
    Windows Vista and Windows 7 ......................... 12
Opening a Database ............................................. 13
    Open an existing database ............................... 13
What’s New in Access 2010 .................................... 14
Understanding the Access Program Screen .......... 15
Giving Commands .............................................. 16
    Ribbon ................................................ 16
    File tab ............................................. 17
    Quick Access Toolbar ................................. 17
Using Command Shortcuts ................................. 18
    Keystroke shortcuts ................................. 18
    Contextual menus ................................. 18
    Mini Toolbar ................................ 18
    Key Tips ........................................... 19
Using Help ...................................................... 21
    Search for help ................................ 21
    Browse for help ................................ 21
    Choose the Help source ........................... 21

Microsoft Access is a powerful database program you can use to store all kinds of information—from a simple list of contacts to an inventory catalog with tens of thousands of products. Once information is stored in a Microsoft Access database, it’s easy to find, analyze, and print.

For 2010, Access has had a number of new features included. If you’ve used Access 2007 before, you’ll still be familiar with much of the program’s functionality, but you’ll notice an updated user interface and new features that have been added to make using Access more efficient.

This chapter is an introduction to working with Access. You’ll learn about the main parts of the program screen, how to give commands, use help, and about new features in Access 2010.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Introduction to Databases

In its simplest form, a database is a collection of information organized into a list. Whenever you make a list of information, such as names, addresses, products, or invoices, you are, in fact, creating a database.

Technically speaking, you don’t even have to use a database program to create a database. You can make a list of information in all kinds of programs, such as Microsoft Excel or Word.

A database program, however, is much more powerful than a simple list you keep on paper or in a Microsoft Word document. A database program lets you:

- **Store Information**: A database stores lists of information that are related to a particular subject or purpose. A database stores personal information, such as a list of aunt Mildred’s home recipes, or business information, such as a list of hundreds of thousands of customers. A database also makes it easy to add, update, organize, and delete information.

- **Find Information**: You can easily and instantly locate information stored in a database. For example, you can find all the customers with the last name “Johnson” or all the customers who live in the 55417 zip code and are older than 65.

- **Analyze and Print Information**: You can perform calculations on information in a database. For example, you could calculate what percent of your total sales comes from the state of Texas. You can also present information in a professional-looking printed report.

- **Manage Information**: Databases make it easy to work with and manage huge amounts of information. For example, with a few keystrokes you can change the area code for hundreds of customers in the (612) area code to a new (817) area code.

- **Share Information**: Most database programs (including Microsoft Access) allow more than one user to view and work with the same information at once. Such databases are called multi-user databases.

**Database objects**

Databases usually consist of several parts. A Microsoft Access database may contain up to seven different database object types.

Some objects you will use all the time (such as Tables), while others you may hardly ever use (such as Modules).

Table 1-1: Database Objects identifies the database objects you can use when creating a Microsoft Access database.
### Table 1-1: Database Objects

<table>
<thead>
<tr>
<th>Database Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tables</strong></td>
<td>Tables store a database’s data in rows (records) and columns (fields). For example, one table could store a list of customers and their addresses while another table could store the customers’ orders. A database must always contain at least one table where it can store information—all the other database objects are optional.</td>
</tr>
<tr>
<td><strong>Queries</strong></td>
<td>Queries ask a question of data stored in a table. For example, a query might only display customers who are from Texas.</td>
</tr>
<tr>
<td><strong>Forms</strong></td>
<td>Forms are custom screens that provide an easy way to enter and view data in a table or query.</td>
</tr>
<tr>
<td><strong>Reports</strong></td>
<td>Reports present data from a table or query in a printed format.</td>
</tr>
<tr>
<td><strong>Macros</strong></td>
<td>Macros help you perform routine tasks by automating them into a single command. For example, you could create a macro that automatically opens and prints a report.</td>
</tr>
<tr>
<td><strong>Modules</strong></td>
<td>Like macros, modules automate tasks but by using a built-in programming language called Visual Basic or VB. Modules are much more powerful and complex than macros.</td>
</tr>
</tbody>
</table>
Starting Access 2010

In order to use a program, you must start—or launch—it first.

Windows Vista and Windows 7

1. Click the Start button.
   The Start menu appears.

2. Click All Programs.
   The left pane of the Start menu displays the programs and menus installed on your computer.

3. Click Microsoft Office.

   The Access 2010 program screen appears.

Other Ways to Launch a Program:
Click the Start button and type the program name in the Search box. Click the program in the search results to launch it.

Tips
✓ If you use Access 2010 frequently, you might consider pinning it to the Start menu. To do this, right-click Microsoft Office Access 2010 in the All Programs menu and select Pin to Start Menu.

Windows 7 users can also pin a program to the taskbar. To do this, right-click the Access button in the taskbar and select Pin this program to taskbar from the contextual menu.

Exercise
• Exercise File: None required.
• Exercise: Start the Microsoft Office Access 2010 program.

Figure 1-2: The All Programs menu in Windows Vista.
Opening a Database

When opening Access 2010, you can choose from a number of options when creating or opening a database:

- **Blank Database**: Create a new blank database from scratch for storing information.

- **Templates**: Select a template stored locally on your computer or from Office Online. Several categories of templates are available: Assets, Contacts, Issues & Tasks, Non-profit and Projects. Within the categories are different types of templates—for example within Issues & Tasks, you can choose from Issues web database or Tasks management database.

- **Recent**: Open an existing database from a list of recently opened databases. A quick list of recent databases is also displayed in the pane on the left.

- **Open**: If your existing database doesn’t appear in the Recent list, click Open to browse your computer or network for more existing databases.

In this lesson, we’ll look only at the most basic of these options—how to open an existing database.

Open an existing database

1. Once you’ve started Access, click the database you want to open in the Recent section in the left pane.

   **Other Ways to Open an Existing Database:***
   
   If the database you want to open doesn’t appear in the Recent list, click **Open** in the left pane and browse to the database file.

The database opens.
What’s New in Access 2010

Access 2010 is very different from previous versions. The table below gives you an overview of what to expect.

<table>
<thead>
<tr>
<th>Table 1-2: What’s New in Access 2010</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customizable Ribbon</strong></td>
</tr>
<tr>
<td><strong>File format</strong></td>
</tr>
<tr>
<td><strong>Backstage View</strong></td>
</tr>
<tr>
<td><strong>Database templates</strong></td>
</tr>
<tr>
<td><strong>Field and table templates</strong></td>
</tr>
<tr>
<td><strong>Application parts</strong></td>
</tr>
<tr>
<td><strong>Object tabs</strong></td>
</tr>
<tr>
<td><strong>New views</strong></td>
</tr>
<tr>
<td><strong>Navigation Pane</strong></td>
</tr>
<tr>
<td><strong>Better object creation tools</strong></td>
</tr>
<tr>
<td><strong>Improved Help</strong></td>
</tr>
<tr>
<td><strong>New data types and controls</strong></td>
</tr>
<tr>
<td><strong>Better tools for design and analysis</strong></td>
</tr>
<tr>
<td><strong>Better security and sharing</strong></td>
</tr>
<tr>
<td><strong>Outlook integration</strong></td>
</tr>
<tr>
<td><strong>Export to PDF or XPS</strong></td>
</tr>
<tr>
<td><strong>Conditional formatting</strong></td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** None required.
- **Exercise:** Review the new features in Microsoft Office Access 2010.
The Fundamentals

Understanding the Access Program Screen

The Access 2010 program screen may seem confusing and overwhelming at first. This lesson will help you become familiar with the Access 2010 program screen as well as the new user interface.

| A | File tab: Contains basic file management commands—such as New, Open, Save, and Close—and program options. |
| B | Quick Access Toolbar: Contains common commands such as Save and Undo. You can add more commands as well. |
| C | Title bar: Displays the name of the workbook you are working on and the name of the program you are using. |
| D | Close button: Click the close button in the Title bar to exit the Access program entirely, or click the close button in the Ribbon to close only the current database object. |
| E | Ribbon: The tabs and groups on the Ribbon replace the menus and toolbars found in previous versions of Access. |
| F | Access Object: View the content of the various database objects |
| G | View buttons: Use these buttons to quickly switch between the different views. |
| H | Scroll bar: Use the scroll bar to view different parts of the database object. |
| I | Status bar: Displays messages and feedback. |
| J | Navigation Pane: Here you can see and open your database objects such as tables, queries, forms, and reports. |
| K | Object tabs: A tab appears for each open database object. Click a tab to view and work with that object. |

Exercise Notes

- Exercise File: Employees.accdb
- Exercise: Understand and experiment with different parts of the Microsoft Office Access 2010 screen.
Giving Commands

Access 2010 provides easy access to commands through the Ribbon. The Ribbon keeps commands visible while you work instead of hiding them under menus or toolbars.

Ribbon

The Ribbon is made up of three basic components: tabs, groups, and buttons. It is the primary way to give commands in Access.

Tabs: Commands are organized into tabs on the Ribbon. Each tab contains a different set of commands. There are different types of tabs:

- **Command tabs**: These tabs appear by default whenever you open the Access program. In Access 2010, the Home, Insert, Page Layout, Formulas, Data, Review, and View tabs appear by default.

- **Contextual tabs**: Contextual tabs appear whenever you perform specific task, or when a specific object is selected. The tabs offer commands relative to only that object or task. For example, whenever you select an image, the Picture Tools tab appears on the Ribbon.

Groups: The commands found on each tab are organized into groups of related commands. For example, the Font group contains commands used for formatting fonts. Click the Dialog Box Launcher in the bottom-right corner of a group to display even more commands. Some groups also contain galleries that display several formatting options.

Tip: Based on the size of the program window, Access changes the appearance and layout of the commands within the groups.

Buttons: One way to issue a command is by clicking its button on the Ribbon. Buttons are the smallest element of the Ribbon. Click a button to give a command.

Tips

- You can hide the Ribbon so that only tab names appear, giving you more room in the program window. To do this, double-click the currently displayed command tab. Or, right-click a Ribbon tab and select Minimize Ribbon from the contextual menu. To display the Ribbon again, click any tab.

Exercise

- **Exercise File**: Employees.accdb
- **Exercise**: Click each tab on the Ribbon to view its commands.

Figure 1-5: Elements of the Ribbon.

Figure 1-6: Hiding the Ribbon gives you more room in the program window.
**File tab**

The _File tab_ appears in the upper-left corner of the program window. When clicked, it opens _Backstage view_, which is where you find commands for basic file management, including New, which creates a new file; Open, which opens an existing file; Save, which saves the currently opened file; and Close, which closes the currently opened file. This is also where you find commands for controlling program options and sharing.

**Tips**

- The File tab replaces the File menu and Office Button found in previous versions of Access.

**Quick Access Toolbar**

The _Quick Access Toolbar_ appears to the right of the File tab and provides easy access to the commands you use most frequently. By default, the Save, Undo, and Redo buttons appear on the toolbar; however, you can customize this toolbar to meet your needs by adding or removing buttons.

![Figure 1-7: The Info tab in Backstage view.](image)

![Figure 1-8: The Quick Access Toolbar.](image)
Using Command Shortcuts

Command shortcuts provide other ways to give commands in Access. Shortcuts can be a time-saving and efficient alternative to the Ribbon. Use shortcuts for the commands you use most frequently.

Keystroke shortcuts

*Keystroke shortcuts* are one of the fastest ways to give commands in Access. They’re especially great for issuing common commands, such as saving an object.

In order to issue a command using a keystroke shortcut, you simply press a combination of keys on your keyboard. For example, rather than clicking the Copy button on the Ribbon to copy a cell, you could press and hold the copy keystroke shortcut, <Ctrl> + <C>.

Contextual menus

A *contextual menu* displays a list of commands related to a specific object or area. To open a contextual menu:

1. Right-click an object or area of the worksheet or program screen.
   
   A contextual menu appears, displaying commands that are relevant to the object or area that you right-clicked.

2. Select an option from the contextual menu, or click anywhere outside the contextual menu to close it without selecting anything.

Mini Toolbar

The *Mini Toolbar* appears when you select text or data within a cell or the formula bar, and contains common text formatting commands.

1. Select text or data within a cell or the formula bar.
   
   The Mini Toolbar appears near the text or data you selected.

   **Trap:** Sometimes the Mini Toolbar can be hard to see due to its transparency. To make the Mini Toolbar more visible, point to it.

   **Tip:** To close the Mini Toolbar while text is still selected, press <Esc>.

2. Click a button on the Mini Toolbar.
   
   The command is given in Access.

Table 1-3: Common Keystroke Shortcuts

<table>
<thead>
<tr>
<th>Keystroke Combination</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Ctrl&gt; + &lt;O&gt;</td>
<td>Opens a workbook.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;N&gt;</td>
<td>Creates a new workbook.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;S&gt;</td>
<td>Saves the current workbook.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;P&gt;</td>
<td>Prints the worksheet.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;B&gt;</td>
<td>Toggles bold font formatting.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;I&gt;</td>
<td>Toggles italic font formatting.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;C&gt;</td>
<td>Copies the selected cell, text or object.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;X&gt;</td>
<td>Cuts the selected cell, text or object.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;V&gt;</td>
<td>Pastes the selected cell, text or object.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Home&gt;</td>
<td>Moves the cell pointer to the beginning of the worksheet.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;End&gt;</td>
<td>Moves the cell pointer to the end of the worksheet.</td>
</tr>
</tbody>
</table>

Figure 1-10: The Mini Toolbar.
Tips

If you don’t want the Mini Toolbar to appear every time you select text, click the File tab and click Options. Click the Personalize category, uncheck the Show Mini Toolbar on selection check box, and click OK.

A larger version of the Mini Toolbar and a contextual menu appear when you right-click an object or area of the worksheet window.

Key Tips

Key Tips appear whenever you press the <Alt> key. You can use Key Tips to perform just about any action in Access, without ever having to use the mouse.

To issue a command using a Key Tip, first press the <Alt> key. Tiny letters and numbers, called badges, appear on the Quick Access Toolbar, and all of the tabs on the Ribbon. Depending on the tab or command you want to select, press the letter or number key indicated on the badge. Repeat this step as necessary until the desired command has been issued.

Figure 1-11: Press the <Alt> key to display Key Tips.
Using Help

When you don’t know how to do something in Access 2010, look up your question in the Access Help files. The Access Help files can answer your questions, offer tips, and provide help for all of Access’s features.

Search for help

1. Click the Microsoft Access Help button ( ) on the Ribbon.
   The Access Help window appears.
   Other Ways to Open the Help window:
   Press <F1>.
2. Type what you want to search for in the “Type words to search for” box and press <Enter>.
   A list of help topics appears.
3. Click the topic that best answers your question.
   Access displays information regarding the selected topic.

Browse for help

1. Click the Microsoft Access Help button ( ) on the Ribbon.
   The Access Help window appears.
2. Click the category that you want to browse.
   The topics within the selected category appear.
3. Click the topic that best answers your question.
   Access displays information regarding the selected topic.

Choose the Help source

If you are connected to the Internet, Access 2010 retrieves help from the Office Online database by default. You can easily change this to meet your needs.

1. Click the Search button list arrow in the Access Help window.
   A list of help sources appears.
2. Select an option from the list.
   Now you can search from that source.

Exercise

- Exercise File: Employees.accdb.
- Exercise: Search for the keywords “create table”. Change the Help source to Access Help in the “Content from this computer” section and notice the change in results. Return to the Help home page and browse topics in the “Getting Started” category of Help.
Tips

Office 2010 offers enhanced ScreenTips for many buttons on the Ribbon. You can use these ScreenTips to learn more about what a button does and, where available, view a keystroke shortcut for the command. If you see the message “Press F1 for more help”, press <F1> to get more information relative to that command.

When you are working in a dialog box, click the Help button (☞) in the upper right-hand corner to get help regarding the commands in the dialog box.

<table>
<thead>
<tr>
<th>Table 1-4: Help buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Back</td>
</tr>
<tr>
<td>Forward</td>
</tr>
<tr>
<td>Stop</td>
</tr>
<tr>
<td>Refresh</td>
</tr>
<tr>
<td>Home</td>
</tr>
<tr>
<td>Print</td>
</tr>
<tr>
<td>Change Font Size</td>
</tr>
<tr>
<td>Show Table of Contents</td>
</tr>
<tr>
<td>Keep On Top</td>
</tr>
</tbody>
</table>
# The Fundamentals Review

## Quiz Questions

1. A database allows you to do which of the following?
   - A. Store information
   - B. Share information
   - C. Find information
   - D. All of these

2. Access automatically opens with Windows. (True or False?)

3. On the Getting Started page, you can create a database using a template. (True or False?)

4. Which of the following is NOT a new feature in Access 2007?
   - A. SmartArt
   - B. Navigation Pane
   - C. New file format
   - D. Object tabs

5. What is the Ribbon?
   - A. A string of code that enables XML compatibility.
   - B. The path name that refers to where a command is located in the program.
   - C. Another name for the title bar.
   - D. The command center that replaces menus and toolbars of previous versions.

6. The Ribbon can be hidden so that only tab names appear. (True or False?)

7. The File tab contains basic file commands. (True or False?)

8. What is the Quick Access Toolbar?
   - A. There are no toolbars in Excel 2010.
   - B. What appears when you select text.
   - C. A customizable toolbar of common commands that appears above or below the Ribbon.
   - D. An extension of the Windows taskbar.

9. Which of the following is NOT a common keystroke shortcut in Excel?
   - A. <Ctrl> + <Alt> + <Delete>
   - B. <Ctrl> + <S>
   - C. <Ctrl> + <O>
   - D. <Ctrl> + <Home>

10. What key can you press to get help in Excel?
    - A. <Esc>
    - B. <Ctrl> + <H>
Quiz Answers

1. D. A database allows you to do all of these functions.
2. False. You must start Access to begin using it.
3. True. On the Getting Started page, you can create a database from a template.
5. D. The Ribbon is the command center that replaces menus and toolbars of previous versions.
6. True. Double-click the active tab to hide the Ribbon, then click any tab to view commands once again.
7. True. The File tab contains basic file commands, similar to the File menu of previous versions.
8. C. The Quick Access Toolbar is a customizable toolbar of common commands that appears above or below the Ribbon.
9. A. <Ctrl> + <Alt> + <Delete> is a Windows command, not an Excel command.
10. C. Press <F1> to access help in Excel.
## Database Basics

**Working with Database Objects**  26
- Navigation Pane  26
- Open a database object  26
- Modify a database object in Design View  27
- Close a database object  27

**Tour of a Table**  28
- Open a table  28
- Navigate a table  28

**Adding, Editing and Deleting Records**  30

**Tour of a Form**  31
- Open a form  31
- Navigate a form  32
- Add a record  32
- Delete a record  32

**Tour of a Query**  33
- Open a query  33
- Display a query in Design View  33

**Tour of a Report**  34
- Open a report  34

**Previewing and Printing a Database Object**  35

**Selecting Data**  36

**Cutting, Copying and Pasting Data**  37

**Using Undo and Redo**  39
- Undo a single action  39
- Undo multiple actions  39
- Redo an action  39

**Checking Your Spelling**  41

**Using the Zoom Box**  43

**Exiting Access 2010**  44
- Close a database  44
- Exit Access  44

This chapter will introduce you to Access basics. We don’t get into great depth here, but we make sure you understand key Access functionality, such as entering data and the basics of tables, forms, queries and reports. This chapter will help you build a solid foundation of Access knowledge, and if you’re involved more with data entry than database design or administration, this chapter may be all you need to do your job.

### Using Exercise Files

This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Working with Database Objects

Think of the Navigation Pane as the mission control center for an Access database. You use the Navigation Pane to open and manage the different types of objects in your database. The Navigation Pane contains buttons for each type of database object. To display a type of object, double-click the appropriate button.

Navigation Pane

1. Click the arrow button at the top of the Navigation Pane to change how objects are viewed in the pane.
   ✓ Tip: If the Navigation Pane is minimized, click the Shutter Bar Open/Close button to expand it.
   Only Table objects are displayed by default in a new database, but you can display all objects...

2. Select Object Type and make sure there’s a checkmark next to All Access Objects.
   Now you can see all the objects in the database.

✓ Tips
✓ In Access 2010, the Navigation Pane replaces the need for switchboards (forms with buttons that helped you navigate older versions of Access). If you’ve converted an old file that has switchboards, you can continue to use them, but some actions may no longer work in Access 2010.

Open a database object

   The object appears on the screen as a tabbed item.
   ❗ Other Ways to Open a Database Object:
   Right-click the object you want to open in the Navigation Pane and select Open from the contextual menu or, if you want to open it in design view for editing, select Design View.

✓ Tips
✓ When you open an object in Access 2010, it appears in the window with its own tab. As you open additional objects, they stack on top of each other in the same window. To bring a different object to the top where its visible, click its tab.

Exercise

- Exercise File: Employees.accdb
- Exercise: Open the Employees table in the Navigation Pane. View the Employees table in Design View. Close the Employees table (remember, this is different than closing the entire database).

Figure 2-1: Database objects in the Navigation Pane.

Figure 2-2: Changing how objects are viewed in the Navigation Pane.
Modify a database object in Design View

You can modify any database object by opening it in Design View. Design View displays the structure of a database object and allows you to make changes to it. You don’t have to know how to make changes to a database object yet, but you will need to know how to open an object in Design View. Here’s how:

1. With an object open, click the Home tab on the Ribbon and click View button list arrow in the Views group.

   Here you have a few different view choices.

2. Select Design View.

   The object appears in Design View where its structure can be modified.

   Other Ways to Open an Object in Design View:
   With the object open, right-click the object’s tab and select Design View from the contextual menu.

Tips

✓ You’ll learn more about additional types of views as you learn how to work with each type of object.

Close a database object

1. Click an object’s tab to display it, if necessary, then click the object’s Close button in the upper-right corner of the window.

   The object closes.

   Other Ways to Close a Database Object:
   Right-click the object’s tab in the window and select Close.

Tips

✓ To rename an object, right-click the object in the Navigation Pane and select Rename. Type a new name.

✓ To delete an object, select the object in the Navigation Pane and press <Delete>. Click Yes.
Tour of a Table

Tables are the heart and soul of any database. Tables are where a database stores all of its information. All the other database objects—queries, forms, reports, pages, macros, and modules—are merely tools to analyze and manipulate the information stored in a table. Any of these other database objects are optional, but without tables, a database wouldn’t be a database.

Each table in a database stores related information. Most databases have more than one table. Each table is used to store a different type of information. For example, one table might contain a list of customers and their addresses, while another table might contain any orders placed by the customers, while yet another table might contain a list of products.

Tables are made up of groups of fields (columns). A field is a specific type of information, such as a person’s last name, address, or phone number. Together, the related fields for each individual person, place, or thing make up a single record (row). If your company has ten employees, your employee table would have ten records—one for each employee.

Open a table

1. Double-click the table you want to open in the Navigation Pane.

   The table opens as a tab in the window. Table information is displayed, entered, and modified in a datasheet. A datasheet is a grid that contains all the records in a table. Records are stored in rows and field names are stored in columns.

   Tip: Of course, before you can open a table someone will need to have already created the table, or else you’ll need to be using a database template that already has tables created for you.

Navigate a table

Let’s take a closer look at the current table. First notice the squares that appear to the left of the table records. Each of these is a record selector, and is highlighted next to the record that you are currently working on.

Next, take a look at the record navigation buttons near the bottom of the screen, as shown in Table 2-1: Table Navigation Using the Record Navigation Bar. The record navigation buttons on the Record Navigation bar display the number of records in the current database and allow you to move between these records.

Exercise

• Exercise File: Employees.accdb
• Exercise: Open the Employees table in Datasheet View. Study and understand fields, record selectors and record navigation buttons.
Database Basics

Tips

✓ If a table has been “related” to another table, you will see expand buttons next to the records in the table. Click one to view information from the related table that is related to that record.

For example, if you have a table containing employee names, and that table is related to another table that lists the computers assigned to each employee, you could click on the expand button next to the employee and see the details of the computer assigned to that employee.

Table 2-1: Table Navigation Using the Record Navigation Bar

<table>
<thead>
<tr>
<th>Go to:</th>
<th>Navigation buttons</th>
<th>Keyboard</th>
<th>Mouse</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next record</td>
<td>Click the Next record navigation button.</td>
<td>Press the &lt;↓&gt; (down arrow) key.</td>
<td>Click the record you want to select (if displayed).</td>
</tr>
<tr>
<td>Previous record</td>
<td>Click the Previous record navigation button.</td>
<td>Press the &lt;↑&gt; (up arrow) key.</td>
<td>Click the record you want to select (if displayed).</td>
</tr>
<tr>
<td>Last record in the table</td>
<td>Click the Last record navigation button.</td>
<td>Press &lt;Ctrl&gt; + &lt;End&gt; (when not editing record).</td>
<td>N/A</td>
</tr>
<tr>
<td>First record in the table</td>
<td>Click the First record navigation button.</td>
<td>Press &lt;Ctrl&gt; + &lt;Home&gt; (when not editing record).</td>
<td>N/A</td>
</tr>
<tr>
<td>New blank record</td>
<td>Click the New (blank) record navigation button.</td>
<td>N/A</td>
<td>Click in the (New) row at the end of the table.</td>
</tr>
<tr>
<td>Search for record using keywords</td>
<td>Type a keyword in the Search box next to the navigation buttons.</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>
Adding, Editing and Deleting Records

You can easily add, change, or delete the records in your table. For example, you might want to add a record to store information about a new employee, change an existing record when an employee’s address changes, or delete a record for an employee who no longer works for the company. In this lesson you'll learn how to add, edit, and delete a table’s records.

Add a record

1. Click the **New Record** button on the Record Navigation bar.

   The record selector jumps to the blank row at the end of the table and the blinking insertion point (|) appears in the first column.

   **Other Ways to Add a New Record:**
   - If the New record row is in view, simply click in that row.

2. Click a field in the new record and enter data as desired.

   As you enter data, you don’t have to click a Save button to save the information—Access automatically saves the information as you enter it.

   **Tip:** Press `<Tab>` or `<Shift> + <Tab>` keys to quickly move between fields in a record.

Edit a record

You can also make changes to the records in a table at any time.

1. Click the field you want to edit and make the changes.

Delete a record

You can permanently delete records that you no longer need from a table.

1. Click the record selector next to the record you want to delete.

2. Click the **Home** tab on the Ribbon, click the **Delete** button in the Records group and click the **Yes** button.

   **Other Ways to Delete a Record:**
   - Click the record selector next to the record you want to delete. Press the `<Delete>` key. Click the **Yes** button.

---

**Exercise**

- **Exercise File:** Employees.accdb
- **Exercise:** Open the Employees table in Datasheet View. Go to the New record at the bottom of the table and enter your last name in the LastName field. Complete the rest of the fields in the record with your own information (enter today’s date for the hire date). Then edit the Title field for your record and change it to “Inside Sales Coordinator”. Delete the record you just created. Close the table.
Tour of a Form

Adding, viewing, and modifying information in a database should be straightforward and easy. However, information in a table is often difficult to understand and manage. Access solves this problem by using forms to display table and query data.

The forms in Access are actually quite similar to the ordinary paper type of form you fill out with a pen or pencil. Access forms have several major advantages over the traditional paper type of forms, however—they save you time, effort, and paper.

Forms can include fill-in-the-blank fields, check boxes, lists of options—even information and prompts to help users complete the form. Forms can also contain buttons that allow you to perform other actions, such as running macros to print reports or labels. Forms can even validate data entry by automatically checking your entries for errors.

There are a few different kinds of forms in Access 2010:

- **Form**: A traditional form view. In Layout view, you can edit the form design while also displaying data.

- **Split form**: Creates a split screen that allows you to view information through a Form view and Datasheet view at the same time. You can use the datasheet to locate a record and the form view to edit it.

- **Multiple items form**: Allows you to view multiple records at a time—unlike a regular form where you can only work with one record at a time. Looks much like a datasheet, but allows for more customization.

- **Other forms types**: You may also come across forms that look like datasheets, or Modal Dialog forms that pop out in their own dialog box windows (instead of appearing as tabbed items next to the other database objects in the main database window).

Open a form

1. Double-click the form you want to open in the Navigation Pane.

   The form opens in the window in Form view.

---

**Exercise**

- **Exercise File**: Employees.accdb
- **Exercise**: Open the Employees form. Click the Next Record button on the Record Navigation bar to go to the next record. Then click the New Record button and add your own name and information to complete the record. Make sure the record you just added appears in the form and then delete the record. Close the form.

![Figure 2-7: A form in Form View.](image-url)
Navigate a form
1. Use the record navigation buttons near the bottom of the screen.

Add a record
1. Click the New Record button on the Record Navigation bar.

   Some forms have only fill-in-the-blank style text fields and display only one record, while others are more complex and may display multiple records and contain lists, combo boxes, check boxes, or sub-forms. Some forms look just like a table datasheet.

2. Enter data as desired.

Delete a record
1. Click the record selector to the left of the record or form to select it.

2. Click the Home tab on the Ribbon and click the Delete button in the Records group.

   A dialog box appears, asking if you’re sure you want to delete the record.

3. Click Yes.

Tips
✓ A simple form may contain only fill-in-the-blank style text fields, but many forms are more complex and may contain lists, combo boxes, check boxes, and sub-forms.

Figure 2-8: The New Record button on the Record Navigation bar.

Figure 2-9: Deleting a record from a form in the Records group on the Home tab.
Tour of a Query

A query, by definition, is a question or inquiry. Queries in Access ask a question of the information in a table and then retrieve and display the results.

For example, if you wanted to know which employees had worked for the company for more than five years, you could create a query to examine the contents of the HireDate field to find all the records in which the hire date is more than five years old. Access would retrieve the information that meets your criteria and display it in a datasheet.

Let’s take a closer look at queries.

Open a query

1. Double-click the query you want to open in the Navigation Pane.

The query appears in the window in Datasheet view. You’ll notice that the layout of a query doesn’t look any different than a table—records appear in rows, fields appear in columns, and the record navigation buttons appear at bottom of the window. Some queries even allow you to add, edit, and delete records to and from the underlying tables. But, the information in a query isn’t a duplication of the data in a table—it’s just another way of looking at it.

Display a query in Design View

In Design View you can see a query’s underlying tables, which fields are included in the query, and the criteria used to specify which records to display.

1. Open the query, click the Home tab on the Ribbon and click the View button in the Views group. Select Design View.

The query appears in Design view. Here you can change the criteria and fields that filter the table data.

Other Ways to Open a Query in Design View:
- Right-click the query object in the Navigation Pane and select Design View. Or, click the Design View button in the Status bar.

Exercise

- Exercise File: Employees.accdb
- Exercise: Open the USA Employees query, which displays only employees from the USA, and display it in Design View. Select the “USA” text in the criteria box and replace it with “UK”. Display the query in Datasheet View. Notice that only UK employees appear. Close the query but don’t save the changes.
Tour of a Report

Managers like paper. Don’t try explaining anything to them—they’ll want to see it in printed hardcopy first. Fortunately, with a report, you can print database information from tables and queries and satisfy the demands of even the most paper-hungry supervisor.

Although you can print table and query information directly from their datasheets, reports give you many more formatting and display options. Reports can be a simple list of records in a table or a complex presentation that includes calculations, graphics or even charts.

Reports are the most static of all the database objects. Unlike tables and forms, which allow user interaction, reports just sit there, waiting to be printed.

In this lesson we won’t actually create a report, but you will learn how to use an existing report.

Open a report

1. Double-click the report you want to open in the Navigation Pane.

   The report appears in Report View.

   Tip: To edit a report’s structure, you need to change to Layout or Design View. Click the View button arrow in the Views group on the Home tab and select a view. Most edits can be made in Layout View, but complex tasks require Design View.

Figure 2-12: A report in Report View.
Previewing and Printing a Database Object

Most database objects—tables, queries, forms, and reports—and the information they contain can be printed. Sometimes it’s a good idea to preview a database object on screen to see if something needs to be changed before sending it to the printer. You can preview a database object by using the Print Preview feature.

Print Preview a database object

1. Make sure the object you want to preview is displayed. Click the File tab on the Ribbon, click Print, and select Print Preview.

   The object appears in the window as it will look when printed. The mouse pointer looks like a magnifying glass. You can zoom in or out on the previewed object by clicking the mouse.

   Other Ways to Print Preview a Report:
   Click the Home tab on the Ribbon, click the View button arrow in the View group, and select Print Preview. Or, click the Print Preview button on the Status bar.

2. Click the mouse to zoom in or out on the previewed object.

   If you no longer want to view the object in Print Preview View, you can close this view.

3. Click the Close Print Preview button on the Ribbon.

   The object returns to the view it was previously displayed in.

Print a database object

1. Make sure the object you want to print is displayed.

2. Click the File tab on the Ribbon and select Print.

3. Click Print.

   The Print dialog box appears. Table 2-2: Print Dialog Box Options describes the options available here.

3. Select any desired print options and click OK.

   Other Ways to Print:
   View the object in Print Preview View and click the Print button on the Print Preview tab. Click OK.

Exercise

• Exercise File: Employees.accdb
• Exercise: Open the Employee List report. Display the report in Print Preview and zoom in and out. Print the report (if you’re connected to a printer). Close the report.

Figure 2-13: A report in Print Preview View.

Table 2-2: Print Dialog Box Options

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Clicking on the Properties button displays a dialog box with options available to your specific printer such as the paper size you want to use, if your document should be printed in color or black and white, etc.</td>
</tr>
<tr>
<td>Print Range</td>
<td>Allows you to specify which pages you want printed. There are several options:</td>
</tr>
<tr>
<td></td>
<td>All: Prints the entire document.</td>
</tr>
<tr>
<td></td>
<td>Pages: Prints only the pages of the file that you specify. Select a range of pages with a hyphen (like 5-8) and separate single pages with a comma (like 3,7).</td>
</tr>
<tr>
<td></td>
<td>Selected Record(s): Prints only the text you have selected (before using the print command).</td>
</tr>
<tr>
<td>Number of Copies</td>
<td>Specify the number of copies you want to print.</td>
</tr>
</tbody>
</table>
Selecting Data

Often, before you can do anything in Access, you must select the data that you want to work with. Many common tasks such as editing, formatting, copying, cutting, and pasting all require you to know how to select information. The procedure for selecting text in Access is no different than selecting text in any other Microsoft Office program.

1. Move the insertion point to the beginning or end of the text you want to select.

2. Click and hold the left mouse button and drag the insertion point across the text, then release the mouse button once the text is selected.

Table 2-3: Data Selection Shortcuts describes several techniques for selecting data in Access.

Tips

✓ To replace text, select the text you want to replace, then type the new text with which you want to replace it.

Table 2-3: Data Selection Shortcuts

<table>
<thead>
<tr>
<th>To select:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A word</td>
<td>Double-click anywhere in the word.</td>
</tr>
<tr>
<td>A cell</td>
<td>Position the mouse over the left edge of the cell you want to select and click to select the cell.</td>
</tr>
<tr>
<td>A record or row</td>
<td>Position the mouse over the record selector and click to select the record. To select multiple records, drag down until you have highlighted all the records you want to select.</td>
</tr>
<tr>
<td>A field or column</td>
<td>Position the mouse over the name of the field you want to select and click to select it.</td>
</tr>
<tr>
<td>An entire table</td>
<td>Click the box to the far left of the field names.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Employees.accdb
- **Exercise:** Open the Employees table. In the first row of the Address column, select “Moss Bay Blvd.” (but not 722). Type “East River Road”. Practice using the record selectors to select rows and the field headers to select columns. Select the entire table. Close the table without saving changes.

Figure 2-14: Click, drag, and type to select and replace text in a table cell.

![Figure 2-14](image1)

Figure 2-15: Selecting rows of data in a table.

![Figure 2-15](image2)
Cutting, Copying and Pasting Data

You already know how to select database data. Once you have selected some text, a cell, a record—or even an entire database object in the Navigation pane—you can cut it, removing it from its original location, and then paste it in another location. Copying is similar to cutting, except the information is copied instead of removed. Whenever you cut or copy something, it is placed in a temporary storage area called the Clipboard. The Clipboard is available in any Windows program, so you can cut and paste between programs.

In Microsoft Access you can cut, copy, and paste any of the following items: Text, Records, Database objects (tables, queries, forms, and reports), or Controls (such as text boxes and labels on forms and reports).

Cut or copy

Cutting and copying both make a copy of selected information, but cutting also removes it from its original location.

1. Select the information you want to cut or copy.

2. Click the Home tab on the Ribbon and click the Cut or Copy button in the Clipboard group.

   Other Ways to Cut or Copy:
   Press <Ctrl> + <X> to cut or <Ctrl> + <C> to copy.

Paste

Once you’ve cut or copied something to the Clipboard, you can paste it to a new location.

1. Select the destination where you want to paste the information.

2. Click the Home tab on the Ribbon and click the Paste button in the Clipboard group.

   Other Ways to Paste:
   Press <Ctrl> + <V>.

Tips

✓ If you are entering a lot of records that are similar, you can copy and paste entire records to create records quickly. Then you can edit the new records to make a few changes. To copy a record, select the record’s row selector, copy the record, select an empty row for the new record, and paste the copied record.

Figure 2-16: Copying and pasting table data.
You can also copy objects from one database to another. Copy the database object, open the destination database, and paste the copied object into the other database.
Using Undo and Redo

*Undo* undoes any previous actions as though they never happened. But, it’s important to note that the Undo feature in Access isn’t nearly as powerful as it is in other Microsoft Office programs. Because Access saves updates to data automatically, if you make a mistake and don’t catch it right away, chances are you won’t be able to use Undo to correct it. For example, if you’re editing the text in a field and make a mistake, you’ll want to undo it before you click out of the field and Access saves the change.

If that weren’t bad enough, Access can’t even undo many actions! For example, if you delete a record and then decide you want to use Undo to retrieve the record, you’re out of luck. (To its credit, Access does warn you whenever you delete a record that you will not be able to use Undo to bring it back.)

**Undo a single action**

1. Click the **Undo** button on the Quick Access Toolbar.

Your last action is undone. For example, if you had deleted text in a field and then decided you wanted to keep it after all, undo would make it reappear (if you hadn’t already clicked out of the field).

**Other Ways to Undo:**

Press `<Ctrl>` + `<Z>`.

**Undo multiple actions**

1. Click the **Undo** button list arrow on the Quick Access Toolbar.

A list of the last actions in Access appears. To undo multiple actions, point to the command you want to undo. For example, to undo the last three actions, point at the third action in the list. Each action done before the one you select is also undone.

2. Click the last action you want to undo in the list.

The command you select and all subsequent actions are undone.

**Redo an action**

*Redo* is the opposite of undo: it redoes an action you have undone.

---

**Exercise**

- **Exercise File:** Employees.accdb

- **Exercise:** Open the Employees table. Change Robert King’s last name to “Queen”, then undo the action. Close the table without saving.
1. Click the **Redo** button on the Quick Access Toolbar.

   - **Other Ways to Redo an Action:**
     - Press `<Ctrl> + <Y>`. 
Checking Your Spelling

You can use the spell checker in Access to find and correct any spelling errors that you might have made in your tables and forms. The spell checker in Access is shared and used by the other programs in the Microsoft Office suite, so any words you add to the custom spelling dictionary in one Microsoft Office program will be available to the other Microsoft Office programs.

⚠️ Trap: Unfortunately, spell checking in Access is not nearly as useful as it is in a word processor. Most databases contain names, addresses, and information that the spell checker may not recognize. When this happens, click either Ignore to ignore the word or Add to add the word to the custom spelling dictionary.

1. Open a table or form. Click the Home tab on the Ribbon and click the Spelling button in the Records group.

   The Spelling dialog box appears and Access begins checking spelling.

   ✔️ Tip: Click the Ignore Field button to ignore an entire field (column). For example, if the field contains proper names and you don’t want Access to check every name individually.

   🔄 Other Ways to Check Spelling:
   - Press <F7>.

   If Access finds an error, the Spelling dialog box appears with the misspelling in the “Not in Dictionary” text box. You have several options to choose from in the Spelling dialog box:

   • Ignore Field: Accepts the spelling for that entire field (column) and moves on to the next spelling error. This is useful if, for example, the field contains proper names and you don’t want Access to check every name individually.

   • Ignore: Accepts the spelling and moves on to the next spelling error.

   • Ignore All: Accepts the spelling and ignores all future occurrences of the word in the worksheet.

   • Add: If a word is not recognized in the Microsoft Office Dictionary, it is marked as misspelled. This command adds the word to the dictionary so it is recognized in the future.

   • Change: Changes the spelling of the word to the spelling that is selected in the Suggestions list.

   • Change All: Changes all occurrences of the word in the worksheet to the selected spelling.

Exercise

• Exercise File: Employees.accdb

• Exercise: Open the Employees table and check spelling. Choose to ignore the LastName field and then the Address field. Choose to change the spelling of “Londan” to “London”. Ignore any remaining words. Save and close the table.

Figure 2-18: The Spelling dialog box.
**Trap:** Exercise caution when using this command—you might end up changing something you didn’t want to change.

- **AutoCorrect:** Changes the spelling of the word to the spelling that is selected in the Suggestions list, and adds the misspelled word to the AutoCorrect list so that Access will automatically fix it whenever you type it in the future.

2. If the word is spelled incorrectly, select the correct spelling from the Suggestions list. Then click **Change**, **Change All**, or **AutoCorrect**. If the word is spelled correctly, click **Ignore Field**, **Ignore**, **Ignore All**, or **Add**.

   Access applies the command and moves on to the next misspelling.

   Once Access has finished checking your table or form for spelling errors, a dialog box appears, telling you the spelling check is complete.

3. Click **OK**.

   The dialog box closes.

**Tips**

- Access cannot catch spelling errors that occur because of misuse. For example, if you entered the word “through” when you meant to type “threw,” Access wouldn’t catch it because “through” is a correctly spelled word.

- The AutoCorrect feature automatically corrects commonly misspelled words for you as you type. For example, it will change “hte” to “the,” “adn” to “and,” and so on.
Using the Zoom Box

When you are viewing and working with data, sometimes a column will not be wide enough to display all the text in a cell or field. This is especially true for notes and memo fields, which may contain several paragraphs of text. Don’t worry—you can summon the Zoom box to make the contents of any field easier to view and edit.

1. Select the field you want to zoom in on and press `<Shift> + <F2>`. The Zoom box appears and displays the contents of the selected field. You can edit the field’s information in the Zoom box. When you’re finished viewing or editing the field…

2. Click OK to close the Zoom box.

The field will display any changes you made to the data.

---

**Exercise**

*Exercise File:* Employees.accdb

*Exercise:* Open the Employees table. Using the Zoom box, zoom in on the Notes field for any record. Close the Zoom box and the table.

---

*Figure 2-19:* Zooming in on the Notes field with the Zoom box.
Exiting Access 2010

When you’re finished using a database, you should close it. When you close a database, however, the Access program doesn’t stop running. To stop using Access completely, you need to exit the program.

Close a database

1. Click the File tab and select Close Database.

The database closes.

Exit Access

1. Click the File tab and click the Exit button.

   Tip: You may be prompted to save changes before exiting. If so, click Yes.

The Access program closes.

Other Ways to Exit Access:
Click the Close button on the title bar (if a database is still open, it will close this as well).

Tips

✓ Having too many programs open at a time could slow down your computer, so it’s a good idea to exit all programs that aren’t being used.

Exercise

- Exercise: Exit the Microsoft Office Access 2010 program.

Figure 2-20: Two ways to exit Access.
Database Basics Review

Quiz Questions

11. You access database objects using the Navigation Pane. (True or False?)

12. The related fields for each person, place, or thing make up a single _______.
   A. Record
   B. Table
   C. Column
   D. Field

13. To add a new record to a table, you can simply click in the New record row and enter the data. (True or False?)

14. You can view records in a form; however, you cannot change them in any way. (True or False?)

15. A query would be suitable for which of the following?
   A. Displaying invoices that are more than 30 days old.
   B. Calculating last year’s sales
   C. Adding records to a table.
   D. All of these tasks.

16. Which of the following statements is NOT true?
   A. Reports present information from a table or query in printed form.
   B. Reports make it easy to add table information.
   C. You can edit a report’s structure.
   D. You can zoom in and out of a report.

17. Which of the following is NOT a Print dialog box option.
   A. Number of Copies
   B. Properties
   C. Preview
   D. Print Range

18. Once you have selected some text, you can replace it with new text by:
   A. Simply typing the new text.
   B. Clicking the New Text button on the Home tab.
   C. You can’t replace selected text with new text.
   D. Clicking the Replace Text button in the Navigation Pane.

19. What is the keyboard shortcut to paste information?
   A. Ctrl + V
   B. Ctrl + C
   C. Ctrl + P
   D. Ctrl + X
20. The keyboard shortcut to undo an action is Ctrl + Z. (True or False?)

21. Access will automatically mark any spelling errors you make with red underlining. (True or False?)

22. To use the Zoom box, select the field you want to zoom and _________.
   A. Press Shift + F4.
   B. Press Shift + F2
   C. Click the Zoom button on the Quick Access Toolbar.

23. Closing a database and exiting Access are the same thing. (True or False?)

**Quiz Answers**

11. True. You use the Navigation Pane to access database objects.
12. A. The related fields for each individual person, place, or thing make up a single record.
13. True. If the New row is visible at the bottom of the window, simply enter your data.
14. False. You can view, add, edit, and delete records in a form.
15. D. Queries can do all of these tasks.
16. B. You can view table information, but you can't add, edit, or change it.
17. C. Preview is not an option in the Print dialog box.
18. A. Simply type the new text to replace any selected text.
21. False. That is a feature available in Microsoft Word, but not Access.
22. B. Press Shift + F2 to zoom in on the field.
23. False. Closing a database closes the open database, but exiting Access closes the program itself.
Creating and Working with a Database

Planning a Database ........................................... 48
Creating a New Database................................. 50
  Create a database from a template........... 50
  Create a new blank database ............... 51
  Create a new blank database .............. 51
Creating a Table .................................................. 52
  Create a table using a template .......... 52
  Create a table in Design View .......... 53
  Create a table in Datasheet View .... 53
Modifying a Table.................................................. 54
  Display a table in Design View .......... 54
  Add a field in Design View ............. 54
  Change a field's data type .......... 54
  Save table structure changes .......... 54
Creating a Query ................................................. 56
  Create a query in Design View .......... 56
Sorting a Query...................................................... 58
Using AND and OR Operators in a Query .... 59
Creating a Form with the Form Wizard .... 60
Creating a Report with the Report Wizard ..... 62
Creating Mailing Labels with the Label Wizard
................................................................. 64
Converting an Access Database ............... 66
  Convert a database to Access 2010 ...... 66
  Convert from Access 2010 to an earlier file format .............. 67

Stop typing lists of information in Microsoft Word or Excel! In this chapter, you will learn how to create databases that can store names, addresses, and any other type of information that you can think of. You will be pleasantly surprised to find that creating a database isn’t all that difficult. Access even includes several wizards and templates to help you out.

Because there are so many components that constitute a database, this chapter will cover a lot of ground—but thankfully not in great detail. In this chapter, you will learn to create and modify the major database objects: tables, forms, queries, and reports. You will also learn how to create mailing labels and how to convert a database to a different version.

If all you need is a simple, easy-to-use database, look no farther than this chapter—more than likely, everything you need to know about creating databases is here.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Planning a Database

Although you can always make changes to a database, a little planning ahead before you create a database can save you lots of time and headaches later on.

Consider Figure 3-1: Examples of database design. In the first table you can only sort by the name or address field. If you sort the name field, the sort is performed by the first name. If you sort by the address field, the sort is performed by the street—you cannot sort by city, state, or zip code. You couldn’t create a query or filter that only displays people from a particular state because the states are not stored in their own field. The fields are not flexible.

Now take a look at the second table. Here you can sort records by first name, last name, address, city, state, and zip code. You can also query and filter records using any of these fields. Here are some guidelines for creating a well-designed database:

- **Determine the purpose of the database**
  The best way to do this is to write down a list of the reports and lists that you want to come out of the database. This may seem a little backward at first, but if you think about it, these reports are really the reason you’re creating the database. Make a list of the reports and lists you want to see and then sketch some samples of these reports and lists—be as detailed as possible. This will help determine the tables and fields to include in your database.

- **Determine the fields you need**
  This should be an easy step once you have determined the purpose of your database and have sketched some sample reports and lists. Think about the data type for each type of your fields—Will the field store text information? Numbers? Dates? Write down the data type next to each field.

- **Determine the tables you need**
  Each table in the Database should be based on only one subject. By breaking each subject into its own table you avoid redundant information and make the database more organized. Look at the second database in Figure 3-1: Examples of database design. It is broken down into two tables, Customers and Invoices, so there isn’t any duplicated data. When you brainstorm, try to break down your information as much as possible. If your tables contain fields like Item 1, Item 2, Item 3, Item 4, and so on, you should probably break the information up into its own table.
Creating and Working with a Database

- **Determine the primary key**
  Each record in a table should have a primary key that uniquely identifies it. When you think about a primary key field, think unique—each primary key value must be the only one of its kind in a table. A customer ID or invoice number would be two good examples of fields that could be used as a table’s primary key.

- **Determine the relationship between tables**
  Look at Figure 3-1: Examples of database design. The ID field links the Customers and Invoices tables together. One of the linked fields should be the table’s primary key.

- **Sketch a diagram of your database**
  Create a diagram of your database. Draw a box for each of your tables and write the table’s field names inside that box. Draw a line between the related fields in the tables. For example, look at Figure 3-1: Examples of database design. Each record in the Customers table is related to one or more records in the Invoices table.

<table>
<thead>
<tr>
<th>Table 3-1: Guidelines for Good Database Design</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Each field or column should contain the same type of information</strong></td>
</tr>
<tr>
<td><strong>Try to break up information as much as possible</strong></td>
</tr>
<tr>
<td><strong>Use multiple tables so that you don’t duplicate information in the same table</strong></td>
</tr>
<tr>
<td><strong>Don’t use duplicate field names</strong></td>
</tr>
</tbody>
</table>
Creating a New Database

When you start Access, you are provided with three main options for creating or opening a database:

- **New Blank Database**: Create a new blank database from scratch for storing information.

- **Templates**: Select a template stored locally on your computer or from Office Online. Several categories of templates are available: Featuring, Local Templates, Business, Education, Personal, and Sample. Within the categories are different types of templates—for example: Assets, Contacts, and Projects.

- **Recent Database**: Open an existing database from a list of recently opened databases or click the More link to browse your computer or network for more existing databases.

In this lesson, we’ll look at how to create a new database from a template, as well as from scratch.

**Create a database from a template**

The easiest way to create a database is by using one of the built-in database templates. A database template saves you time and effort, providing you with ready-to-use tables, forms, queries, and reports. There are templates available for the most common types of databases, such as contact management, inventory, and order taking. Once you create a database with an Access template you can modify it to better suit your needs.

1. Once Access is open, click a **template category** button in the Available Templates section.
   
The templates for that category appear on the page.

2. Click **template** button for the template you want to use.
   
The right side of the screen changes to display information about that type of database.
   
   ✅ **Tip**: Here you can give the new file a name of your choosing. Access displays the file path to the location where your file will be saved, but you can change the location.

3. Click the **Create** or **Download** button.
   
   ✅ **Tip**: If the template is a saved locally on your computer, you will click Create. If it is an online template, you will need to click Download so that Access can retrieve the template from the Microsoft Web site.
   
The database appears in the window.
Create a new blank database

The advantage of creating a blank database is that it gives you the most flexibility and control over your database design. The disadvantage of creating a blank database is that you have to create every table, form, report, and query yourself.

1. Once Access is open, click the Blank Database button in the Available Templates section.

   🔄 Trap: You may need to expand your window to see the Blank Database button.

   The right side of the screen changes to display information about creating a blank database.

   🔄 Other Ways to Create a New Blank Database:
   Click the File tab and select New.

2. Enter a name for the new database file in the File Name text box.

   Access displays the file path to the location where your file will be saved, but you can change the location.

3. Click the Create button.

   Access creates a new blank database and creates a single blank table where you can start storing data.
Creating a Table

In Access 2010 you have a number of options when creating tables. You can create a new blank table from scratch or set up tables that are connected to SharePoint lists. If you use one of the Quick Start options in the Application Parts to create a new database, tables with predefined fields will be created.

Create a new blank table

Creating a new blank table allows you to immediately start entering your data into the table.

1. Click the Create tab on the Ribbon and click the Table button in the Tables group.
   The table appears in the window in Datasheet View. In this view, you can start entering data right away. However, it’s usually smart to first add some fields using the Field Templates pane. The Field Templates pane contains many common fields that are preformatted with the correct data type.

2. To add a new field, click the Click the Add field heading and select the field type for the list that appears.

3. Once you have selected the field type, the new field will automatically be named in numerical order – Field1, Field2, Field3, etc.
   The field name will be selected – simply type in a new, more appropriate name for your data field.

4. Click in the field to enter the correct data for this particular field, or click the next Click to Add field heading to add another field.

Tips

✓ Another method to add a new field, is click the correct data type in the Add & Delete group on the Format tab under Table Tools. The new field will be added to the left of the currently selected field.
✓ To change a field’s data type, right-click the field heading and select the correct data type..

Tips

✓ To change the name of a field header, double-click the field header and type the field name you want to use.
Create a table in Design View

The most straightforward way to build a table from scratch is using Design View, where adding fields to a table and specifying their data types is not much different than basic data entry.

1. Click the Create tab on the Ribbon and click the Table Design button in the Tables group.

   A new table appears in the window in Design View. Now all you have to do is add the fields you want included in the table.

2. Enter a field name in the Field Name column, then click the Data Type list arrow and select a data type for the field. Repeat as desired.

Create a SharePoint list table

SharePoint lists can be created within Access 2010. To do this, you need to have an existing SharePoint site that you can add the SharePoint list too.

1. Click the Create tab on the Ribbon and click the SharePoint Lists button in the Tables group.

2. Select the relevant type of list you want to create – either Contacts, Tasks, Issues or Events.

   Select Custom if you wish to specify your own fields or choose Existing SharePoint List if you want to link to a list that has previously been created on the SharePoint site.

3. Enter the SharePoint URL address, a name for the new list and any further information before clicking OK.
Modifying a Table

Once you have created a table, you can modify it later by adding, deleting, and modifying its fields.

In this lesson, we’ll look at how to work with views, fields and data types.

Display a table in Design View

1. Open the table in Datasheet View. Click the Home tab on the Ribbon and click the View button in the Views group and select Design View.

Other Ways to Do Something:
Right-click the table in the Navigation Pane and select Design View from the contextual menu.

The table appears in Design View. Here you can add, delete, or modify the table’s structure and fields.

Add/modify a field in Design View

1. In Design View, enter or edit a field name in the Field Name column, click in the Data Type column for that row, click the Data Type list arrow and select a data type for the field. Repeat as desired.

Change a field’s data type

Because there are so many different types of data, Access offers several different types of fields. A field’s data type determines the type of information that can be stored in a field. A field’s data type restricts what type of information you can enter in a field. For example, you cannot enter text into a number field.

1. Display the table in Design View.

2. Click the field’s Data Type box, click the list arrow, and select a data type from the list.

Table 3-2: Table Field Data Types provides descriptions of the different data types.

Other Ways to Modify a Table:
You can add fields and change data types in Datasheet view by using the Add & Delete options on the Fields tab under Table Tools.

Save table structure changes

Access automatically saves your work as you add or edit data, but when you make a change to an object’s structure—such as adding a field to a table—you’ll want to save the change.
Creating and Working with a Database

1. Click the **Save** button on the Quick Access Toolbar.

   **Tip:** If you try to leave the window before saving, Access will prompt you to save your work. Click **Yes**.

   **Other Ways to Save:**
   Press `<Ctrl> + <S>`.

<table>
<thead>
<tr>
<th>Table 3-2: Table Field Data Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Type</td>
</tr>
<tr>
<td>-----------</td>
</tr>
<tr>
<td>Text</td>
</tr>
<tr>
<td>Memo</td>
</tr>
<tr>
<td>Number</td>
</tr>
<tr>
<td>Date/Time</td>
</tr>
<tr>
<td>Currency</td>
</tr>
<tr>
<td>AutoNumber</td>
</tr>
<tr>
<td>Yes/No</td>
</tr>
<tr>
<td>OLE Object</td>
</tr>
<tr>
<td>Hyperlink</td>
</tr>
<tr>
<td>Attachment</td>
</tr>
<tr>
<td>Calculated</td>
</tr>
<tr>
<td>Lookup Wizard</td>
</tr>
</tbody>
</table>
Creating a Query

You can create a simple query in Design View or by using the Query Wizard.

Create a query in Design View

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.
   The Show Table dialog box appears.

   Other Ways to Create a Query:
   You can also use the Query Wizard to create a query. Click the Create tab on the Ribbon and click the Query Wizard button in the Queries group. Follow the onscreen instructions to create the query.

2. Select the table you want to add to the query and click Add.

3. Repeat Step 2 as necessary for additional tables or queries, and click Close.
   The Query window appears in Design View. Notice that the window is split. The top half contains a box that displays all the fields in the table you added to the query. The bottom half of the screen contains a design grid, which is where you will add the fields you want to appear in your query.

4. In the field list, double-click each field you want to include in the query.
   Often you will have to use the field list’s scroll bar to scroll up or down the list in order to find a field.
   Now you need to specify any criteria for the query. You enter the criteria in the design grid’s Criteria row. For example, you could select to see only records whose City field contains “London”, or you could enter K* to return only results that begin with K.

   Table 3-3: Common Criteria Operators displays some common criteria operators you can use.

   Other Ways to Add a Field to a Query:
   Drag the field from the field list onto the design grid.

5. In the design grid, enter any desired search criteria for the field in the Criteria box.
   Tip: If you want to use a field in the query, but you don’t want it to be displayed in the query results, uncheck the Show box for that field.

Exercise

- Exercise File: Customers.accdb
- Exercise: Create a new query in Design View to display the first and last name of those employees who are from London. Add the Employees table in the Show Table dialog box. Add the LastName, FirstName, and City fields to the design grid. Type “London” in the City column’s criteria row. Click the Show box for the City column to uncheck it. Save the query as “London Query”. Run the query. Display the query again in Design View. Delete the City column and add the Region column. Type “WA” in the Region column’s criteria row. Move the FirstName field in front of the LastName field. Run the query again. Close the query without saving the changes.
6. Click the **Save** button on the Quick Access Toolbar, enter a name for the query in the Save As dialog box and click **OK**.

   The query is saved and now appears in the Navigation Pane.

   Let’s run the query.

7. Click the **Design** tab under Query Tools on the Ribbon and click the **Run** button in the Results group.

   The query runs and the results appear in Datasheet View.

   **Other Ways to Run a Query:**
   Switch to Datasheet View.

   **Tips**
   ✓ To delete a query field in Design View, click the top of the field you want to delete and press `<Delete>`.

   ✓ To rearrange fields in Design View, click just above the field name in the design grid to select the field. Then click and drag the field to a new location.

### Table 3-3: Common Criteria Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>=</code></td>
<td><code>=&quot;MN&quot;</code></td>
<td>Finds records equal to MN.</td>
</tr>
<tr>
<td><code>&lt; &gt;</code></td>
<td><code>&lt;&gt;&quot;MN&quot;</code></td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td><code>&lt;</code></td>
<td><code>&lt;10</code></td>
<td>Finds records less than 10.</td>
</tr>
<tr>
<td><code>&lt; =</code></td>
<td><code>&lt;=10</code></td>
<td>Finds records less than or equal to 10.</td>
</tr>
<tr>
<td><code>&gt;</code></td>
<td><code>&gt;10</code></td>
<td>Finds records greater than 10.</td>
</tr>
<tr>
<td><code>&gt; =</code></td>
<td><code>&gt;=10 AND &lt; &gt;5</code></td>
<td>Finds records greater than or equal to 10 and not equal to 5.</td>
</tr>
<tr>
<td><strong>BETWEEN</strong></td>
<td><strong>BETWEEN 1/1/07 AND 12/31/07</strong></td>
<td>Finds records between 1/1/07 AND 12/31/07.</td>
</tr>
<tr>
<td><strong>LIKE</strong></td>
<td><em><em>LIKE &quot;S</em>&quot;</em>*</td>
<td>Finds text beginning with the letter “S.” You can use LIKE with wildcards such as <code>*</code>.</td>
</tr>
</tbody>
</table>
Sorting a Query

Tables normally display records in the order they were entered. Instead of working with a table’s jumbled record order, you can create a simple query that sorts the table information and presents it in an ordered, easy-to-read display. You can sort records alphabetically, numerically, or chronologically (by date) in ascending (A to Z) or descending (Z to A) order. You can also sort by multiple fields—for example, you could sort by LastName and then by FirstName. This lesson will show you how you can use a query to sort information in a table.

1. Display the query in Design view.

2. Add the field you want to use to sort the query to the design grid, along with any other fields you want to appear in the query results.

   Tip: Double-click the asterisk at the top of a field list to add all the table’s fields to the design grid at once.

   To sort a query, click the Sort row for the field you want to use to sort the query and select either Ascending or Descending.

3. Click the Sort list arrow for the first field you want to use to sort the query, then select either Ascending or Descending.

4. Repeat Steps 2-3 for each additional field you want to use to sort the query, bearing in mind that the fields will be sorted from left to right.

   Tip: If you want to use a field to sort the table, but you don’t that field to appear, you can uncheck it’s “Show” box.

5. Save and run the query.

Exercise

- Exercise File: Customers.accdb
- Exercise: Create a new query in Design View to sort employee information. Use the Employees table. Double-click the asterisk in the Employees field list to add all the fields to the design grid. Then add the LastName and FirstName fields to the design grid separately (we’ll be using them to sort the query). Click the list arrow in the LastName field’s Sort box and select Ascending. Repeat for the FirstName field. Uncheck the Show box for the LastName and FirstName fields. Save the query as “AZ Query” and run the query.

Figure 3-12: Sorting a query in Design View.

Figure 3-13: Sorted query results.
Using AND and OR Operators in a Query

The longer you work with Access, the more you will want to analyze your data. Before long you will want to create queries that match two or more conditions, such as “Which people have bought our products AND live in Michigan?” You might also want to create a query that matches only one of several conditions, such as “Which people have bought our beach balls OR water rafts?”

To that end, this lesson introduces AND and OR operators:

- **AND** narrows your query, making it more restrictive. For example, you could filter for employees who are from Washington AND who have been with the company for more than five years. To create an AND query, enter the criteria for the fields on the same Criteria row of the design grid.

- **OR** relaxes your query, so that more records match. For example, you could filter for employees who are from California OR Minnesota. To create an OR query, enter the criteria for the fields on different Criteria rows of the design grid.

**Use AND or OR criteria in queries**

1. Display the query in Design View.

2. Enter your criteria in the appropriate field’s first Criteria box.

3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more fields in the appropriate field’s “Criteria” box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more fields in the appropriate field’s “or” box, using a different row for each OR criteria.

4. Save and run the query.

---

**Exercise**

- **Exercise File**: Customers.accdb
- **Exercise**: Open the Customers List query in Design view. Let’s query the customers who are owners AND from France. Click the ContactTitle column’s Criteria row and type “Owner”. Click the Country column’s Criteria row and type “France”. Run the query. Now let’s query customers from France OR Mexico. In Design View, delete the “Owner” criteria from the ContactTitle Criteria row. In the Country column, click the second Criteria row and type “Mexico”. Run the query. Save the query.

**Figure 3-14**: An AND query and its results.

**Figure 3-15**: An AND query and its results.

Creating and Working with a Database
Creating a Form with the Form Wizard

You will usually want to use the Form Wizard to create your forms. It’s almost always easier to create and modify a form created by the Form Wizard than it is to create one from scratch. This lesson will show you how to use the Form Wizard to create a form.

1. Click the Create tab on the Ribbon, click the Form Wizard button in the Forms group.

   The Form Wizard appears. Anytime you create a form, you have to tell Access which table or query you want to use for your form.

2. Click the Tables/Queries list arrow and select the table or query you want to use to create your form.

   Now that you have specified the table, you need to tell the Wizard which fields you want to display on the form. To add a field to the form, you can either double-click the field or select the field and click the right arrow button.

3. Double-click the fields that you want to appear on the form. Click Next when you’re finished.

   Tip: If you selected fields from more than one table, the Form Wizard would ask how you would like to organize the data on your form. Make a selection and click Next.

   Next the Form Wizard asks how you want to lay out the data on the form. Your options will depend on what fields and tables you’re using, but may include these options:
   - **Columnar:** Displays one record at a time in an easy-to-read format.
   - **Tabular:** Displays many records at a time.
   - **Datasheet:** Displays many records at a time and looks exactly like a table in Datasheet view.
   - **Justified:** Displays one record at a time in a format similar to a tax return—interesting, but it usually creates complicated forms that are difficult to work with.

4. Select the layout you want to use for the form and click Next.

5. Enter a title for your form in the text box and select to either open the form or modify the form’s design. Click Finish.

Exercise

- **Exercise File:** Customers.accdb
- **Exercise:** Use the Form Wizard to create a form with the Employees table. Add the LastName, FirstName, Title, Address, City, Region, PostalCode, and Country fields to the report. Leave the Columnar layout option selected and name the form “Employees Form”. View the form.
The form appears in the window. In the form, you can add, edit, and delete records, just like in a table—except that you usually only see one record at a time.

Figure 3-18: A form created with the Form Wizard.
Creating a Report with the Report Wizard

It’s almost always easier to create and modify a report created by the Report Wizard than it is to create one from scratch.

1. Click the **Create** tab on the Ribbon and click the **Report Wizard** button in the Reports group.

2. Click the **Tables/Queries** list arrow and select the table or query you want to use to create your report.

   Now that you have specified the table, you need to tell the Wizard which fields you want to display on the form. To add a field to the form, you can either double-click the field or select the field and click the right arrow button.

3. Double-click the fields that you want to appear on the form. Click **Next** when you’re finished.

   **Tip:** If you selected fields from more than one table, the Form Wizard would ask how you would like to organize the data on your form. Make a selection and click **Next**.

   Then the Report Wizard asks you if and how you want to group the data in your report. For example, you can group all the customers from the same country together in your report. Grouping can help organize and summarize the information in your report. To use a specific field to group data, double-click the field you want to use.

4. Double-click any fields you want to group, in the order you want to group them. Click **Next**.

   **Tip:** Once you’ve added fields to group by, you can move them around by using the Priority arrow buttons.

   Next the Report Wizard asks if you want to sort the records in your report.

5. Click the list arrows and select fields to sort by and click **Next**.

   You can sort by up to four fields.

   **Tip:** Click the button to the right of each list to toggle between ascending and descending sort orders.

   Now the Report Wizard asks how you want to lay out the data on the report. You can also specify the page orientation here. Layout options Stepped, Block and Outline. You can select a Layout option to preview it.

   **Exercise**
   - **Exercise File:** Customers.accdb
   - **Exercise:** Use the Report Wizard to create a report with the Customers table. Add the CompanyName, ContactName, Address, City, and Country fields to the report. Group the report data using the Country field. Sort the report based on the CompanyName field. Leave the Stepped layout and Portrait orientation options selected. Name the report “Customers by Country” and preview the report.
6. Select a Layout option and an Orientation option for the report, then click **Next**.

Finally, you need to give the report a name.

7. Enter a name in the text box and select whether you want to preview the report or modify its design. Click **Finish**.

If you chose to preview the report, it appears in Print Preview view. If you chose to modify the report, it appears in Design view, where you can make changes to its structure.

![Figure 3-22: A report created with the Report Wizard.](image)
Creating Mailing Labels with the Label Wizard

For bulk mailings, nothing beats a good stack of mailing labels. The Access Label Wizard helps you quickly create labels using data from your Access database. The Label Wizard supports a huge variety of label sizes and brands. In this lesson, you will use the Label Wizard to create a set of mailing labels.

1. Open the table or query that contains the data for your labels.
   For example, a Contacts table that contains names and addresses is a common table for making labels.

2. Click the Create tab on the Ribbon and click the Labels button in the Reports group.
   The Label Wizard dialog box appears, listing the various types of labels by product number. Simply scroll down and find the number that matches the one on your label box.
   Tip: If you can’t find your label type, click the Customize button and tell the Label Wizard how to set up your nonstandard labels.

3. Click the Filter by manufacturer list arrow and select your label’s manufacturer, then select the correct label size from the list. Click Next.
   The next window of the Label Wizard lets you change the font used in your label. You can format the font type, size, weight, and color. If you’re satisfied with the default font (Arial 8 point), you can simply click Next.

4. Select the font and font formatting options you want to use for your label and click Next.
   It’s time to tell the Label Wizard which fields you want to use.
   If you want to place fields on separate rows, you’ll need to press <Enter> in the Prototype label area to move to the next row before inserting the field.
   Also, if you want certain text to appear on every label—such as comma between the city and state—you can type the text in the Prototype label area.

5. Select each field you want to use from the list and click the arrow button. Click Next.
   Next you can determine the order of your labels by sorting.

---

Exercise

- Exercise File: Customers.accdb
- Exercise: Use the Labels Wizard to create labels using the Customers table. Select the default label size, font and color. Add the ContactName, CompanyName, and Address fields on separate lines of the prototype label. On the next line down, enter the City, Region, and PostalCode fields. Separate the City and Region with a comma and add necessary spaces between the fields. Sort the labels by PostalCode and name the label report “Customer Labels”. View the labels on the screen.

Figure 3-23: Selecting label size in the Label Wizard.

Figure 3-24: Adding fields to the prototype label.
6. Select the field you want to sort by from the list and click the **right arrow** button to add it to the Sort by area. Click **Next**.

✔ **Tip:** You can sort by multiple fields if desired.

Finally, you can give your label report a name (when you’re making labels, you’re really just creating a report).

7. Enter a name in the text box and select whether you want to preview the report or modify its design. Click **Finish**.

If you chose to preview the report, it appears in Print Preview view. If you chose to modify the report, it appears in Design view, where you can make changes to its structure.

The labels report is saved for you. You can now print the labels at any time by simply loading the printer with labels and printing the report.

---

**Figure 3-25:** Labels created with the Label Wizard.
Converting an Access Database

If you’re working with a database created in a previous version of Access (.mdb), you can convert it to the 2007/2010 file format (.accdb) to take advantage of the new features.

On the other hand, if you’ve created a database with the Access 2007/2010 file type (.accdb), but you want to share it with people using earlier versions of Access, you can usually convert it to an earlier file format by saving it as a different file type.

In this lesson, we’ll look at both scenarios.

Convert a database to Access 2010

To convert a file to the Access 2010 format, you need to open the file in Access 2010 and Save As with the 2010 file format.

Trap: An Access 2010 file (.accdb) can only be opened in Access 2007/2010 and not earlier versions of Access so make sure everyone who uses the file is running the correct version before you convert it.

1. In Access 2010, click the File tab and click Open.

   The Open dialog box appears. Here you need to select the database you want to convert to Access 2010 format.

2. Select the database you want to convert and click Open.

   Trap: If you see the Database Enhancement dialog box, the database is in a file format earlier than Access 2000. See the Access Help files for help converting this type of file.

   The database opens.

3. Click the File tab, point to Save & Publish, and select the Access Database (.accdb) file format in the “Save Database As” area.

4. Click the Save As button.

   Tip: If you have any open database objects, you’ll see a message telling you to close them. Click Yes. If Access is unable to convert the file, you’ll also see that message at this point.

   The Save As dialog box appears.

Exercise

- Exercise File: Customers.accdb
5. Enter a name for the database in the File name box and click Save.

A copy of the database is made and the copy is opened. The original database is closed.

**Convert from Access 2010 to an earlier file format**

ℹ️ Trap: Not all Access 2010 files can be converted to an earlier format. If the database contains new 2010 features such as attachments, multi-valued fields, offline data, or links to some external files, Access may not be able to convert the file.


1. Open the Access 2010 file you want to convert, click the File tab, point to Save & Publish, and select the Access 2002 – 2003 Database (.mdb) or Access 2000 Database (.mdb) file format in the “Save Database As” area.

2. Click the Save As button.

The Save As dialog box appears.

3. Enter a name for the database in the File name box and click Save.

The Access 2010 database is closed and the converted file opens. The original database still exists—since all you did is save a copy in a different format—but must be opened separately.

![Figure 3-26: Converting an Access 2010 database by saving it as an earlier file format.](Image)
Creating and Working with a Database Review

Quiz Questions

24. You should always plan the design and structure of a database before you begin creating it. (True or False?)

25. Once you create a database with an Access template you can modify it to better suit your needs. (True or False?)

26. Which of the following is not a pre-made template for creating a table in Access?
   A. Contacts
   B. Tasks
   C. Issues
   D. Notes

27. Which of the following determines the type of information that can be stored in a field?
   A. A data type
   B. A field size
   C. A primary key
   D. An index property

28. You cannot add a field to a query without displaying the field in the query results. (True or False?)

29. You want to sort a query by a table’s Last Name field. In order to do this, the Last Name field MUST appear in the displayed results of the query. (True or False?)

30. To specify OR criteria in a query, enter everything on the same criteria row. (True or False?)

31. What is the first step in creating a form with the Form Wizard?
   A. Selecting how the form should be formatted.
   B. Reading several screens of mostly useless information and clicking Next.
   C. Selecting the underlying table or query on which you want to base the form.
   D. Selecting the fields you want to appear in the form.

32. The Report Wizard button is found in the ______ group on the Create tab on the Ribbon.
   A. Wizards
   B. Reports
   C. Labels
   D. Documents

33. Microsoft Word is required to print mailing labels with Access. (True or False?)
34. Access 2007 databases use the same file format as Access 2003 databases. (True or False?)

**Quiz Answers**

24. True. You should always plan before creating a database.
25. True. You can easily modify a database created from a template.
26. D. Notes is not a table template in Access.
27. A. A data type determines the type of information that can be stored in a field.
28. False. You can include a field in a query without displaying it in the query results by unchecking its Show box.
29. False. You can sort the results of a query without displaying the field you used to sort the query.
30. False. To specify OR criteria, enter it on a different row.
31. C. Selecting the underlying table or query.
32. B. The Report Wizard button is found in the Reports group.
33. False. The Label Wizard is included in Access and makes creating labels easy.
As databases grow larger and larger, finding a specific record or group of records becomes harder and harder. Fortunately, Microsoft Access is equipped with an arsenal of Find, Sort, and Filter commands that can track down and organize a table’s information in record time.

In this chapter you will learn how to use these commands. First, you’ll learn how to use the Find command to look up a specific record. Next, you’ll learn how to sort information in a table—in ascending or descending order. Then, you’ll learn all about filters: How they can find and display only records that meet your criteria, such as customers from the state of Texas.

Once you’ve learned how to organize and sort all that information, you’ll learn how to make it look more professional. This chapter explains how to format a datasheet to change its font and appearance. You will also learn how to freeze and hide columns in a datasheet—an important task if you need to view large amounts of information.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Finding and Replacing Data

Although you can use a query to find data, sometimes you just want to quickly find a small amount of data. The Find feature allows you to quickly search tables, queries, and forms for specified text. You can also use the Replace command to quickly find and replace data.

The Find command in Access is similar to the Find command in other Office programs, but it contains some additional features as well. For example, you can choose to match part or all of the data in a field.

Find and Replace

The Find and Replace commands make it very easy to find and replace specific words and values in your tables. You can also find and replace information in forms and find information (but not replace) in queries.

For these steps, we’ll assume you are working in a table’s datasheet. First, you need to put the cursor in the field that contains the data you want to look for.

1. Select the column header for the field you want to search or click in any cell in the field you want to search.

   Tip: If you want to search the entire table, click in any cell. Once you open the Find and Replace dialog box, click the Look In list arrow and select Current document.

2. Click the Home tab on the Ribbon and click the Find button in the Find group.

   The Find tab of the Find and Replace dialog box appears.

   Other Ways to Find:
   Press <Ctrl> + <F>.

3. If you want to replace data, click the Replace tab.

   The Replace tab is displayed.

   Other Ways to Replace:
   Press <Ctrl> + <H>.

4. Type the text or value you want to find in the Find what text box.

   If you are replacing the data, you’ll need to enter the replacement text or value as well.

Exercise

• Exercise File: EmployeeList.accdb
• Exercise: Open the Employees table. Find “Redmond” in the City field. Then, in the Title field, find and replace all instances of “Sales Representative” with “Sales Associate”.

Figure 4-1: The Find tab of the Find and Replace dialog box.

Figure 4-2: The Replace tab of the Find and Replace dialog box.
5. If desired, enter the replacement text or value in the Replace With box.

Next, you have a few optional changes you can make to the search.

6. If desired, click the Match list arrow and select an option.

The Match options allow you to broaden or narrow your search. See Table 4-1: Using the Match List Options for a description of the Match options.

7. If desired, check the Match Case box.

If you check the Match Case box, Access finds only text that has the same pattern of uppercase and lowercase characters as the text you entered.

8. Make sure the Search Fields As Formatted box is checked and click the Find Next button.

Access jumps to the first occurrence of the text or value that you entered.

9. Click the Find Next button again to move on to other occurrences or click Replace or Replace All if you want to replace the data. When you’re finished, click Close.

Tips

✓ Finding or replacing data in a form works the same way as in a table, except that you select controls to search instead of fields. When you use the Find command in a form, Access is actually searching the underlying table.

✓ You can find, but not replace, data in query results.

✓ To find wildcard characters, type an opening bracket ([), the wildcard character you want to find, and a closing bracket (]) in the Find What box. For example, you would type [*] to find all instances of an asterisk.

<table>
<thead>
<tr>
<th>Table 4-1: Using the Match List Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole Field</td>
</tr>
<tr>
<td>Example: John finds John, but not Johnson, or Sue and John.</td>
</tr>
<tr>
<td>Any Part of Field</td>
</tr>
<tr>
<td>Example: John finds John, Johnson, and Sue and John.</td>
</tr>
<tr>
<td>Start of Field</td>
</tr>
<tr>
<td>Example: John finds John and Johnson, but not Sue and John.</td>
</tr>
</tbody>
</table>
Sorting Records

When you enter new records in a table they are added at the end of the table in the order you enter them. Working with information in such a jumbled order can be difficult if not impossible.

Fortunately you can sort, or change, the order of records in a table. You can sort records alphabetically, numerically, or chronologically (by date). Additionally, you can sort information in ascending (A to Z) or descending (Z to A) order.

Tips

✔ If you frequently sort a table the same way, you should consider creating and using a query that automatically sorts the table data for you. A query that sorts a table alphabetically by name would be a good example of such a query.

Sort records

1. Open the table you want to sort and click anywhere in the column (field) you want to use to sort by.

2. Click the Home tab on the Ribbon and click either the Ascending or Descending button in the Sort & Filter group.

The table is sorted. See Table 4-2: Sort Examples for examples of different types of sorts.

Other Ways to Sort:
Right-click in the field you want to sort by and select a sort option.

Clear a sort

1. Click the Home tab on the Ribbon and click the Remove Sort button in the Sort & Filter group.

The sorted data returns to its original order.

Exercise

- Exercise File: EmployeeList.accdb
- Exercise: Open the Employees table. Sort the table by the Last Name field in Ascending order. Then sort it in Descending order. Sort the table by the Birth Date field in Ascending order. Clear the sort.
Using Common Filters

Sometimes you may want to see only certain records in your table. By filtering a table, you display only the records that meet your criteria and hide the records that do not. For example, you could filter a client list to display only clients who live in California.

There are several filter methods:

- **Common Filters**: A number of commonly-used filters are available on a menu, making it easy for you to quickly use these pre-defined filters.
- **Filter by Selection**: Simply find and select the value you want to use as the filter criteria, and then use the Filter By Selection command to find all records with the selected value.
- **Filter by Form**: Here you type your filter criteria into a blank form that contains all the field names in the table. Works well if you have more than one criteria.
- **Advanced Filter/Sort**: The most powerful and complicated filter method. Creating an advanced filter is really not any different from creating a query.

In this lesson, we’ll look at common filters you can access quickly using the contextual menu, as well as how to remove a filter.

**Apply a common filter**

1. Click anywhere in the column you want to filter by, click the **Home** tab on the Ribbon and click the **Filter** button in the Sort & Filter group.

   A contextual menu appears with two ways to filter:

   - Use the check box list. This list contains all the values in that column. Uncheck a box and click **OK** to filter out a particular value. If the box next to a value is checked, it will appear in the filtered table.
   - Point to **[Data type] Filters**, then point to an option—such as **Equals** or **Does Not Equal**—on the submenu that appears. Enter a filter criterion in the Custom Filter dialog box. For example, if you select Equals and enter Johnson, Access will filter out all records except for those with Johnson in that field.

   **Trap**: These options aren’t available if you selected multiple columns. To filter multiple columns you need to filter each column individually or use an advanced filter.

---

**Exercise**

- **Exercise File**: EmployeeList.accdb
- **Exercise**: Use the Filter button to filter the Title column to display all values except for Sales Manager (hint: use the check boxes on the contextual menu). Then clear the filter.

---

**Figure 4-6**: The Sort & Filter group.

**Figure 4-7**: Filter menu that appears when you click the Filter button in the Sort & Filter group.
2. Select a filter option.

The data is filtered.

⚠️ Other Ways to Use Common Filters:
Right-click the field value you want to filter by and select one of the filter options at the bottom of the contextual menu or point to [Data type] Filters and select an option from the submenu.

Clear a filter

1. Click the Home tab on the Ribbon, click the Advanced Filter Options button in the Sort & Filter group and select Clear All Filters.

All data is once again displayed.

⚠️ Other Ways to Clear a Filter:
Click in a filtered column, click the Filter button in the Sort & Filter group on the Home tab, and select Clear filter from [field name].

⚠️ Tips
✓ To unapply/reapply a filter (without clearing it), click the Home tab on the Ribbon and click the Apply/Remove Filter button in the Sort & Filter group (called the Toggle Filter button when all filters have been cleared). Or, click the Filtered/Unfiltered button at the bottom of the window in the Record Selector bar (called the No Filter button when all filters have been cleared).
Filtering by Selection

A quick way you can filter a table is with the Filter by Selection feature.

1. Click the field value on which you want to base the filter.

2. Click the Home tab on the Ribbon and click the Selection button in the Sort & Filter group.

The menu that appears contains four filter-related commands: you can read more about them in Table 4-3: Filter by Selection Menu Commands.

3. Select an option from the menu.

Other Ways to Filter by Selection:
Right-click the field value you want to filter by and select one of the options at the end of the contextual menu.

Table 4-3: Filter by Selection Menu Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals [selected field value]</td>
<td>Displays only records with the selected value.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> If John is selected, only records with John in this column are displayed.</td>
</tr>
<tr>
<td>Does Not Equal [selected field value]</td>
<td>Displays all records that don’t contain the selected value.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> If John is selected, records with John in this column are not displayed, but Johnson is.</td>
</tr>
<tr>
<td>Contains [selected field value]</td>
<td>Displays all records that contain the selected value in any form.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> If John is selected, John and Johnson are displayed.</td>
</tr>
<tr>
<td>Does Not Contain [selected field value]</td>
<td>Displays records that don’t contain the selected value in any form.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> If John is selected, neither John nor Johnson is displayed.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** EmployeeList.accdb
- **Exercise:** Use the Filter by Selection feature to filter by the WA value in the Region field. Select the Equals option. Then clear the filter.

Figure 4-8: Filtering a table by selection to display only records where the selected field equals “WA”.

Filtering by Form

Filtering by Form makes it easy to create a filter that uses more than one criterion. The Filter by Form window enables you to enter your filter criterion by picking values that you want the filtered records to have. You can filter by form when working in tables, forms or queries.

1. Click the Home tab on the Ribbon, click the Advanced Filter Options button in the Sort & Filter group, and select Filter by Form.

The Filter by Form window appears.

Tabs with the names “Look for” and “Or” appear at the bottom of the Filter by Form window. If you specify more than one criterion on the first tab, Access treats it as an AND criteria statement, meaning a record must match all the criteria in order to be displayed. For example, you could filter for employees who are from Washington AND who had been with the company for more than five years.

If you specify filter criterion on both tabs, Access treats it as an OR criteria statement, meaning a record has to match the criterion on one tab or the other to be displayed. For example, you could filter for employees from California OR Minnesota. Once you add an OR criteria, another OR tab appears next to it so that you can continue adding OR criteria.

2. Click the empty cell below the field you want to filter, click the list arrow and select the value you want to use to filter the records.

Other Ways to Enter Filter Criteria:
Instead of selecting a filter criterion from the list arrow, you can type filter criteria yourself.

3. Repeat Step 2 for each additional field you want to use to specify additional filter criteria.

4. If you want to use Or criteria, click the Or tab at the bottom of the screen and specify additional filter criteria in the same way.

5. Click the Apply Filter button in the Sort & Filter group.

The data is filtered using the criteria you entered in the form.
Creating an Advanced Filter

The most powerful type of filter is the Advanced Filter. The Advanced Filter is so powerful that you can think of it as a type of query. In fact, the procedure for creating an Advanced Filter is virtually the same as it is for creating a simple query. You can use an Advanced Filter when working in tables, forms or queries.

Advanced Filters have many advantages. They have the ability to:

- **Sort by multiple fields:** You can sort records using several fields. For example, you could sort a table alphabetically by last name and then by first name.

- **Use complex filter criteria and expressions:** You can use advanced expressions and operators to search for data. For example you could filter for dates that fall Between 1/1/95 And 12/31/99.

- **Use multiple AND/OR statements:** You can use more than one criterion to sift through records. For example, you could filter for employees who are from Washington AND who have been with the company for more than five years.

This lesson explains how to get your own Advanced Filters up and running.

1. Open the table that contains the data you want to filter or sort.

2. Click the Home tab on the Ribbon, click the Advanced Filter Options button in the Sort & Filter group, and select Advanced Filter/Sort.

   The advanced filter window appears. Notice that the window is split—just like a query in Design view. The top half contains a box that displays all the fields in the table. The bottom half of the screen contains a design grid, which is where you will add the fields you want to filter.

   Often you will have to use the field list’s scroll bar to scroll up or down the list in order to find a field.

3. Double-click each field you want to include from the field list.

   **Other Ways to Add Fields to the Design Grid:**
   Drag the field from the field list onto the design grid. Or, click the list arrow in the Field row of the design grid and select a field.

   To sort by a field, you can click the Sort row in the column that contains the field that you want to sort and select Ascending or Descending from the list.

Exercise

- **Exercise File:** EmployeeList.accdb
- **Exercise:** Create an Advanced Filter that sorts the records in Ascending order by Last Name and then First Name, and also filters for employees from London who were hired after 1/1/93. Clear the filter.
Finding, Filtering, and Formatting Data

4. Click the **Sort** list arrow for the field and select a sort order (optional).

   If you use several fields to sort a table, Access performs the sort in the order the fields appear in the design grid.

   Now you need to specify criteria for the filter. Table 4-4: Common Criteria Operators shows some common criteria operators you can add to your criteria to make them more useful.

5. In the design grid, enter any desired search criteria for the fields in the Criteria row.

   If you specify more than one criterion on the same Criteria row, Access treats it as an AND criteria statement, meaning a record must match all the criteria in order to be displayed. For example, you could filter for employees who are from London AND who were hired after January 1, 2003.

   If you specify filter criterion on the Or rows, Access treats it as an OR criteria statement, meaning a record has to match the criterion on one row or the other to be displayed. For example you could filter for employees from London OR Washington.

6. Click the **Apply Filter** button in the Sort & Filter group.

### Table 4-4: Common Criteria Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>= “MN”</td>
<td>Finds records equal to MN.</td>
</tr>
<tr>
<td>&lt; &gt;</td>
<td>&lt; &gt; “MN”</td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td>&lt;</td>
<td>&lt; 10</td>
<td>Finds records less than 10.</td>
</tr>
<tr>
<td>&lt; =</td>
<td>&lt;= 10</td>
<td>Finds records less than or equal to 10.</td>
</tr>
<tr>
<td>&gt;</td>
<td>&gt; 10</td>
<td>Finds records greater than 10.</td>
</tr>
<tr>
<td>&gt; =</td>
<td>&gt;= 10 AND &lt; &gt; 5</td>
<td>Finds records greater than or equal to 10 and not equal to 5.</td>
</tr>
<tr>
<td>BETWEEN</td>
<td>BETWEEN 1/1/07 AND 12/31/07</td>
<td>Finds records between 1/1/07 AND 12/31/07.</td>
</tr>
<tr>
<td>LIKE</td>
<td>LIKE “S*”</td>
<td>Finds text beginning with the letter “S.” You can use LIKE with wildcards such as *.</td>
</tr>
</tbody>
</table>
Adjusting and Rearranging Rows and Columns

Access is usually pretty smart about how wide to make the columns of a table or query datasheet so hopefully you won’t have to do much resizing. Sometimes, however, you will discover that some of the columns or rows are not large enough to display the information they contain. This lesson explains how to change the width of a column and the height of a row, as well as how to rearrange columns.

Tips

✓ When you adjust the height of a row, all the rows change, but when you adjust the width of a column, only the selected column(s) change.

Adjust column width

1. Drag the column header’s right border to the left or right.

Other Ways to Adjust Column Width:
Right-click the column header(s), select Field Width from the contextual menu, enter the column width, and click OK. Or, select the column(s) you want to adjust, click the Home tab on the Ribbon, click the More button in the Records group, select Field Width, enter the column width and click OK.

Adjust row height

1. Drag the row header’s bottom border up or down.

Other Ways to Adjust Row Height:
Right-click the row header(s), select Row Height from the contextual menu, enter the row height, and click OK. Or, select any row, click the Home tab on the Ribbon, click the More button in the Records group, select Row Height, enter the row height and click OK.

Automatically adjust columns

You can also have Access automatically adjust the width of a field or column so that it can hold the widest entry. To do this, simply double-click the right edge of the column.

1. Double-click the right border of the column.

Exercise

• Exercise File: EmployeeList.accdb
• Exercise: Drag the Birth Date column’s header to make it slightly wider. Auto-adjust the Address column’s width. Make all the rows twice as tall, then return them to their original height. Move the Home Phone column so that it is directly to the left of the Address column.

Figure 4-12: Adjusting column width.
Rearrange columns

When you first created a table, hopefully, you thought about its field order, so that most of the time your data will appear in the order you want. Sometimes, however, you may want to change the column order of a table.

1. Click the field name of the column you want to move. Then, click it again and hold down the mouse button.

   Now you have to drag the column to its new destination. If the destination is too far to the left or right to appear on the screen, drag the column to the left or right of the window—the datasheet will scroll in that direction.

2. Drag the selected column to its new location.

   ✔ Tips

   ✓ As you move the column, a bar moves between the columns, showing where the column will go when you release the mouse button.

   ✓ Don’t worry that altering column order will affect your data—it doesn’t.
Changing Gridline and Cell Effects

There isn’t a lot of formatting you can do to tables in Access, but you can change how gridlines appear, apply background colors, and add 3-D effects to the table’s cells.

Change gridlines

By default, Access displays both horizontal and vertical lines in a table, but you can select to show Horizontal, Vertical, Both, or None.

1. Click the Home tab on the Ribbon, click the Gridlines button in the Text Formatting group, and select the gridline option you want to use.

Other Ways to Change Gridlines:
Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Text Formatting group. Check or uncheck the Horizontal and Vertical boxes in the Gridlines Shown area.

Tip: Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Text Formatting group to display the Datasheet Formatting dialog box. Here you can change gridline color, change gridline style (for example, a dotted line), and change the direction of the table columns so that they go from right-to-left.

Apply background colors

1. Click the Home tab on the Ribbon, click the Background Color button arrow in the Text Formatting group, and select a color.

The first row in the table and each alternating row is displayed with the color you selected.

You can also apply a second color to the alternating rows.

2. Click the Alternate Row Color button arrow in the Text Formatting group, and select a color.

The alternate rows are filled with the color you chose.

Other Ways to Apply Background Colors:
Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Text Formatting group. Click the Background Color or Alternate Background Color list arrow and select the color you want to use.
Apply cell effects
You can also add a 3-D effect to the table cells.

1. Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Text Formatting group. The Datasheet Formatting dialog box appears.

2. Select Raised or Sunken in the Cell Effect area and click OK. The selected effect is applied to the table cells.

Figure 4-15: The Datasheet Formatting dialog box.
Changing the Datasheet Font

Being a practical business program, Access displays its tables in a no-nonsense, easy-to-read font. However, you can change the font used to display table data. You can make the text appear darker and heavier (bold), slanted (italics), larger, and in a different typeface or color.

Tips

✓ The font settings you change apply to the entire table, not just a particular cell, column, or row.

Here’s how to change the font used in a table.

1. Click the Home tab on the Ribbon and format the table data using the commands in the Text Formatting group.

Table 4-5: Text Formatting group commands describes the specifics for using each of the font formatting commands in the Text Formatting group:

<table>
<thead>
<tr>
<th>Font</th>
<th>Click the Font list arrow and select a font type—for example, Arial.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Size</td>
<td>Click the Font Size list arrow and select a font size.</td>
</tr>
<tr>
<td>Bold</td>
<td>Click the Bold button to bold the table text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Click the Italic button to italicize the table text.</td>
</tr>
<tr>
<td>Underline</td>
<td>Click the Underline button to underline the table text.</td>
</tr>
<tr>
<td>Font Color</td>
<td>Click the Font Color list arrow and select a font color.</td>
</tr>
<tr>
<td>Text Alignment</td>
<td>Click the Align Text Left, Center, or Align Text Right buttons to align text within the table cells.</td>
</tr>
</tbody>
</table>

Exercise

- Exercise File: EmployeeList.accdb
- Exercise: Apply Bold, Red formatting, then remove the Bold and return the font color to Automatic.

Figure 4-16: Font formatting commands in the Text Formatting group.
Freezing a Column

Most tables have so much information that it won’t all fit on the same screen. When this happens, you have to scroll through the datasheet to add, delete, modify, and view information. The problem with scrolling and viewing information in a large table is that it can be confusing when you can’t see important information such as names or product numbers.

To overcome this problem, you can freeze a column so it stays in the same place while you scroll to the right in a table. Here’s how to freeze a column.

Freeze a column

1. Right-click the header for the column you want to freeze and select Freeze Fields from the contextual menu.

   The column is now frozen and is moved to the left side of the table. Here it will always remain visible as you scroll to the right through the rest of the fields in the table.

   ✔ Tip: To freeze more than one column, freeze them individually. Or, select all the columns you want to freeze, right-click the field header area and select Freeze Fields.

   ✗ Other Ways to Freeze or Unfreeze a Column:
   Select the column you want to freeze, click the Home tab on the Ribbon, click the More button in the Records group, and select Freeze Fields or Unfreeze All Fields.

Unfreeze a column

1. Right-click any column header in the table and select Unfreeze All Fields.

   All columns are unfrozen.

   ✔ Tip: Once you unfreeze the column, you will still need to move the column back to its old position, if desired. Or, simply choose not to save changes when you close the table—when you reopen it, the columns will be in their previous positions.

Exercise

• Exercise File: EmployeeList.accdb
• Exercise: Freeze the Last Name column. Then unfreeze all columns and move the Last Name column back to its original position.

Finding, Filtering, and Formatting Data
Hiding a Column

You can temporarily hide a column when you want to reduce the amount of information that is displayed on the screen. Hiding a column doesn’t delete any information—it only hides it. The procedure for hiding and unhiding a column is almost the same as for freezing a column.

Hide a column

1. Right-click the header for the column you want to hide and select **Hide Fields** from the contextual menu.

   The column is hidden.

   ✓ **Tip:** To hide multiple columns at once, select them all, then right-click one of the selected column headers and select **Hide Fields**.

Unhide a column

1. Right-click any table header and select **Unhide Fields** from the contextual menu.

   The Unhide Columns dialog box appears.

2. Click the check box next to each column you want to redisplay. Click **Close**.

   The column(s) are unhidden.

---

**Exercise**

- **Exercise File:** EmployeeList.accdb
- **Exercise:** Hide the Last Name column, then unhide it.

---

![Figure 4-18: The Unhide Columns dialog box.](image)

![Figure 4-19: Before and after hiding the Last Name column.](image)
Finding, Filtering, and Formatting Data Review

Quiz Questions

35. The Replace command finds a string of text and replaces it with another string of text. (True or False?)

36. How would you sort a Datasheet in ascending order by a date field?
   A. Double-click the top of the Date field column header.
   B. Select any Date field and click the Sort button in the Tools group.
   C. Select any Date field and click the Ascending button in the Sort & Filter group.
   D. Access can’t sort chronological information.

37. Which of the following is not a filtering method in Access?
   A. Filter by Table
   B. Filter by Selection
   C. Filter by Form
   D. Advanced Filter/Sort

38. Filter by Selection is the most difficult and advanced way to filter information. (True or False?)

39. You should only use Filtering by Form when you want to use one filter criterion. (True or False?)

40. How can you add fields to the design grid in an Advanced Filter?
   A. Double-click the field from the Field List.
   B. Select the field from the Add Field List on the Ribbon.
   C. Right-click the grid and select Add Field from Menu.
   D. Press Ctrl + X

41. Double-click the left border of a column to automatically adjust the width of a column to fit the largest cell. (True or False?)

42. By default, Access displays both horizontal and vertical gridlines in a table. (True or False?)

43. Which of the following is not a font-related option you can change in Access?
   A. Font Size
   B. Text Alignment
   C. Bold
   D. Zoom

44. To freeze a column in Access, right-click the column’s header and select __________.
   A. Freeze Field
   B. Pin Column
45. When you hide a column or field, you permanently lose all the information stored in the field. (True or False?)

**Quiz Answers**

35. True. The Replace command finds a string of text and replaces it with another string of text.
36. C. To sort a Datasheet by a date field select any Date field and click the Ascending button in the Sort & Filter group.
37. A. Filter by Table is not a filtering option in Access.
38. False. Filter by Selection is a fast and easy way to filter information.
39. False. With Filter by Form you can easily filter with several criteria.
40. A. Double-click the fields you want to add from the Field List.
41. False. Double-click the right border of a column.
42. True. Horizontal and vertical gridlines appear by default in Access tables.
43. D. Zoom is not a font-related option.
44. C. Select Freeze Columns from the contextual menu.
45. False. The information is still there, it’s just hidden.
# Working with Tables and Fields

- **Understanding Field Properties** ..................................... 90
- **Indexing a Field** .......................................................... 92
- **Adding a Primary Key to a Table** ....................................... 94
- **Inserting, Deleting, and Reordering Fields** ..................... 96
  - Insert a field ............................................................. 96
  - Change field order .................................................... 96
  - Delete a field ........................................................... 97
- **Adding Field Descriptions and Captions** ......................... 98
- **Changing the Field Size** ................................................ 99
- **Formatting Number, Currency, and Date/Time Fields** .......... 101
  - Format number and currency fields ................................ 101
  - Change the number of decimal places .... 101
- **Formatting Number, Currency, and Date/Time Fields by Hand** 103
- **Formatting Text Fields** .................................................. 105
- **Setting a Default Value** .................................................. 106
- **Requiring Data Entry** ..................................................... 107
- **Validating Data** ............................................................ 108
- **Creating an Input Mask** .................................................. 110
- **Creating a Lookup Field** ................................................ 112
- **Creating a Value List** ..................................................... 114
- **Modifying a Lookup List** ................................................ 116
  - Modify a lookup list ..................................................... 116
  - Modify a value list ...................................................... 117

---

Tables are by far the most important part of any database. Tables are where a database stores all of its information. All the other database objects—queries, forms, reports, pages, and macros—are merely tools to analyze, manipulate, and display the information stored in a table. Any of these other database objects are optional—but without tables, a database wouldn’t be a database.

If you are interested in creating your own databases, this may be one of the most important chapters in the entire book. Why? Because, at their heart, the most useful and efficient databases consist of well-structured tables.

This chapter explains just about everything you will ever need to know about tables and fields: how to link two or more related tables, how to create indexes for faster performance, and how to create a primary key field, which uniquely identifies each record in a table. This chapter also explains how to change all the properties and settings for your tables’ fields, such as how they are formatted and what kind of information they can store.

**Using Exercise Files**

This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Understanding Field Properties

A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, a car’s properties would include its color, make and model, and shape. A property for a numeric field might be the number of decimal places displayed or the maximum number of characters a field can hold.

Just about every object in Access—every heading on a report, every label on a form, every field in a table—has its own set of properties that you can view and change. This property concept might seem a little confusing at first, but it’s something you have to learn if you want to become proficient at using Microsoft Access. Because you can almost always change object properties, you can also think of an object’s properties as its settings.

To view and modify the Field Properties for a table, open the table in Design View.

1. Double-click the table you want to open in the Navigation pane.
   The table opens in Datasheet View.

2. Click the Home tab on the Ribbon and click the View button in the Views group.
   The table is displayed in Design View and the Design contextual tab appears under Table Tools on the Ribbon.

Other Ways to Open a Table in Design View:
Right-click the table you want to open in the Navigation pane and select Design View from the contextual menu.

As you can see, the table design window is broken into two sections. The top section contains the table’s field names and the bottom section displays the properties for the selected field. Simply click the field name whose properties you want to view.

3. In the top part of the window, click the field name whose properties you want to view.
   To change a field property…

4. Click the property box you want to change and enter or select the new settings.

Table 5-1: Important Field Properties describes many important field properties. Don’t worry if some of them seem confusing—you’ll get plenty of practice adjusting them in other lessons.

Exercise

- **Exercise File**: CustomerTours.accdb
- **Exercise**: Open the tblCustomers table. Click in the LastName field and view the field’s properties in the bottom half of the window.

Figure 5-1: Viewing field properties in Design View.
Working with Tables and Fields

Tips

✓ The Property Sheet displays some additional, highly technical table properties. To hide or show the Property Sheet, click the Design tab under Table Tools, and click the Property Sheet button.

✓ It's important to note that certain types of fields have their own sets of properties. For example, number fields have a Decimal Places property while text fields do not.

| Field Size | Text fields: The maximum number of characters (up to 255) that can be entered in the field. The default setting is 50. Number / Currency fields: Stores the number as a Byte, Integer, Long Integer, Single, Double, or Replication ID, or Decimal. The default setting is Long Integer. |
| Format | How the data in the field will be displayed on the screen. |
| Input Mask | Creates a format or pattern in which data must be entered. |
| Decimal Places | The number of decimal places in Number and Currency fields. |
| Caption | A label for the field that will appear on forms. If you don’t enter a caption, Access will use the field name as the caption. |
| Default Value | A value that Access enters automatically in the field for new records. |
| Validation Rule | An expression that limits the values that can be entered in the field. |
| Validation Text | The error message that appears when an incorrect or restricted value is entered in a field with a validation rule. |
| Required | Specify whether or not a value must be entered in the field. The default is No. |
| Allow Zero Length | Specify whether or not the field allows zero-length text strings (a string containing no characters). Zero-length text strings are useful if you must enter data in a field, but no data exists. For example, if a Social Security field requires data, but you don't know the social security number, you would enter a zero-length text string in the field. To enter a zero-length text string type ”” in the cell. The cell will appear empty. The default is No. |
| Indexed | Specify whether or not you want to index the field to speed up searches and sorts performed on the field. The default is No. |
Indexing a Field

Just like an index in a book, when you index a field, it helps Access find and sort information quickly—especially in large tables. You can index any field in a table to dramatically speed up queries and sorts. When you sort or query a large table using an indexed field, Access finds or sorts the information by consulting the index instead of sifting through the entire table.

Here are some more important notes about indexes:

- Since indexes speed up searching and sorting, you should index the fields you frequently use to search or sort. For example, if you often search for specific last names, you should create an index for the LastName field.
- Don’t index too many of a table’s fields. The more fields you index, the slower your searches and sorts will be—defeating the entire purpose of an index. Only index the fields you use to search and sort data.
- Any field can be indexed except memo, OLE, attachment, calculated, and hyperlink fields.
- Primary key fields are indexed automatically (we’ll discuss primary keys more in future lessons).
- If you choose, indexes can prevent duplicate entries in your table (for example, if you don’t want to allow two customers to have the same social security number).

This lesson will show you how to add indexes to your tables.

1. **Open the table you want to index in Design view.**
   
   Indexing a field is a fairly simple operation. First you need to click the name of the field you want to index. You will want to index a field that is frequently used to find and sort information—for example, a LastName field.

2. **Click the field name you want to index in the top part of the screen.**

3. **Click the Indexed row in the Field Properties section and click its list arrow.**

   The Indexed list gives you three choices:

   - **No:** The field is not indexed. This is the default setting.
   - **Yes (Duplicates OK):** The field is indexed and Access will allow records in this field to have the same value.

### Exercise

- **Exercise File:** CustomerTours.accdb
- **Exercise:** In the tblCustomers table, index the LastName and ZipCode fields, choosing the “Yes (Duplicates OK)” option. Save the changes.

![Figure 5-2: Indexing a field.](image-url)
• **Yes (No Duplicates):** The field is indexed and Access won’t allow records in this field to have the same value (for example, if you don’t want to allow two customers to have the same social security number).

Most of the time you will want to choose the “Yes (Duplicates OK)” option. For example, if you’re indexing a Last Name field, you’ll want to select “Yes (Duplicates OK)” since some people may have the same last name.

4. Select an indexing option from the list.

   Most of the time Access creates the index in a matter of seconds. If you have a huge table with thousands of records, it will take longer to create the index.

   When you’re done indexing, save the changes you’ve made to your table.

5. Click the **Save** button on the Quick Access Toolbar.

   The indexing is saved.

**Tips**

✓ If you need to remove an index from a field, select the field, click the Indexed row’s **list arrow**, and select the **No** option. Access will delete the field’s index.
A primary key is a special kind of indexed field that uniquely identifies each record (row) in a table. When you think about primary key fields, think unique—each primary key value must be the only one of its kind in a table. A customer ID or invoice number would be two good examples of fields that could be used as a table’s primary key.

Here are some things you need to know about primary keys:

- A table can have only one primary key.
- The values in the primary key fields must be unique. For this reason, many people use an AutoNumber field as their primary key. AutoNumber fields automatically add a new, unique number to each record in a table. Another reason to use AutoNumber fields for your primary keys is because they are “factless”—meaning they don’t contain factual information that describe the row. Factless fields are better than factual fields like Last Name because they are less likely to change.
- A primary key field needs to always contain a value and should rarely or never change.
- Every table you create should have a primary key because it helps keep your data organized and easy to work with.
- The primary key field is automatically indexed.
- Memo, OLE, calculated, and attachment fields can’t be used as the primary key.
- The primary key is normally a single field, but two or more fields can act together as the primary key, so long as their combined values are unique. Such multi-field keys are usually difficult and confusing to work with, however.
- Primary keys are especially important in creating relationships between tables.

So what makes a good primary key field? The most important consideration for a primary key is its uniqueness. A primary key field must always be different in every record, so you might be able to use a Customer ID, Invoice Number, or Social Security Number field as your table’s primary key.

Fortunately, in Access 2010 you won’t usually have to worry about assigning a primary key because Access does it for you. When you create a new table, Access automatically creates a primary key with the field name ID and the AutoNumber data type.

**Exercise**

- **Exercise File:** CustomerTours.accdb
- **Exercise:** In the tblCustomers table, add a primary key to the CustomerID field. Save the change.

*Figure 5-3: Assigning a primary key to the CustomerID field.*
Working with Tables and Fields

However, if you have an existing table to which you want to add a primary key field, you’ll want to pay close attention to the steps in this lesson, which explain how to add a primary key.

✔ Tips

✓ If a table doesn’t already have a unique field that is suitable as the primary key, add an AutoNumber field to your table. The AutoNumber field will automatically add a new, unique number to each of the records in a table.

1. Open the table you want to add a primary key to in Design view.

2. Click the name of the field you want to use as your primary key in the top part of the screen.

3. Under Table Tools on the Ribbon, click the Design tab and click the Primary Key button in the Tools group.

A key symbol appears next to the field, indicating that it is the table’s primary key. Notice that Access also sets the Indexed field to “Yes (No Duplicates).” Access automatically indexes the field so that sorts and queries using the field will be faster and so that you cannot enter duplicate values in the field.

✔ Tips

✓ If a field appears in more than one table and is a primary key in one table, it is called a foreign key in the other table (because it is another table’s primary key).

✓ To remove a primary key, just click the Primary Key button again. However, if the primary key is involved in any table relationships, you’ll first need to delete the relationships before you can remove the primary key.
Inserting, Deleting, and Reordering Fields

You can insert, delete, and reorder fields in your tables in Design View. Remember that in Design View, each row corresponds to a field in the table. You add a field by inserting a new row and delete a field by deleting its corresponding row.

**Tips**

- You can also insert, reorder, and delete fields in Datasheet View.

### Insert a field

1. Display the table you want to work with in Design View.

   To insert a new field, you must first click the row selector for the field that will appear below the new field you want to insert.

2. Click the row selector for the field that will be below the new field you want to insert.

3. Under Table Tools on the Ribbon, click the Design tab and click the Insert Rows button in the Tools group.

   A new row is added.

   **Other Ways to Insert a Field:**
   Right-click in the row below where you want to insert the new field and select Insert Rows from the contextual menu.

4. Enter a Field Name for the new field, then click the Data Type list arrow and select a data type.

### Change field order

1. In Design View, click the row selector for the field you want to move.

2. Click and drag the selected row up or down to the desired location.

---

### Exercise

- **Exercise File:** CustomerTours.accdb
- **Exercise:** In the tblCustomers table in Design View, insert a field called “MI” above the Phone field. Move the MI field down before the City row. Then delete the MI field.

---

**Figure 5-4:** The Insert and Delete Rows commands in the Tools group.

**Figure 5-5:** Inserting a new row in Design View.
Delete a field

1. In Design View, click the row selector for the field and press `<Delete>`.

2. Click Yes.

   ☀ Other Ways to Delete a Field:
   Right-click the field’s row and select Delete Rows. Click Yes.

✅ Tips
✓ Once you leave Design View, you’ll need to save the changes you’ve made to the table design.
Adding Field Descriptions and Captions

Descriptions provide extra instructions to users about a field, while captions allow you to create nicknames for fields, making their names more meaningful to users.

Add a description to a field

Descriptions make your database fields easier to fill out and use by providing users with onscreen instructions and help. Whenever a user selects a field, anything you type in that field’s Description box will appear in the Status bar.

There really isn’t anything complicated about adding a description to a field—just type the text you want to appear in the field’s Description box.

1. Make sure the table is displayed in Design View, click the field’s Description box, and type the description.
   
   When you return to Datasheet View, and click anywhere in that field, you will see the Description appear in the Status bar.

Add a caption to a field

Think of the Caption property as a field’s pseudonym or stage name. When you view a table in Datasheet View or create forms and reports, Access uses the field’s Field Name as the field’s heading. When you add a caption to a field, however, it appears as the heading for the field instead of the field name.

Captions are useful when you want to provide more detailed headings for your field names. For example, instead of displaying the rather ambiguous DOB field name, you could add a more meaningful “Date of Birth” caption to the DOB field to make the field name easier to read and understand. The original DOB field name is not affected in any way.

1. Make sure the table is displayed in Design View.

2. Click the field you want to add a caption to.

3. Click the Caption box in the Field Properties section and type the caption.

Exercise

- **Exercise File:** CustomerTours.accdb
- **Exercise:** In the tblCustomers table, change the DOB field’s data type to Date/Time. Add the description “Enter the Customer’s Last Name” to the LastName field, and “Enter the Customer’s First Name” to the FirstName field. Add the caption “Date of Birth” to the DOB field and “Social Security No.” to the SSN field. Save the changes.
   
   View the table in Datasheet View and notice the message in the status bar when you click in the LastName and FirstName fields, and the new headings for the DOB and SSN fields.

![Figure 5-6: Once you enter a description in Design View, it appears in the Status bar in Datasheet View.](image)
Changing the Field Size

The Field Size property determines the maximum size of information that can be stored in a text or number field. For example, if you set the size of a text field to 2, you could enter “MN” but not “Minnesota.” There are several reasons why you would want to change the size of a field:

- Changing the field size reduces data-entry errors.
- Access can process smaller field sizes more quickly.
- Smaller field sizes require less hard-drive storage space.

Field sizes work a little differently for text and number fields. In text fields, the Field Size property determines the maximum number of characters the field can accept. In numerical type fields, the Field Size property determines what type of number the field will accept.

In this lesson you will change the size of a table’s fields.

1. Make sure the table is displayed in Design view.
2. Select the field whose size you want to change.
3. Click the Field Size box in the Field Properties section.
   Now you’re ready to change the field size. If the field is a text field, you can type the field size value, but if it’s a number field, you’ll need to click the list arrow and select an option.
4. Type or select the field size. If prompted, click Yes to complete the action.

 Trap: Be very careful when changing the Field Size of a field that already contains data. Access will truncate or delete data that is larger than the new field size.

Table 5-2: Number Field Sizes describes the field sizes available for use with the Number data type.

<table>
<thead>
<tr>
<th>Field Type</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Byte</td>
<td>Integers from 0 to 255.</td>
<td>Very small – not usually a good choice.</td>
</tr>
<tr>
<td>Integer</td>
<td>Integers from –32,768 to 32,767.</td>
<td>Good for small numbers with no decimals.</td>
</tr>
<tr>
<td>Long Integer</td>
<td>Integers from –2,147,483,648 to 2,147,483,647.</td>
<td>Works for most numbers without decimals.</td>
</tr>
<tr>
<td>Single</td>
<td>Positive or negative numbers up to 38 zeroes and 7 decimal places.</td>
<td>Good for large numbers with decimals.</td>
</tr>
<tr>
<td>Double</td>
<td>Positive or negative numbers up to 308 zeroes and 15 decimal places.</td>
<td>For really big numbers with decimals.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File**: CustomerTours.accdb
- **Exercise**: In the tblCustomers table in Design View, change the State field’s size to 2 and the ZipCode field to 11. Save the changes.

Figure 5-7: Changing the ZipCode field’s Field Size.
## Table 5-2: Number Field Sizes

<table>
<thead>
<tr>
<th>Replication ID</th>
<th>Description</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replication ID</td>
<td>Long unique codes.</td>
<td>Used when you want to merge copies of a database.</td>
</tr>
<tr>
<td>Decimal</td>
<td>Positive or negative numbers up to 28 zeroes and 28 decimal places.</td>
<td>Good for numbers with lots of decimals.</td>
</tr>
</tbody>
</table>
Formatting Number, Currency, and Date/Time Fields

A field’s Format property changes how information appears in the field, not how the data is actually stored in the field. For example, a date field could be formatted to display the same value as 6/10/2000; Saturday, June 10, 2000; or 10-Jun-00. Each field type has its own set of formats. For example, number fields have a different set of formats than date/time or text fields.

There are two ways to format a number, currency, and date/time field:

- Selecting a ready-made format from the Format list (the easy way). For most people, the ready-made formats listed in Table 5-3: Number and Date/Time Formats will be all you will ever need to format your fields.
- Typing a series of formatting characters by hand in the Format box (the hard way).

This lesson explains the first way—how to format number, currency, and date/time fields by selecting a ready-made format. We’ll also look at how to change the number of decimal places.

Format number and currency fields

1. Make sure the table is displayed in Design view and click the field you want to format.
2. Click the Format box in the Field Properties section.
   A list arrow appears in the Format box. You can format this field the easy way by clicking the arrow to select from a list of ready-made number formats.
3. Click the list arrow and select a number format.

Change the number of decimal places

You can also specify how many decimal places you want numbers in a field to display. To change the number of decimal places in a number field, enter the number of decimal places you want displayed in the Decimal Places box.

1. Make sure the table is displayed in Design view and click the field you want to format.
2. Click the Decimal Places box in the Field Properties section.
   A list arrow appears.
3. Click the list arrow and select the number of decimal places you want to display.

Now Access will only display the number of decimals you selected.

<table>
<thead>
<tr>
<th>Number Format:</th>
<th>Example:</th>
<th>Date/Time Format:</th>
<th>Example:</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Number</td>
<td>1234.567</td>
<td>General Date</td>
<td>6/10/2000 6:35:21 PM</td>
</tr>
<tr>
<td>Currency</td>
<td>$1,234.57</td>
<td>Long Date</td>
<td>Saturday, June 10, 2000</td>
</tr>
<tr>
<td>Euro</td>
<td>€1,234.57</td>
<td>Medium Date</td>
<td>10-Jun-00</td>
</tr>
<tr>
<td>Fixed</td>
<td>1234.57</td>
<td>Short Date</td>
<td>6/10/2000</td>
</tr>
<tr>
<td>Standard</td>
<td>1,234.57</td>
<td>Long Time</td>
<td>6:35:21 PM</td>
</tr>
<tr>
<td>Percent</td>
<td>123456.70%</td>
<td>Medium Time</td>
<td>6:35 PM</td>
</tr>
<tr>
<td>Scientific</td>
<td>1.23E+03</td>
<td>Short Time</td>
<td>18:35</td>
</tr>
</tbody>
</table>
Formatting Number, Currency, and Date/Time Fields by Hand

If none of the ready-made number, currency, or date/time formats meet your needs, you can format fields the old-fashioned way—by hand. Formatting fields requires that you tell Access how you want the field to be formatted by typing the appropriate formatting characters in the Format box. Manual formatting is difficult, but it gives you complete flexibility on how the field displays its information.

In this lesson you will learn how to format number, currency, and date/time fields by hand.

1. Make sure the table is displayed in Design view and click the field you want to format.

2. Click the Format box in the Field Properties section.

   You can use Table 5-4: Number, Currency, and Date/Time Formatting Characters to help you know what characters to enter. You can mix and match any of the characters—for example, you could add “mmmm” (full name of month) to “yy” (last two digits of the year) to get “January 00.”

3. Enter the appropriate formatting characters or symbols for how you want the date or number to be formatted.

<table>
<thead>
<tr>
<th>Date/Time Formatting Characters:</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>:</td>
<td>h:mm</td>
<td>8:45</td>
</tr>
<tr>
<td>/</td>
<td>m/d/yy</td>
<td>10/8/00</td>
</tr>
<tr>
<td>-</td>
<td>m-d-yy</td>
<td>10-8-00</td>
</tr>
<tr>
<td>d</td>
<td>m/d/yy</td>
<td>10/8/00</td>
</tr>
<tr>
<td>dd</td>
<td>m/dd/yy</td>
<td>10/08/00</td>
</tr>
<tr>
<td>ddd</td>
<td>ddd, m/d/yy</td>
<td>Sun, 3/8/00</td>
</tr>
<tr>
<td>dddd</td>
<td>dddd, m/d/yy</td>
<td>Sunday, 3/8/00</td>
</tr>
<tr>
<td>m</td>
<td>m/d/yy</td>
<td>3/15/00</td>
</tr>
<tr>
<td>mm</td>
<td>mm/dd/yy</td>
<td>03/15/00</td>
</tr>
<tr>
<td>mmm</td>
<td>mmm-dd-yy</td>
<td>Mar-15-00</td>
</tr>
<tr>
<td>mmmm</td>
<td>mmmm d, yyyy</td>
<td>March 15, 2000</td>
</tr>
<tr>
<td>yy</td>
<td>m/d/yy</td>
<td>3/15/00</td>
</tr>
<tr>
<td>yyyy</td>
<td>mmmm d, yyyy</td>
<td>March 15, 2000</td>
</tr>
<tr>
<td>h</td>
<td>h:n</td>
<td>8:45</td>
</tr>
</tbody>
</table>

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: Open the tblCustomerTours table Design View, enter “ddd mmm d” in the Format box for the Date field. Save the change and view the Date field in Datasheet View.
### Table 5-4: Number, Currency, and Date/Time Formatting Characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Data</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>hh</td>
<td>Hour in two digits</td>
<td></td>
<td>hh:mm</td>
<td>08:45</td>
</tr>
<tr>
<td>nn</td>
<td>Minute in two digits</td>
<td></td>
<td>hh:mm</td>
<td>13:09</td>
</tr>
<tr>
<td>ss</td>
<td>Second in two digits</td>
<td></td>
<td>hh:mm:ss</td>
<td>10:45:07</td>
</tr>
<tr>
<td>AM/PM</td>
<td>Twelve-hour clock (uppercase)</td>
<td></td>
<td>hh:mm AM/PM</td>
<td>08:45 AM</td>
</tr>
<tr>
<td>am/pm</td>
<td>Twelve-hour clock (lowercase)</td>
<td></td>
<td>hh:mm am/pm</td>
<td>08:45 am</td>
</tr>
</tbody>
</table>

#### Number Formatting Characters:

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Data</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Display a digit or nothing</td>
<td>50</td>
<td>#</td>
<td>50</td>
</tr>
<tr>
<td>0</td>
<td>Display a digit or 0</td>
<td>50</td>
<td>.00</td>
<td>50.00</td>
</tr>
<tr>
<td>.</td>
<td>Display a decimal separator</td>
<td>50</td>
<td>.</td>
<td>50.</td>
</tr>
<tr>
<td>,</td>
<td>Display thousands separator</td>
<td>5000</td>
<td>,###</td>
<td>5,000</td>
</tr>
<tr>
<td>$</td>
<td>Display the $ currency symbol</td>
<td>50</td>
<td>$#.00</td>
<td>$50.00</td>
</tr>
<tr>
<td>%</td>
<td>Multiply the value by 100 and add a percent sign</td>
<td>0.5</td>
<td>#%</td>
<td>50%</td>
</tr>
<tr>
<td>E-, E+, e-, e+</td>
<td>Scientific notation</td>
<td>500000</td>
<td>.00E+00</td>
<td>5.00E+05</td>
</tr>
</tbody>
</table>
Formatting Text Fields

Just like number, currency, and date/time fields, a text field’s Format property changes how information appears in the field. The Format property only changes how data is displayed on screen, not how the data is actually stored in the field.

Unfortunately, unlike number fields, text fields don’t have any ready-made settings built into them and must be formatted manually. Luckily, text fields don’t have nearly as many formatting options as number, currency, and date/time fields. The most common of these text formatting characters are the greater than symbol (>), which makes all text in the field appear in uppercase, and the less than symbol (<), which makes all text in the field appear in lowercase, regardless of how it was entered. In both cases, Access actually stores the data exactly as it was typed.

1. Make sure the table is displayed in Design view and click the text field you want to format.

2. Click the Format box in the Field Properties section.

3. Enter the appropriate text formatting symbols.

Tips

- Remember that the Format property only changes how data is displayed onscreen, not how the data is actually stored in the field.

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: Open the tblCustomers table in Datasheet View and enter a new record. Add your own personal information to the fields, but enter the abbreviation in the State field in all lowercase letters. Display the table in Design View and type “>” in the State field’s format box. Save the changes and return to Datasheet View, where the State abbreviation is now uppercase.

![Figure 5-11: Formatting the State field to display only uppercase letters.](image)

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Text</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Aligns text from the right</td>
<td>Hello</td>
<td>!</td>
<td>Hello</td>
</tr>
<tr>
<td>&lt;</td>
<td>Lowercase</td>
<td>Hello</td>
<td>&lt;</td>
<td>hello</td>
</tr>
<tr>
<td>&gt;</td>
<td>Uppercase</td>
<td>Hello</td>
<td>&gt;</td>
<td>HELLO</td>
</tr>
<tr>
<td>“ABC”</td>
<td>Always displays quoted text</td>
<td>4</td>
<td>“oz.”</td>
<td>4 oz.</td>
</tr>
<tr>
<td>@</td>
<td>Character is required</td>
<td>5558000</td>
<td>@ @ @ @ @ @</td>
<td>555-8000</td>
</tr>
<tr>
<td>*</td>
<td>Fill available space with next character</td>
<td>Alert</td>
<td>*!</td>
<td>Alert !!!!!!!!!!</td>
</tr>
<tr>
<td>[color]</td>
<td>Displays value in color</td>
<td>Hello</td>
<td>[red]</td>
<td>Hello</td>
</tr>
</tbody>
</table>
Setting a Default Value

You can enter a default value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX.” When a user adds a record to the table, they can either accept the “TX” default value for the State field or enter their own value.

1. Make sure the table is displayed in Design view and click the field you want to add a default value to.

2. Click the Default Value box in the Field Properties section.

3. Enter the default value you want to appear in the field for new records.

Tips

✓ A common default value used in Date fields is the current date. To automatically add the current date, type =Date() in the field.

Exercise

Exercise File: CustomerTours.accdb

Exercise: In the tblCustomers table, make the default value for the State field “MN”. Save the change, switch to Datasheet View, scroll down to the New record row, and notice that MN is automatically entered in the State field.
Requiring Data Entry

In most tables, there are usually at least a few fields that absolutely must contain data in order for the record to be meaningful. For example, at the absolute minimum, a customer record needs to have the customer’s first and last name—otherwise, why bother entering it? You can specify that a field must contain data to prevent users from leaving out important information when they are entering data.

This lesson explains how you can make sure that a field has a value for each record.

1. Make sure the table is displayed in Design view and click the field you want to require data entry for.

2. Click the Required box in the Field Properties section.

   Here’s how to prevent a user from leaving out data in a field.

3. Click the list arrow and select Yes.

   From now on, if a user tries to add a record without entering a value for this field, Access will display a dialog box stating that the field cannot contain a null value.

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: In the tblCustomers table, make LastName a required field. Add a new field to the table, leaving the LastName field blank. Try to save the record (Access won’t let you). Delete the new record.
Validating Data

Without a doubt, data validation is the most powerful tool you can use to prevent data-entry errors. With data validation, Access actually tests data to make sure that it conforms to what you want to appear in the table. If the incoming data doesn’t meet your requirements, Access rejects it and displays an error message. For example, in an Employees table you could specify that the DOB field cannot be later than today’s date. (You can’t have employees with birthdays in the future, after all.)

Data validation works best in number, currency, and date/time fields. You can create a validation rule for text entries, but doing so can be complicated—especially if you want to test a lot of text variables.

There are actually two boxes that relate to data validation:

- **Validation Rule box**: Used to specify the requirements for data entered into the field.
- **Validation Text box**: Used to specify the message that will be displayed to the user when data that violates the validation rule is entered.

Creating data validation rules can be a little tricky—you create a data validation using the same hard-to-remember operators that you use in filters and queries. Here’s how:

1. Make sure the table is displayed in Design view and click the field you want to apply a validation rule to.

2. Click the **Validation Rule** box in the Field Properties section.

3. Enter an expression you want to use to validate the field’s data.

Table 5-6: Data Validation Examples describes some data validations that you can modify and use in your tables.

Next you have to specify the error message that Access will display if someone tries to break your validation rule by entering a future date.

4. Click the **Validation Text** box in the Field Properties section.

5. Type the text that Access will display when the user tries to enter incorrect data for the field.

Now whenever a user violates the validation rule, Access will display the validation text.

---

**Exercise**

- **Exercise File**: CustomerTours.accdb
- **Exercise**: In the tblCustomers table, add the validation rule “<Date()” to the DOB field. Add the validation text “Date must not be later than today’s date.” Save and switch to Datasheet View. Try to change the Date of Birth field for any record to tomorrow’s date and press <Enter>. Click OK and press <Esc> to cancel the change.

![Figure 5-14: Adding a validation rule and text in Design View.](image)

- **Figure 5-15**: If you break a validation rule, Access disallows the action and displays the validation text.
Consider Table 5-6: Data Validation Examples your data validation “cheat sheet.” It contains samples of the most common types of validation rules. Feel free to copy, modify, or mix and match these examples to create your own validation rules.

<table>
<thead>
<tr>
<th>Validation Rule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;100</td>
<td>Must be less than 100.</td>
</tr>
<tr>
<td>&lt;=100</td>
<td>Must be less than or equal to 100.</td>
</tr>
<tr>
<td>Between 1 and 10</td>
<td>Must be between 1 and 10.</td>
</tr>
<tr>
<td>&lt;&gt;0</td>
<td>Must not equal 0.</td>
</tr>
<tr>
<td>&lt;1/1/95</td>
<td>Must be a date before 1/1/95.</td>
</tr>
<tr>
<td>&gt;= Date()</td>
<td>Must be today’s date or later.</td>
</tr>
<tr>
<td>&lt;= Date()</td>
<td>Must be today’s date or earlier.</td>
</tr>
<tr>
<td>&quot;Business&quot; Or &quot;Pleasure&quot; Or &quot;Other&quot;</td>
<td>Must be “Business” or “Pleasure” or “Other.”</td>
</tr>
<tr>
<td>Like &quot;??&quot;</td>
<td>Must have two characters.</td>
</tr>
<tr>
<td>Like &quot;####&quot;</td>
<td>Must have four numbers.</td>
</tr>
</tbody>
</table>
Creating an Input Mask

An Input Mask limits the amount and type of information that can be entered in a field. You have probably already seen an example of an input mask on an ordinary paper form—the type of form that wants you to write down your phone number or social security number a certain way and thus provides you with a guide like (___) ___-____ or ____-____-_____. Look familiar? That’s an input mask, pure and simple.

There are two ways to create an input mask:

- **Use the Input Mask Wizard** to create the input mask for you (the fast and easy way). The only problem with the Input Mask Wizard is that it can only help you create input masks for phone numbers, social security numbers, Zip Codes, and date and time fields.

- **Create the input mask** yourself by typing a series of characters in the Input Mask box (the hard way). If you want to use this method, refer to Table 5-7: Input Mask Characters to see what you have to enter in order to create an input mask.

In this lesson you will learn how to use the Input Mask Wizard to add an input mask to a field.

1. Make sure the table is displayed in Design view and click the field you want to create an input mask for.

2. Click the Input Mask box in the Field Properties area (the bottom half of the window).

   The Build button appears next to the Input Mask box.

   **Other Ways to Create an Input Mask:**
   Enter characters directly into the Input Mask box in the Field Properties area.

3. Click the Build button to start the Input Wizard.

   The first step of the Input Mask Wizard appears. All you need to do here is select the input mask you want to choose.

   If you want to try an input mask to see how it works, click the input mask you want to use and then type some sample text in the “Try It” box.

4. Select an input mask from the predefined list and click Next.

   Here you can customize the input mask to your specifications.

5. Make modifications to the characters in the Input Mask box, if desired. Click the Placeholder
character list arrow to select a different placeholder, if desired. Click Next.

The next step of the Input Wizard is very important—specifying how Access should store your data. You have two choices:

- **With the symbols in the mask:** This will store only the text you type in the field and the input mask symbols. For example, if you enter 5555555555 in a Phone field, Access will save the input mask symbols with the text you enter, so (555) 555-5555 would be saved.

- **Without the symbols in the mask:** This will store only the text you type in the field. For example, if you enter 5555555555 in a Phone field, Access will display (555) 555-5555 but only store the numbers you typed (5555555555).

This may not seem like much of an issue, and really isn’t unless you want to export your table. Then you will have to work with the results of the decision you made here: the phone numbers will be in either 5555555555 or (555) 555-5555 format.

6. Select an option for storing your data and click Next. Click Finish.

Now whenever you enter data into that field, the input mask will appear to guide you.

---

### Table 5-7: Input Mask Characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Numbers 0 to 9 required; plus and minus signs not allowed.</td>
<td>&amp;</td>
<td>Character or space required.</td>
</tr>
<tr>
<td>9</td>
<td>Number or space optional; plus and minus signs not allowed.</td>
<td>C</td>
<td>Character or space optional.</td>
</tr>
<tr>
<td>#</td>
<td>Number or space optional; plus and minus signs not allowed.</td>
<td>&lt;</td>
<td>Converts the following characters to lowercase.</td>
</tr>
<tr>
<td>. , ; /</td>
<td>Decimal point, thousands, date, and time separators.</td>
<td>&gt;</td>
<td>Converts the following characters to uppercase.</td>
</tr>
<tr>
<td>A</td>
<td>Letter or number required.</td>
<td>!</td>
<td>Displays characters from right to left, rather than left to right.</td>
</tr>
<tr>
<td>a</td>
<td>Letter or number optional.</td>
<td>\</td>
<td>Displays the following input mask character. For example, * would display *.</td>
</tr>
<tr>
<td>L</td>
<td>Letters A to Z required.</td>
<td>Password</td>
<td>Displays an asterisk( * ) for each character you type.</td>
</tr>
<tr>
<td>?</td>
<td>Letter or number optional.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Creating a Lookup Field

Lookup fields are definitely one of the coolest and most powerful features in Access. A lookup field lets you pick a field’s entry from a list of values. There are two ways that a lookup field can get its list of values:

- **From a Lookup List:** A list of values in a table or query. For example, instead of entering a CustomerID number, you could select it from a list of customers.

- **From a Value List:** A list of values or options that you enter yourself. For example, you could add the values “FedEx,” “UPS,” and “AirBorne” to a Shipping field.

In this lesson, we’ll look at the first way—using a list of values in a table or query.

1. Display the table in Design view.

2. Click the field’s Data Type box, click the list arrow, and select **Lookup Wizard**.

   The Lookup Wizard dialog box appears, asking if you want your lookup field to get its values from another table or query or if you want to type a list of options yourself.

3. Click the **I want the lookup column to look up the values in a table or query** option and click **Next**.

   The next step in the Lookup Wizard is to select the table or query that contains the values for your lookup field. Because you can use queries to sort and filter information, consider using them as the source for your lookup fields.

4. Select the table or query you want to use for the lookup list and click **Next**.

   Now you have to select the fields that contain the values you want to display in your lookup field.

   This step can be a little confusing at first. You need to add the field that contains the value you want to enter—for example, the CustomerID field—but you also want to add several fields that will display more meaningful information in the value list, such as the LastName and FirstName fields.

5. Double-click the fields you want to add to the lookup field and click **Next**.

   **Other Ways to Add Fields:**
   Select the field in the Available Fields list and click the arrow buttons to add or remove them from the Selected Fields list.
The next step in the Lookup Wizard dialog box is selecting a sort order for your list. You can sort records by up to four fields, in either ascending or descending order.

6. Select a sort order for your list (optional) and click Next.

This next step allows you to adjust the width of the columns in your lookup list. To adjust the width of a column, drag its right edge to the width you want, or double-click the right edge of the column heading to get the best fit.

You can also indicate whether or not to include the primary key in the column by checking or unchecking the “Hide key column” check box. Any primary key fields will be hidden by default to make the lookup field less confusing.

✓ Tip: If the table or query you are working with does not have a primary key, the “Hide key column” check box will not appear. The Lookup Wizard will instead include an additional step where you will be prompted to select the column that uniquely identifies the row.

7. Adjust the width of the columns that will appear in the lookup list and, if necessary, select whether or not to hide the key column. Click Next. If necessary, click Next again.

8. Enter a label for the lookup column and click Finish.

✓ Tip: You can select to Allow Multiple Values. If you check this box, Access allows you to select multiple values from your list and store them in a single field (a multi-value field) For example, if a single product is made in two different countries, you can display both countries.

Now you can use the lookup list.

9. Click the Design tab under Table Tools on the Ribbon and click the View button in the View group to return to Datasheet View. Click Yes to save the table.

10. Click any record in the column where you created the lookup list. Click the list arrow and select a value from the list.

✓ Tip: You can also select an option from a lookup field by typing the first few letters of the entry.

Figure 5-19: A Lookup List.
Creating a Value List

Similar to the lookup list, a value list displays a list of values in a drop-down list. Unlike a lookup list, which displays data in a table or query, a value list displays a list of options that you manually enter. A value list is useful if you enter the same data in a field again and again. For example, if you ship a product using three different courier services, you could create a value list that displays the three courier services, such as AirBorne, FedEx, and UPS.

Although it’s possible to change the options displayed in a value list, doing so is a rather cumbersome process. For that reason, you should only use value lists for values that will not change very often. If you want to display a lot of options, such as a list of state abbreviations or values that may change frequently, you should create a table to store those values and then display them with a lookup list instead. It’s a lot easier to change values in a table than it is to change options in a value list.

This lesson will show you how to create a value list that contains several static options.

1. Display the table in Design view.

2. Click the field’s Data Type box, click the list arrow, and select Lookup Wizard.

   The Lookup Wizard dialog box appears, asking if you want your lookup field to get its values from another table or query or if you want to type a list of options yourself.

3. Click the I will type in the values that I want option and click Next.

   The next step of the Lookup Wizard appears. This step is pretty easy—simply enter the options you want to be displayed in the value list.

4. In Col1, enter the values you want to be displayed in the value list. Resize the column if necessary and click Next.

   Tip: There is only one column of values by default, but you can add more. If you do so, an extra screen will appear after you click Next, asking you which of the column contains the values you actually want to store in the database (the other columns will just be there to give you more information about which value to select).

5. Enter a label for the lookup column and click Finish.

   Tip: Here you can select to Allow Multiple Values. If you check this box, Access will allow
you to select multiple values from your list and store them in a single field.

Once you return to Datasheet View and click the list arrow in any record in the column, you’ll be able to see the value list you entered and select a value to populate the field.
Modifying a Lookup List

Modifying an existing lookup field isn’t nearly as straightforward as creating one. You can display and modify the properties for a lookup field by clicking on the Lookup tab in the Field Properties section. There are many different reasons why you would want to modify a lookup field, including:

- To sort the records in a lookup list. For example, to sort the records in a lookup list alphabetically by last name.
- To add, change, or delete the static options in a value list. For example, you could add “U.S. Postal Service” to a Ship Via value list.

Modify a lookup list

1. Display the table in Design view.
   Display and change the properties for a lookup field by clicking the Lookup tab in the Field Properties section.

2. Click the field name for a field that contains a lookup list based on a table or query, then click the Lookup tab in the Field Properties section.
   The properties for the field’s lookup field are displayed. You can learn more about these properties in Table 5-8: Lookup Field Properties.

3. Click the Row Source box.
   The data in this box (which should look something like SELECT [tblCustomers].[CustomerID]) is a SQL statement. SQL (Structured Query Language) is a language most database programs use to create queries; it tells lookup fields where to get their values. Fortunately, you don’t have to know how to write SQL to modify a lookup field—you can use the familiar query grid to create the SQL statement for you.

4. Click the Row Source button.
   The Query Builder window appears, displaying a query grid. Here you can change the fields included in the lookup list, or you could add or remove a sort.

5. Make the desired changes and then click the Query Builder window’s Close button. Click Yes to save the changes.
Modify a value list

1. Display the table in Design view.
   Display and change the properties for a lookup field by clicking the Lookup tab in the Field Properties section.

2. Click the field name for a field that contains a value list, then click the **Lookup** tab in the Field Properties section.
   The properties for the field’s lookup field are displayed.

3. Click the **Row Source** box.
   The Row Source box contains the value list options. For example, it could contain the text "Airbone";"FedEx";"UPS". You can add or edit options in the value list by typing in the Row Source box—just make sure that the options are enclosed by quotation marks (" ") and separated by a semi colon (;).

4. Edit the value list options as desired in the Row Source box.

5. Save your changes.

Table 5-8: Lookup Field Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Control</td>
<td>Determines whether the lookup field is a text box, combo box, or list box.</td>
</tr>
<tr>
<td>Row Source Type</td>
<td>Determines how Access provides data to the lookup field: from a table or query, from a list of values specified in the Row Source box, or from a list of field names in a table or query.</td>
</tr>
<tr>
<td>Row Source</td>
<td>Determines what is displayed in the lookup field. The Row Source property setting depends on the Row Source Type property setting.</td>
</tr>
<tr>
<td>Bound Column</td>
<td>The column in the lookup list that contains the value that is actually stored in the field. The bound column is the first column (1) by default.</td>
</tr>
<tr>
<td>Column Count</td>
<td>The number of columns that are displayed in the lookup field list.</td>
</tr>
<tr>
<td>Column Heads</td>
<td>Determines whether the field names, captions or first row of data is used as a column heading.</td>
</tr>
<tr>
<td>Column Widths</td>
<td>The width of each column that is displayed in the lookup field list. Setting a column width to 0 hides the column.</td>
</tr>
<tr>
<td>List Rows</td>
<td>The maximum number of rows that appear in the list box.</td>
</tr>
<tr>
<td>List Width</td>
<td>The width of the list box that is displayed.</td>
</tr>
<tr>
<td>Limit to List</td>
<td>Determines whether a field can accept a value that is not in the lookup list.</td>
</tr>
<tr>
<td>Allow Multiple Values</td>
<td>Determines whether multiple values for this lookup column are allowed.</td>
</tr>
<tr>
<td>Allows Value List Edits</td>
<td>Determines whether the values in the lookup column can be edited.</td>
</tr>
<tr>
<td>List Items Edit Form</td>
<td>Lists a form to open when lookup values are being edited.</td>
</tr>
<tr>
<td>Show Only Row Source Values</td>
<td>Determines whether only values that match the row source are displayed.</td>
</tr>
</tbody>
</table>
Working with Tables and Fields

Quiz Questions

46. To view and modify the Field Properties for a table, open the table in ________ View.
   A. Table
   B. Property
   C. Design
   D. Datasheet

47. Indexing fields speeds up searching and sorting. (True or False?)

48. Which of the following fields would NOT make a suitable primary key?
   A. A memo field
   B. A social security number
   C. An AutoNumber field
   D. An invoice number

49. In Design View, commands for inserting and deleting columns are found on the Design tab in the ________ group.
   A. Show/Hide
   B. Tools
   C. Add
   D. Insert

50. Text entered in a field’s Description box will appear in a pop-up window whenever a user selects that field. (True or False?)

51. The Field Size property works differently, depending on whether the field is a text or number field. (True or False?)

52. Changing the formatting of a field changes how the information is stored in the field. (True or False?)

53. Which of the following Format properties would display the full name of the month?
   A. mmmm
   B. mm
   C. FULLMONTH
   D. MONTH

54. What would adding a > to the Format box of a text field do?
   A. Require all characters entered in the field to be uppercase.
   B. Display the text in the field in uppercase.
   C. Require all characters in the field to be numbers.
   D. Display the text in the field in a larger font.
55. Which of the following can you use to specify a value that is automatically entered in a field when a new record is created?
   A. A lookup value
   B. A numeric value
   C. An automatic value
   D. A default value

56. The Required property determines if a user must enter a value in a field or not.

57. There are two properties that relate to validation. (True or False?)

58. An input mask only affects how information is displayed in a field - not how it is actually stored. (True or False?)

59. You want to create a field that lets you add a customer's name by picking it from a list arrow. Which of the following fields would let you do this?
   A. A memo field
   B. An OLE field
   C. A lookup field
   D. A hyperlink field

60. A value list looks up values in a table or query. (True or False?)

61. Where in the Field Properties can you go to modify a Value or Lookup list?
   A. The Lookup tab
   B. The General tab
   C. The Lookup field
   D. The SQL field

---

**Quiz Answers**

46. C. Display a table in Design View to see its Field Properties.
47. True. Indexing allows you to search or sort fields faster.
48. A. You can’t use memo fields as primary keys.
49. In Design View, commands for inserting and deleting columns are found on the Design tab in the Tools group.
50. False. Text in the field’s Description box will appear in the Status bar when a user selects that field.
51. True. Text fields and Number/Currency fields have a different set of Field Size properties.
52. False. Formatting a field only changes how the field displays information, not how it stores it.
53. A. mmmm would display the full name of the month.
54. B. Adding a > to a text field’s Format box would display all its text in uppercase.
55. D. A default value lets you specify a value that is automatically entered in a field when a new record is created.
56. True. The required property does determine if a user must enter a value in a field or not.
57. True. The Validation Rule and Validation Text properties both help you create a validation.

58. False. Depending on your preferences, an input mask can store information with or without symbols (i.e. (800) 555-1212 vs. 8005551212).

59. C. A lookup field lets you select a value from a list arrow.

60. False. A value list contains a list of preset values. A lookup list looks up values in a table or query.

61. A. The Lookup tab lets you modify a Value or Lookup list.
This chapter covers what many people agree is one of the most difficult database concepts—how to create and work with relational databases. A relational database contains two or more tables that are related to each other in some way. For example, a database might contain a Customers table and an Invoices table that contains the customer’s orders.

In this chapter you will learn how to link tables in an existing database together in a one-to-many relationship to create a relational database. You will also learn how to enforce referential integrity between those tables to keep records in related fields valid and accurate.

Relational databases can be confusing at first, so we’ll take things slowly and explain everything in great detail as we go. Let’s get started!

**Using Exercise Files**
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Understanding Table Relationships

There are two basic types of databases:

- **Flat File**: Think of a Rolodex when you think of a flat-file database. A flat-file database stores all of its information—names, addresses, etc.—in the same place, just like addresses are stored on a Rolodex card. Flat-file databases are incredibly simple to create and use, but they’re not very powerful or well suited to many business tasks.

- **Relational**: A relational database contains multiple tables that are related through matching fields. Figure 6-1 illustrates the design of a relational database. It has two tables—one that stores customer names and addresses, and another that stores customer orders. The two tables are related or linked by a common field. Relational databases are very powerful, but developing one takes a lot of skill, a lot of practice, and a strong understanding of tables and fields.

Microsoft Access can create either type of database—flat file or relational. However, most Access databases tend to be of the relational type.

Still fuzzy about how relational databases work? Look closer at Figure 6-1. To track customers and their orders, the database uses two tables: Customers and Orders. Each table contains fields that store similar information. The Customers table contains only information about customers and their addresses. The Orders table contains only information about any orders that were placed—it doesn’t contain any information about the customers. The two tables both have an ID field, and it’s this ID field that relates or links the two tables.

Relational databases save storage space by cutting down on duplicate data. For example, the database in Figure 6-1 stores information in two related tables and eliminates the need to reenter a customer’s name and address each time that customer places a new order.

Planning a relational database

Relational databases require lots of planning ahead. Before you attempt to create one, sit down with a pen and paper and walk through the following steps:

- **Determine the Purpose of the Database**: Write down a list of the reports and lists that you want to come out of the database. This may seem a little backward at first, but these reports are the reason you’re creating the database.
Make a list of the reports and lists you want to see and then sketch some samples of these reports and lists—be as detailed as possible. This will help determine the tables and fields to include in your database.

- **Write Down the Fields You Need:** This should be an easy step once you have determined the purpose of your database and have sketched some sample reports and lists.

- **Organize and Group Related Fields into Separate Tables:** Each table in the database should be based on only one subject. By breaking each subject into its own table, you avoid redundant information and make the database more organized. If your table contains fields like Item 1, Item 2, Item 3, Item 4, and so on, you should probably break each item up into its own table.

- **Identify and Add Fields Common to Each Table:** In Figure 6-1, the Customers table’s ID field links to the Orders table’s ID field. One of the linked fields should be the table’s primary key.

- **Sketch a Diagram of Your Database:** Create a diagram of your database similar to the one shown in Figure 4-3. Draw a box for each of your tables and write the table’s field names inside that box. Draw a line between the related fields. Most table relationships are a one-to-many relationship. This means that a record in one table may be related to one or more records in another table.

  For example, in Figure 6-1, each record in the Customers table is related to one or more records in the Orders table. This makes sense because, hopefully, most customers will place more than one order. You should indicate the two sides of the relationship by drawing a “1” on the “one” side of the relationship line and an infinity symbol on the “many” side of the relationship line.

All this writing and planning may seem like a lot of work, but they’re both critical steps in creating a sound database.
Creating Relationships Between Tables

Once you begin to understand the concept of relational databases, the process of actually linking the tables in a database is rather simple. You link related tables by connecting the table’s common fields in Access’s Relationships window. The Relationships window lets you view, create, and modify relationships among tables in a database.

Keep the following rules in mind as you link two tables:

- Linked fields should be (almost) identical.
- Related fields must have the same data type and field size and must contain the same kind of information. Related fields don’t have to have the same field name but they should, to avoid confusion. The most common problem people have when they try to link two tables is caused by fields with different data types and/or sizes.
- The primary key in one table is usually linked with a matching field in the other table.
- Fields related to an AutoNumber primary key field must be Number fields with the Long Integer Field Size.

Now you’re ready to create a relationship between the tables in your database. Here’s how:

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group.
   
The Design contextual tab appears under Relationship Tools and a Relationships window appears.
   
   Tip: If relationships already exist between the tables in your database, each of these tables will appear in a small box with lines connecting the table’s linked fields.

   First you have to add the tables that you want to relate using the Show Table dialog box.

2. Click the Show Table button in the Relationships group.
   
The Show Table dialog box appears.

3. Click the table you want to add and click Add. Repeat as necessary.
   
The table appears in the Relationships window.

Exercise

- Exercise File: Company.accdb
- Exercise: Open the Relationships window and add the tblCustomers, tblCustomerTours, and tblTours tables to the window. Link the TourID field in the tblTours table to the TourID field in the tblCustomerTours table. Save the change.

Figure 6-3: The Relationships group.

Figure 6-4: The Edit Relationships dialog box.

Figure 6-5: Linked tables in the Relationships window.
4. Click the Close button in the Show Table dialog box.

Now you’re ready to start relating the tables you added. Relating tables may sound difficult, but it’s really nothing more than dragging and dropping the field you want to use to link one table to the other.

✔ Tip: Before you can drag and drop the matching field from one table to the other, you have to make sure the linking fields in both tables are visible.

5. Click the related field in the first table and drag it to the related field in the second table.

Dragging a field from one table to another in the Relationships window links the two tables using the selected field.

✔ Tip: Access is very picky about where you point, click, drag, and drop. You need to be very accurate and drag the pointer right next to the field you’re linking to.

The Edit Relationships dialog box appears. What’s especially important here is the Enforce Referential Integrity check box. Referential integrity helps you avoid “orphan” records and maintains database accuracy. For example, checking the Enforce Referential Integrity box would ensure that you could not enter an invoice for a customer in an Invoice table unless that same customer existed in a Customers table. We’ll discuss referential integrity more in another lesson.

6. Check the Enforce Referential Integrity (optional), then click the Create button to create the relationship.

The tables are now linked.

7. Click the Close button in the Relationships group on the Design tab and click Yes to save the changes.

⚠ Other Ways to Relate Tables:
Display a table in Datasheet View, click the Table tab under Table Tools on the Ribbon, and click the Relationships button in the Relationships group to display the Relationships window.

✔ Tips
✓ If you can’t see all your table relationships, click the All Relationships button in the Relationships group on the Design contextual tab under Relationship Tools on the Ribbon.
Enforcing Referential Integrity

When you create a relationship between two tables, it is usually a good idea to enforce referential integrity. What does that mean? Referential integrity keeps records in related fields valid and accurate. Referential integrity ensures that you don’t accidentally change or delete related data in one table but not in the other. For example, say you were using two related Social Security fields to link two tables. Referential integrity would not allow you to change the Social Security number in one record without changing the Social Security number in the other related records.

Access is very picky about when you can set referential integrity. You can only use referential integrity when all of the following conditions are met:

- One of the linked fields is a primary key
- The related fields are the same data type and size. (If you are using an AutoNumber field, you can relate it to a Number field with a Long Integer Field size.)
- Both tables are in the same Access database.
- You can’t have a record in a related table unless a matching record already exists in the primary table. Orphan data in a related table is the most common problem people encounter when attempting to establish referential integrity.

Once you have established referential integrity, the following rules are set:

- You can’t add a record to a related table unless a matching record already exists in the primary table.
- You can’t change the value of a primary key in the primary table if matching records exist in the related table (unless you select the Cascade Update Related Fields option).
- You can’t delete a record from a primary table if matching records exist in a related table (unless you select the Cascade Delete Related Records option).

In this lesson you will learn how to enforce referential integrity.

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group. The Relationships window appears.
2. If necessary, click the Design contextual tab, click the Show Table button in the Relationships group, and add tables to the Relationships window.

Once you have more than one table added, you can relate the tables and enforce referential integrity.
Creating Relational Databases

3. Click the related field in the first table and drag it to the related field in the second table.

The Edit Relationships dialog box appears.

**Other Ways to Display the Edit Relationships Dialog Box:**
To edit (instead of create) a relationship, double-click the line connecting the tables to display the Edit Relationships dialog box. Or, click the Edit Relationships button in the Tools group on the Design tab.

Now let’s enforce referential integrity.

4. Check the Enforce Referential Integrity box.

If you get an error message, it’s because your tables and fields don’t meet all required conditions.

There are two other very important boxes in the Edit Relationships dialog box:

- **Cascade Update Related Fields:** When you change data in the main field of one table, Access will automatically update the matching data in the related table.

- **Cascade Delete Related Records:** When you delete a record in the main table, Access will automatically delete any matching records in the related table.

Think twice before using these powerful options.

5. If you want changes to the primary field of the primary table copied to the related field in the related table, check the Cascade Update Related Fields box.

6. If you want Access to automatically delete orphan records in the related table, check the Cascade Delete Related Records box.

7. Click Create to create the relationship (or click OK if you are editing an existing relationship).

Access creates the relationship between the two tables and enforces referential integrity between them. Notice that the join line between the tables looks different than normal. This relationship indicates that referential integrity is being enforced between the two tables and that the tables have a one-to-many relationship (more about that in another lesson).

8. Click the Close button in the Relationships group on the Design tab and click Yes to save the changes.
## Printing and Deleting Relationships

Sometimes you may want to print a hard copy of the Relationships window or you may want to delete the relationship between two tables.

### Print the Relationships window

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group.
   The Design contextual tab appears under Relationship Tools.

2. Click the Relationship Report button in the Tools group.
   A report showing the tables and relationships appears in Print Preview mode.
   **Tip:** If you want to modify the report before printing, click the Close Print Preview button and edit the report in Design View.

3. Click the Print button in the Print group on the Print Preview tab.
   The Print dialog box appears.

4. Select desired print settings and click OK.
   The Relationships report is printed.

5. Click the Close Print Preview button in the Close Preview group.
   The report appears in Design View.

6. Click the Relationships report’s Close button and save changes if you want to use the report in the future.

### Delete a table relationship

Access is very restrictive about letting you modify a related table, and often you must temporarily delete the relationship between two tables, modify one of the tables, and then re-connect them. Here’s how to delete a table relationship.

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group.
   The Design contextual tab appears under Relationship Tools.

---

### Exercise

- **Exercise File:** Company.accdb
- **Exercise:** Display a Relationship Report in Print Preview.
  Right-click the join line between the tblTours table and the tblCustomerTours table and select Delete, but then click No to cancel deletion of the link.

---

**Exercise File:** Company.accdb

**Exercise:** Display a Relationship Report in Print Preview.

Right-click the join line between the tblTours table and the tblCustomerTours table and select Delete, but then click No to cancel deletion of the link.

---

**Figure 6-8:** A Relationship Report in Print Preview mode.

**Figure 6-9:** Deleting a table relationship.
Creating Relational Databases

2. Click the join line that connects the tables and press \textless Delete\textgreater.

3. Click Yes to confirm the deletion.

The table relationship is removed.

\textbf{Other Ways to Delete a Table Relationship:}
Right-click the join line connecting the related tables and select Delete. Click Yes.
Understanding Relationship Types

When you link two tables together, they form one of three possible relationships. This information is rather technical, but it’s good to know if you’re working with related or linked tables. Look over Table 6-1: Types of Relationships to get a better understanding of table relationships.

Table 6-1: Types of Relationships

<table>
<thead>
<tr>
<th>Relationship:</th>
<th>Description:</th>
</tr>
</thead>
<tbody>
<tr>
<td>One to One</td>
<td>Each record in a table relates to one record in another table. This is the simplest type of relationship, but it doesn’t occur very often because it’s usually easier to store such information in one table instead of two. <strong>Example:</strong> Each customer has one credit report.</td>
</tr>
</tbody>
</table>

| One to Many   | Each record in a table relates to one or more records in another table. This is the most common type of relationship. **Example:** Each customer has one or more invoices. |

| Many to Many  | One or more records in a table relate to one or more records in another table. Many-to-many relationships can be very confusing. To create a many-to-many relationship, use a third intermediate table that contains the primary keys from each of the two tables in the relationship. Such an intermediate table is called a junction table. **Example:** Each sales representative sells several products, and each product is sold by several sales representatives. |

Exercise

- **Exercise File:** None required.
- **Exercise:** Study the table in the lesson to understand the types of table relationships.

Creating Relational Databases
Creating Relational Databases Review

Quiz Questions

62. A flatfile database stores information in a single table. (True or False?)

63. You can use fields with different data types to link two tables. (True or False?)

64. If the Cascade Delete Related Records referential integrity option is selected, when you delete a record in the main table, Access will automatically delete any matching records in the related table. (True or False?)

65. Once you create a relationship between tables, that relationship can never be deleted. (True or False?)

66. Which of the following is NOT a type of table relationship in Access?
   A. One to One
   B. One to Many
   C. Infinite
   D. Many to Many

Quiz Answers


63. False. With the exception of AutoNumber and Number fields, related fields must always have the same data type in order to be used to join two tables.

64. True. The Delete Cascade Related Records option automatically deletes records in any related tables.

65. False. You can delete table relationships.

66. C. Infinite is not a type of table relationship in Access.
Queries are the stars of Microsoft Access. Queries make sense out of all the thousands of jumbled records and display exactly what you need to know. Queries can tell you the average price of tea in China or which customers bought the most parakeet food from your company. Queries can even make widespread changes to the records in your database without wearing out your mouse and keyboard! For example, a delete query can automatically delete a whole bunch of records that meet your criteria.

In this chapter you will learn how to harness the power of queries. First you will learn about all the different types of queries: simple select queries, parameter queries that prompt you for more information, crosstab queries that summarize records in an easy-to-understand format, and action queries that actually modify the records in your database.

All this power comes with a price tag: Many people find that queries are one of the more difficult database objects, and learning how to fully utilize queries isn’t something you can learn in an afternoon. By the time you finish this chapter, however, you will be on your way toward understanding and mastering queries.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Understanding Different Types of Queries

Up until now, when you thought of a query, you were actually probably thinking of a select query—a particular type of query. Select queries are by far the most common and useful type of query in Access; however, there are other types of queries that are also important. Table 7-1: Types of Queries provides a quick overview of different types of queries you’ll find in Microsoft Access.

<table>
<thead>
<tr>
<th>Types of Queries</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Query</td>
<td>The most basic and common type of query, select queries find and display the data you want from one or more tables or queries.</td>
</tr>
<tr>
<td>Parameter Query</td>
<td>Prompts the user for specific information every time the query is run.</td>
</tr>
<tr>
<td>Crosstab Query</td>
<td>Summarizes data in a table format that makes it easy to read and compare information.</td>
</tr>
<tr>
<td>Make Table Query</td>
<td>Creates a new table from all or part of the data in one or more tables. Useful for backing up and exporting information.</td>
</tr>
<tr>
<td>Append Query</td>
<td>Appends or adds selected records from one table to another table. Useful for importing information into a table.</td>
</tr>
<tr>
<td>Delete Query</td>
<td>Deletes selected records from one or more tables.</td>
</tr>
<tr>
<td>Update Query</td>
<td>Updates selected information in a table. For example, you could raise the prices on all trips to Europe by 15 percent.</td>
</tr>
<tr>
<td>Union Query</td>
<td>Combines fields from two or more tables or queries into one field and is written directly in SQL.</td>
</tr>
<tr>
<td>Pass-Through Query</td>
<td>Allows you to work directly with tables on an ODBC database server, instead of having the Access database on your local computer process the data.</td>
</tr>
<tr>
<td>Data Definition Query</td>
<td>Does not retrieve data (unlike other types of queries). Can be used instead of the Access graphical interface to create tables, constraints, indexes, and relationships. Should only be used by users who are experienced with SQL statements and who plan to delete and re-create these items regularly.</td>
</tr>
</tbody>
</table>

**Figure 7-1:** The Query Type group on the Design tab.
Creating a Multiple Table Query

In Access you will often need to look at and analyze information that comes from not one but several different tables. Since Access is a relational database, it’s easy to establish a relationship between two or more tables and look at the information that goes together.

Just like it sounds, a multiple-table query blends together information from two or more related tables. Working with a multiple-table query usually isn’t much different from working with a single-table query. You tell Access which tables you want to use in your query and specify the fields and criteria you want to see. The main difference between a multiple-table query and a single-table query is that with multiple-table queries, Access creates a link between related tables. When the query is displayed in Design View, this link (called a join) appears as a line that connects two or more tables.

When you create a multiple-table query, Access will usually link or join the tables automatically. Sometimes, however, you will have to manually join two tables in the query design window. You can manually join two tables by dragging a field from one table’s field list to the matching field in the other table’s field list. If the tables don’t have any fields in common, you must add another table to act as a bridge between them.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.
   The Show Table dialog box appears. Here you need to choose the tables or queries you want to use for the query.

2. Select the table or query you want to use and click Add.

3. Repeat Step 2 as necessary for additional tables or queries. Click Close when you’re finished.
   If two tables are related, Access will automatically connect their common fields with a join line. If the tables aren’t related you will have to manually join the tables by dragging a field from one table’s field list to the matching field in the other table’s field list.

   ✔️ Tip: To remove a join line, click the join line and press <Delete>.

Exercise

- **Exercise File:** Query.accdb
- **Exercise:** Create a multiple table query with limiting criteria:
  Create a query in Design View. Add the tblEmployees, tblCustomerTours, and tblTours tables to the query. Link the EmployeeID field in the tblEmployees table with the Employee field in the tblCustomerTours table.
  Add the following fields to the design grid:

<table>
<thead>
<tr>
<th>tblEmployees</th>
<th>tblTours</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>LastName</td>
<td>FirstName</td>
<td>TourName</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cost</td>
</tr>
</tbody>
</table>

Add the criteria “Between 1/1/00 and 3/31/00” to the Date column. Sort the Date column Ascending. Save the query as qryFirstQuarterTours. Run the query.
4. If Access doesn’t automatically join the tables, click the related field in the first table and drag it to the related field in the second table. Repeat as necessary to connect all the tables.

Next you need to specify the fields you want to appear in the query results. Because field lists don’t have much room to display their contents, you may have to scroll up or down the list in order to find the field you want.

5. Double-click each field you want to include in the query from the field list.

> **Other Ways to Add a Field to a Query:**
> Drag the field from the field list onto the design grid.

Next you need to specify any criteria for the query.

6. In the design grid, enter any desired search criteria for a field in the Criteria row.

7. If desired, click in the Sort box for a field, click the list arrow, and select a sort order.

8. Click the Save button on the Quick Access Toolbar, enter a name for the query, and click **OK**.

9. Click the Run button in the Results group.
   The query results appear in Datasheet View.

10. Click the query window’s **Close** button.
Creating a Calculated Field

Normally, when you create a database, you should only have to enter the information you need and not have to worry about data or values that Access calculates based on information that is already stored in the database. A calculated field performs some type of arithmetic on one or more fields in a database to come up with a completely new field. For example, if your database has an Order Total field and a Tax Rate field, Access can calculate these two fields to find out the Sales Tax for each order: \[ \text{[Order Total]} \times \text{[Tax Rate]} = \text{[Sales Tax]} \].

You must create an expression (or formula) to perform a calculation. To enter fields in an expression, type the field name in brackets ([Order Total]). If a field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets ([Customer Tours]) followed by an exclamation mark (!). Then type the field name in brackets, such as [Order Total]. For example if an Orders table and a Shipping table both contain a Date field, you would tell Access which of the two Date fields you want to use by typing the table name ([Orders]), an exclamation mark (!), and then the field name ([Date]) or, in other words, [Orders]![Date].

This lesson will show you how to add a calculated field to a query.

1. Display the query in Design view.
2. Click the Field row of a blank column in the design grid.
3. Enter the field name for the field that will display the results of the calculation, followed by a : (colon).
4. Enter the expression you want Access to calculate, using the proper syntax.

For example, the expression Bonus:[Cost]*[Commission] will create a new calculated field named “Bonus” that will display the results of the Cost field from one table multiplied by the Commission field from another table.

**Tip:** Use arithmetic operators such as multiplication (*), addition (+), subtraction (-), division (/), and exponentiation (^) to create your expressions.

### Exercise
- **Exercise File:** Query.accdb
- **Exercise:** Create a calculated field to calculate employee bonuses:
  Open the qryEmployeeSales query in Design View. Create a calculated field that multiplies the Cost field in the tblCustomerTours table by the Commission field in the tblEmployees table (hint: Bonus:[Cost]*[Commission]). Run the query and save it as qryEmployeeBonus (hint: use the Save Object As command on the File tab).
5. Click the **Design** tab under Query Tools on the Ribbon and click the **Run** button in the **Results** group.

   Access displays the results of the query. The “Bonus” calculated field multiplies the Cost field by the Commission field in each record and displays the results.

   If you’ve been modifying an existing query, you can save the changes as a new query.

6. Click the **Save** button in the Quick Access Toolbar. Enter a query name and click **OK**.

   Access saves your changes in a new query.

   **Other Ways to Create a Calculated Field:**
   You can also use the Expression Builder—covered further in another lesson—to help you create your calculated fields.
You can add calculations to queries, forms, and reports by typing an expression. An expression is simply a formula that tells Access exactly what to calculate. An expression can be any combination of values, identifiers (such as the value in a field), and operators that result in a value.

Here’s an example of an expression that calculates profit from two fields called Income and Expenses:

**Profit:** `[Income] – [Expenses]`

You can also use constants in an expression, such as:

**Commission:** `[Sales] * .15`

Number fields aren’t the only types of fields that you can use in expressions—you can also perform calculations with dates, times, and text data. Here’s an example of an expression that combines text:

**Agent:** `[FirstName] & " " & `[LastName]`

In this example, the ampersand (&) symbol is used to combine or concatenate two or more text fields. The " " adds a space between the `[FirstName]` and `[LastName]` fields.

The problem with creating expressions is that you have to enter a formula so that Access understands it. For example, when you create an expression, some types of information must be enclosed between special characters so that Access knows what type of information it is—table names and field names must be enclosed in [brackets], text strings in "quotation marks," and so on.

Table 7-2: How Types of Data Should Look in an Expression has more information about how to use various elements in an expression.

If you know what you want an expression to do but not how to write it, you can try using the Expression Builder. The Expression Builder lets you pick the fields, mathematical symbols, and functions you can use to create an expression.

### Use the Expression Builder

1. Display the query in Design view.

   **Tip:** In this lesson, we’ll look at how to use the Expression Builder with a query, but you can also use it to create expressions in tables, forms, and reports.

   **Exercise File:** Query.accdb

   **Exercise:** Manually create an expression to combine the FirstName and LastName fields:

   Open the qrySales query in Design View. In the design grid, insert a new column before the Normal Price column. In the new column, enter `Agent:[FirstName]& " " & [LastName]` in the Field row.

   Use the Expression Builder to create an expression that calculates the cost of a tour:

   Click in the field row of a blank column and display the Expression Builder. Multiply Normal Price by Number of Tickets and click OK. Replace “Expr1” in the field name with “Total”. Run the query and save the changes.

---

**Figure 7-6:** Expressions in the design grid.

**Figure 7-7:** The Expression Builder dialog box.
Working with Queries

2. Click the **Field** row of a blank column in the design grid.
   
   Now you need to enter the expression. You can enter it manually, but let’s look at how to use the Expression Builder tool to make it easier.

3. Click the **Design** tab under Query Tools on the Ribbon and click the **Builder** button in the Query Setup group.
   
   The Expression Builder appears. The Expression Builder contains an area where you can build the expression, buttons you can use to build the expression, and the fields and controls in the current query, report, or form.

   ☝️ **Other Ways to Open the Expression Builder:**
   
   Right-click an empty field in the design grid and select **Build** from the contextual menu.

4. Select a field to use in the calculation, click the button that corresponds to the calculation you want, and then click or type any other fields or values you want to use.

5. Click **OK**.
   
   The Expression Builder closes. Add a meaningful label to the new calculated field.

6. In the new calculated field, replace the Expr1: label with a more meaningful field name.

7. Save and run the query.

Microsoft Access is very strict about how you write your expressions. If your expressions aren’t written in the correct syntax, they won’t work. Use the following table as a guideline for adding fields, text, and constants to your expressions.

<table>
<thead>
<tr>
<th>Table 7-2: How Types of Data Should Look in an Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text</strong></td>
</tr>
<tr>
<td><strong>Date/Time</strong></td>
</tr>
<tr>
<td><strong>Field Name</strong></td>
</tr>
<tr>
<td><strong>Field Name in a Specific Table</strong></td>
</tr>
<tr>
<td><strong>Concatenated (Combined) Text and Fields</strong></td>
</tr>
<tr>
<td><strong>Calculated Field (Using Two Fields)</strong></td>
</tr>
<tr>
<td><strong>Calculated Field (Using a Field and a Constant)</strong></td>
</tr>
</tbody>
</table>
Using an IIf Function

Functions are used to create complicated calculations or expressions. For example, the SUM function adds several values together, and the IPmt function calculates the loan payments based on an interest rate, the length of the loan, and the principal amount of the loan.

There are several hundred functions in Access, but all of them are used in a similar way: the name of the function, followed by the arguments in parentheses. An argument in Access is the value a function uses to perform its calculation. For example, the argument in the formula πr² would be r, or the radius, used to find the area of a circle.

This lesson introduces a very useful database function: the IIf function. The IIf function is a conditional function or logical function because it evaluates a condition and returns one value if the condition is true and another value if the condition is false. For example, you could use the IIf function in an invoice to create a formula that would subtract a 5-percent discount from the invoice if the total were more than 500 dollars—otherwise, the IIf function wouldn’t subtract anything. Or, you could create an IIf function to create a field that gives passengers a 50-dollar rebate if they fly first class and a 25-dollar rebate if they fly coach.

The IIf function contains three arguments, but since you can use the Expression Builder to help you create IIf function formulas, you really don’t need to memorize the syntax of the function.

1. Display the query in Design view.

2. Click the Design tab under Query Tools on the Ribbon and click the Builder button in the Query Setup group.

   The Expression Builder appears. In the bottom-left of the window, the Expression Builder displays a list of several folders that contain information.

   For example, the Tables folder contains a list of all the tables in the current database. These folders are displayed in a hierarchical view. A plus symbol or a minus symbol next to a folder means a folder contains several subfolders. Normally, these subfolders are hidden. You can display the hidden folders within a folder by double-clicking the folder. To see the contents of a folder, simply select the folder—its contents will appear in the middle and left windows.

   Exercise

   • Exercise File: Query.accdb
   • Exercise: Use the IIf function to provide a $50 rebate to first class passengers and a $25 rebate to coach passengers: Open the qrySales query in Design View. In the design grid, click in the first open Field column and display the Expression Builder. Add the IIf function to the expression box. Replace the «expr» argument with the First Class field from the tblCustomerTours table. Type “=True”. Replace «truepart» with 50 and «falsepart» with 25. Click OK. In the new calculated field, replace “Expr1” with “Rebate”. Run and save the query.

   Rebate: IIf([First Class] = True, 50, 25)

   Figure 7-8: The syntax for the IIf function.

   If First Class = True (or 1)...  ...then Rebate = 50...

   ...otherwise (if First Class does not = True or 1) Rebate = 25)

   Figure 7-9: Here the IIf function evaluates the value in the First Class field and returns 50 if the First Class field is True and 25 if the First Class field is False.
3. Double-click the **Functions** folder in the bottom-left window.

The Functions folder expands and displays its contents. The Built-In Functions folder contains several hundred functions that are included in Access.

4. Click the **Built-In Functions** folder, scroll down the middle window and click the **Program Flow** category, double-click the **IIf** function in the right column.

Access adds IIf («expr», «truepart», «falsepart») to the expression box. Now that you know the proper syntax of the IIf function, you need to replace the argument names with the data values. You can double-click to select any argument name so that you can replace it with your own value.

5. Replace the argument placeholders with the fields and values you want to use.

   ✓ **Tip:** Use the folders in the Expression Builder to replace the «expr» field with the field to which you want to apply the logical test. Replace the «truepart» and «falsepart» arguments with the values you want to use if the IIf statement is true or false.

6. Click **OK**.

   The Expression Builder closes. Now you can give the new calculated control a more meaningful name.

7. In the new calculated field, replace the Expr1: label with a more meaningful field name.

8. Save and run the query.

   ✓ **Other Ways to Use the IIf Function:**
   To enter the IIf function manually, without using the Expression Builder, click the **Field** row of a blank column in the design grid. Enter the field name followed by a : (colon). Type the expression using the syntax IIf(«expr», «truepart», «falsepart»).
Summarizing Groups of Records

When you work with queries, you will often be less interested in the individual records and more interested in summarized information about groups of records. A query can calculate information about a group of records in one or more tables. For example, you could create a query that finds the total amount of tea your company sold to China in 2007 or how much all that tea cost. The Total row lets you group and summarize information in a query. The Total row normally is tucked away from view in the query design window—you can make the Total appear by clicking the Totals button in the Show/Hide group on the Design tab under Query Tools on the Ribbon. Once the Total row is displayed, you can tell Access how you want to summarize the fields.

1. Display the query in Design View.

2. If necessary, click the Design tab under Query Tools on the Ribbon and click the Totals button in the Show/Hide group.

   The Total row appears in the design grid.

   First you need to add the field that you want to group data by onto the design grid. If, for example, you sell tours and want to calculate the total sales and number of tickets sold for each tour package, you might group the query by the TourName field.

3. Move the field that you want to group data by onto the design grid. Make sure Group By appears in that field’s Total row.

   Tip: The field(s) you want to group by must appear first in the design grid and have Group By in their Total row.

   Next you need to select the fields you want to summarize.

4. Move the field that you want to summarize and perform calculations on onto the design grid.

   Now you need to choose the type of calculation that you want to perform.

5. Click the field’s Total row, click the list arrow, and select a calculation from the list.

   Table 7-3: Total Options describes the calculations that are available.

Exercise

- Exercise File: Query.accdb
- Exercise: Use the Total row to calculate the total sales and number of tickets sold for each tour during a certain period:

  Display the qryTourSales query in Design View. Add the following fields to the design grid:

<table>
<thead>
<tr>
<th>tblTours</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>TourName</td>
<td>Number of Tickets</td>
</tr>
<tr>
<td></td>
<td>Cost</td>
</tr>
<tr>
<td></td>
<td>Date</td>
</tr>
</tbody>
</table>

  Display the Total row on the design grid and sum the Number of Tickets and Cost columns. Select “Where” in the Total row of the Date column. Enter Between 4/1/00 and 6/30/00 in the Date column’s Criteria row. Save the query as qryTourTotals (hint: use the Save Object As command on the File tab) and run the query.

Figure 7-10: Summarizing records in a query using the Total row.
Working with Queries

You can specify criteria to limit the records you want to be calculated—simply enter the criteria in the Criteria row of any grouped or calculated fields. For example, you could calculate only records from the second quarter of the year by adding criteria to the Date field.

If the field you want to use for the criteria isn’t one of the grouped or calculated fields, you must use the “Where” option in the field’s Total row.

Tip: The “Where” option is used only to limit records—it’s results cannot be displayed in the results of the query. Access automatically unchecks the “Show” check box.

6. If desired, add criteria to the Criteria row of any of the fields. If the field isn’t grouped or calculated, click the field’s Total row’s list arrow and select the Where option.

7. Save and run the query.

Access displays the results of the query.

Table 7-3: Total Options

<table>
<thead>
<tr>
<th>Group By</th>
<th>Groups the values in the field so that you can perform calculations on the groups.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Calculates the total (sum) of values in a field.</td>
</tr>
<tr>
<td>Avg</td>
<td>Calculates the average of values in a field.</td>
</tr>
<tr>
<td>Min</td>
<td>Finds the lowest value in a field.</td>
</tr>
<tr>
<td>Max</td>
<td>Finds the highest value in a field.</td>
</tr>
<tr>
<td>Count</td>
<td>Counts the number of entries in a field, not including blank (Null) records.</td>
</tr>
<tr>
<td>StDev</td>
<td>Calculates the standard deviation of values in a field.</td>
</tr>
<tr>
<td>Var</td>
<td>Calculates the variance of values in a field.</td>
</tr>
<tr>
<td>First</td>
<td>Finds the values from the first record in a field.</td>
</tr>
<tr>
<td>Last</td>
<td>Finds the values from the last record in a field.</td>
</tr>
<tr>
<td>Expression</td>
<td>Tells Access that you want to create your own expression to calculate a field.</td>
</tr>
<tr>
<td>Where</td>
<td>Specifies criteria for a field to limit the records included in a calculation.</td>
</tr>
</tbody>
</table>
Display Top or Bottom Values

If all you care about is the highest or lowest values produced by a query, you can display only these records. For example, you could display the ten largest or smallest orders in the Invoices table. If you’re working with dates, you can display the most recent or oldest results.

This lesson explains how you can use the Top Values list to display the top or bottom values in a query.

1. Display the query in Design View.

2. Add the fields you want to see in your query.

Now you need to sort the field that you want to display the top or bottom values for. The Sort row works a little differently when you’re using top or bottom values:

- **Ascending**: Displays bottom values.
- **Descending**: Displays top values.

3. Click the appropriate Sort field, click the list arrow, and select either Ascending or Descending.

Next you have to use the Return list to specify the number of top values you want to be displayed in your query results.

4. Click the Design tab under Query Tools on the Ribbon and click the Return list arrow in the Query Setup group. Select an option from the list.

Table 7-4: Return List explains the options in the Return list.

   ✅ **Tip**: If you don’t like any of the options, you can type your own in the Return box.

5. Save and run the query.

Access displays the query results.

---

**Exercise**

- **Exercise File**: Query.accdb
- **Exercise**: Display the five most expensive nonsmoking tours:

Display the qryTourSales query in Design View. Add the following fields to the design grid:

<table>
<thead>
<tr>
<th>tblTours</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>TourName</td>
<td>Cost</td>
</tr>
<tr>
<td></td>
<td>Smoker</td>
</tr>
</tbody>
</table>

Enter the criteria “False” in the Smoker column. Sort the Cost column in Descending order and choose to display the top 5 values. Run the query.

Modify the query so that it calculates the total sales of nonsmoking tours: Display the Total row in the design grid and sum the Cost column. Select Where in the Total row of the Smokers column. Sort the cost column in Ascending order. Save the query as qryTopValues and run the query.

**Figure 7-11**: A query that displays the five tours with the lowest total sales.

---

**Table 7-4: Return List**

<table>
<thead>
<tr>
<th>Do This…</th>
<th>…to Display This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click 5, 25, or 100 from the Return list</td>
<td>The top 5, 25, or 100 records</td>
</tr>
<tr>
<td>Type a number, such as 15 in the Return box</td>
<td>The top 15 (or specified number of) records</td>
</tr>
<tr>
<td>Click 5% or 25% from the Return list</td>
<td>The top 5 or 25 percent of records</td>
</tr>
<tr>
<td>Type a percentage, such as 20%, in the Return box</td>
<td>The top 20 percent (or specified percent) of records</td>
</tr>
<tr>
<td>Click All from the Return list</td>
<td>All of the records</td>
</tr>
</tbody>
</table>

Parameter Queries

Getting tired of modifying a query every time you want to use a new criterion? A parameter query is your answer. A parameter query prompts the user for the query’s criteria. For example, you could create a Regional Sales query that would ask for the name of the state you want to filter by.

Creating a parameter query is easy. All you have to do is click the Criteria row for the field that you want to use as a parameter and type a message, enclosed in [brackets], that you want Access to display when you run the query.

1. Display the query in Design View.
2. Add the fields you want to use onto design grid.
   For example, if you want to create a query that summarizes total employee sales, you might add the FirstName, LastName, State, Cost, and Date fields.

   Tip: Depending on the goal of your query, you may need to tell Access to group and summarize some of the query fields. This is covered in another lesson.

   In our example, you may want to use the Date field as the criteria to limit records to those that fall between two dates. Instead of entering a criteria expression with two fixed date values, such as “Between 1/1/07 and 3/31/07,” you could create two parameters that will prompt the user to enter the two date values each time they run the query.

3. Click the Criteria row for the field you want to use for your parameter criteria and enter the text of the prompt, surrounded by square brackets [ ].
   For example, you could enter **Between [Enter start date] and [Enter end date]** in the Date field’s criteria row.

   Tip: If you are using Total rows and are only using a field—such as the Date field—as a criteria field, you’ll also want to select the Where option from its Total row so that the field won’t appear in the query results.

4. Save and run the query.
   Access prompts you to enter the parameter(s).

5. Enter a criteria value in response to the prompt and click OK. Repeat for additional parameters.
   Access displays the results of the parameter query.

Exercise

- **Exercise File:** Query.accdb
- **Exercise:** Use a parameter query to summarize total employees sales for certain dates and states:
  Display the qryTourSales query in Design View. Add the following fields to the design grid:

<table>
<thead>
<tr>
<th>tblEmployees</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>tblCustomerTours</td>
</tr>
<tr>
<td>LastName</td>
<td>State</td>
</tr>
<tr>
<td>State</td>
<td>Cost</td>
</tr>
<tr>
<td>Date</td>
<td></td>
</tr>
</tbody>
</table>

Display the Total row and sum the Cost column. Enter the parameters “Between [Enter start date] and [Enter end date]” in the Date column and “[Enter the state]” in the State column. Select “Where” in the Date and State columns’ Total rows. Run the query and enter “WA”, “1/1/00”, and “6/30/00” when prompted for the parameters. Save the query as qryParameter.
Tips

Some advanced Access developers use custom-made forms to provide parameter queries with their information. If developers bind a parameter to the controls on a form (such as [frmCustomers]![Name]), users can fill out one dialog box instead of having to fill out five or six pop-up dialog boxes.
Finding Duplicate Records

The Find Duplicates Query Wizard helps you find records that have the same value in one or more fields. So when would you need to use a Find Duplicates Query? Here are a few scenarios:

- To search for duplicate values in an Orders table to find out which customers have placed more than one order.
- To search for duplicate values in several fields to locate any data-entry errors. For example, if you and another user accidentally entered the same customers into a table, you could search for duplicate values in the LastName and FirstName fields to find and delete the duplicated records.

Access provides a wizard to make creating a query that finds duplicate information in a snap.

1. Click the Create tab on the Ribbon and click the Query Wizard button in the Queries group.

   The New Query dialog box appears, displaying different kinds of query wizards.

2. Select Find Duplicates Query Wizard and click OK.

   Next, choose the table or query that you want to sift through for duplicate records.

   Tip: To change the options displayed in the list, click the Tables, Queries, or Both option in the View area.

3. Select the table or query you want to search and click Next.

   Now you need to tell Access which field or fields might contain the duplicate information.

4. Double-click the field(s) that may contain the duplicate values and click Next.

   Next you can select any field (other than the ones you just specified as possible duplicates) that you want to be displayed in the query.

5. Double-click any additional fields that you want to appear in the query results and click Next.

6. Give the query a name and click Finish.

   Access saves the query with the name you specified and displays the results of the query.

Exercise

- **Exercise File:** Query.accdb
- **Exercise:** Create a new query using the Find Duplicates Query Wizard: Use the tblCustomers table and add the LastName and FirstName fields to the Duplicate-value fields list. In addition, display the City and State fields. Save the query with the default name and view the query.

Figure 7-15: Step One: Select the table or query you want to search for duplicate values.

Figure 7-16: Step Two: Select the field or fields that contain the duplicate values.

Figure 7-17: The query displays those records that have duplicate values in both the LastName and FirstName fields.
Finding Unmatched Records

The Find Unmatched Query Wizard helps you find the records in one table that do not have matching records in another table. Some scenarios when you might need to create such a query include:

- To find customers who have never placed an order.
- To find products that have never been purchased.
- To find “orphan” records. If you haven’t enforced referential integrity in your related tables, deleting a record in one table could leave one or more orphan records in a related table. For example, if you delete a customer record from a Customer table, you may leave several unmatched records for that customer in an Order table.

1. Click the **Create** tab on the Ribbon and click the **Query Wizard** button in the **Queries** group.
   
The New Query dialog box appears, displaying different kinds of query wizards.

2. Select **Find Unmatched Query Wizard** and click **OK**.

   Now you need to choose the table or query whose values you want to display in the query. For example, if you ran a tour company and wanted to find customers without any tour packages, you would select the tblCustomers table.

3. Select the table whose values you want to display and click **Next**.

   Here you have to tell Access which table contains the related records. In our example, you might select the tblCustomerTours table.

4. Select the table that contains the related records and click **Next**.

   Here you have to specify the related field to join the records in the first table to the records in the second table. To do this, you need to select the same field in both lists.

5. Select the same field in both tables, then click the `<=>` button to join the two tables and click **Next**.

   Now you have to specify which fields you want to see in the query.

Exercise

- Exercise File: Query.accdb
- Exercise: Use the Find Unmatched Query Wizard to create a query to find customers who have never booked a tour: Select to display the tblCustomers table, then select the related tblCustomerTours table. Verify that the CustomerID field is selected in both tables and join the tables. Add the LastName, FirstName, City, and State fields to the query, save the query with the default name and view the results.

Figure 7-18: Joining tables in the Find Unmatched Query Wizard using matching fields
6. Double-click any additional fields that you want to appear in the query results and click Next.

7. Give your query a name and click Finish.
   Access saves the query with the name you specified and displays the results.
Crosstab Queries

There are many ways that queries can help you summarize and analyze the information in your database. A crosstab query displays summarized information in a table format that makes it easy to analyze and compare data.

You can create a crosstab query in Design view or by using the Crosstab Query Wizard. The Crosstab Query Wizard is usually much easier, but it does have some limitations:

- If you need to use more than one table or query in the crosstab query, you will first need to create a separate query that contains the tables you want to use.
- You can’t specify any limiting criteria when using the Crosstab Query Wizard. (But you can always modify the crosstab query in Design view and add the criteria yourself.)

In this lesson we’ll look at using the Crosstab Query Wizard.

1. Click the Create tab on the Ribbon and click the Query Wizard button in the Queries group.

   The New Query dialog box appears, displaying different kinds of query wizards.

2. Select Crosstab Query Wizard and click OK.

   The first step of the Crosstab Query Wizard appears. Here you need to select the table or query that contains the values you want to use.

   Tip: If you want to include fields from multiple tables, you’ll first need to create a query containing all those fields, and then select that query during this step in the Crosstab Query Wizard.

3. Select the table or query you want to use and click Next.

   The second step of the Crosstab Query Wizard requires you to select which field you want to use as the row headings for the crosstab.

4. Select the field you want to use as the row heading, click the right arrow button and click Next.

   The next step is to determine which field you want to use for your column headings.

Exercise

- Exercise File: Query.accdb
- Exercise: Use the Crosstab Query Wizard to create a query that summarizes monthly ticket sales by tours: Use the qryToursByName query as the source. Use the TourName field for row headings and the Date field for column headings. Specify a monthly interval. Choose to calculate the sum of the Number of Tickets field. Save the query as “qryTicketsByDate” and view the query.

Figure 7-19: Specifying the crosstab query’s calculation.

Figure 7-20: The results of a crosstab query.
5. Select the field you want to use as the column heading and click Next.

⚠️ Tip: If you select a date field, the Wizard will also ask you how you want to group the dates.

Probably the most important step in the Crosstab Query Wizard is determining which field you want to calculate where columns and rows intersect and the type of calculation you want to use to summarize the fields.

6. Select the field you want to summarize from the Fields list, select the type of calculation you want to use to summarize the field from the Functions list, and click Next.

7. Enter a name for the crosstab query and click Finish.

Access saves the query with the name you specified and displays the results.

⚠️ Tip: Once you’ve created the Crosstab query, you can display it in Design View to make modifications such as adding limiting criteria to certain fields.
Delete Queries

A delete query is the most dangerous of all queries. Once you have deleted records using a delete query, you cannot undo the results—the records are gone forever! Creating a delete query is no different than creating a simple select query—with one very important difference: While a select query displays the records that match your criteria, a delete query deletes those records.

If you want to delete records from multiple tables—for example, a customer and all of that customer’s orders—you need to do a few things first:

- Define relationships between the tables.
- Establish referential integrity for the join(s) between the tables and turn on the “Cascade Delete Related Records” option.

In this lesson you will learn how to create a delete query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.
   The query design window and Show Table dialog box both appear. Now you have to select the tables and/or queries you want to use in the delete query.

2. Select the tables and queries you want to add and click Add. When you’re finished, click Close.
   If the tables are related, Access automatically connects their common fields with a join line. If the tables aren’t related, you will have to manually join them by dragging a field from one table’s field list to the matching field in the other table’s field list.

3. Connect any unrelated tables.
   Next, tell Access that this is a delete query.

4. Click the Design tab under Query Tools on the Ribbon and click the Delete button in the Query Type group.
   Access converts the select query to a delete query and displays the Delete row in the query design grid. Now you have to tell Access what you want to delete.

5. Drag the asterisk (*) from the top of the table field list for the table from which you want to delete information onto the design grid.
   Notice that From appears in the Delete cell for the asterisk field, indicating that the records will be deleted from this table. Unless you want the delete query to delete each and every record in the table, you will need to add some limiting criteria.

Exercise

- Exercise File: Query.accdb
- Exercise: Create a new delete query in Design View to delete all the tours sold by LeAnne Chang: Add the tblEmployees, tblCustomerTours, and tblTours tables to the query. Link the EmployeeID field in the tblEmployees table to the Employee field in the tblCustomerTours table. Click the Delete button in the Query Type group on the Ribbon. Drag the asterisk (*) from the top of the tblCustomerTours table onto the design grid. Also add the LastName field from the tblEmployees table. Enter the criteria “Chang” in the LastName column. Preview the query in Datasheet View. Return to Design View and run the query. Close the query without saving.

Figure 7-21: The Delete button in the Query Type group.

Figure 7-22: A delete query in Design View.
For example, if you’re deleting information from a Customers table, you could use the Last Name field as a limiting criterion to delete only records with a certain last name.

6. Drag the field you want to use as the limiting criteria onto the design grid.

This time Where appears in the Delete cell for the field you added, indicating that the field will be used as the criteria to select which records will be deleted from the table you added earlier.

Next you need to tell Access the specific data to delete. For example, if you were using the Last Name field as your criteria, you could enter the name “Smith” to delete all records that contain “Smith” in the Last Name field.

7. Click the field’s Criteria row and type the specific data you want to delete and press <Tab>.

Access will add the “quotation marks” around the text string Chang for you. That’s all there is to creating a delete query.

⚠️ Trap: Before you run a delete query, always preview the results in Datasheet View first.

8. Click the View button in the Results group on the Design tab to display the delete query in Datasheet View.

The delete query displays the results of the delete query. Let’s switch back to Design View.

9. Click the View button in the View group on the Home tab to display the delete query in Design View.

Now run the delete query to delete the records.

10. Click the Run button in the Results group on the Design tab.

Access asks if you really want to delete the records.

11. Click Yes.

Access silently deletes the records.

12. Close the query without saving.
Append Queries

An append query takes a group of records from one or more tables or queries in your database and adds them to another existing table. Append queries are especially useful for importing information into a table. For example, you could use an append query to import several dozen customer records from an Excel spreadsheet into an existing table. Of course, you would have to know how to import the Excel spreadsheet first—and that’s another lesson in itself.

There are several rules that you must follow when using an append query:

- The appended data must meet the data validation and referential integrity rules of the table to which it is being added.
- The appended data must have its own unique primary-key values. If the primary-key field in the table to which the data is being added is an AutoNumber field, do not append that field—Access will generate new numbers for the new records.
- The type of data in the records you’re adding must match the type of data in the table to which you’re adding them.

In this lesson you will learn how to create an append query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The query design window and Show Table dialog box both appear. Here you have to select the tables and/or queries containing the data you want to append to another table.

2. Select the tables and queries you want to add and click Add. When you’re finished, click Close.

   Now you need to make the query an append query.

3. Click the Design tab under Query Tools on the Ribbon and click the Append button in the Query Type group.

   The Append dialog box appears. Here you need to select the table to which you want the results of the query to be added. First, though, you need to select the database where the table is located. You have two options:

   - Current Database: If the table is in the currently open database.
   - Another Database: And browse to the other database.

---

**Exercise**

- **Exercise File:** Query.accdb
- **Exercise:** Create an append query to add a new group of tours to the tblCustomerTours table: Create a new query in Design View using the tblCaribbeanTours table. Then make the query into an Append query that appends to the tblCustomerTours table. Add all of the fields in the tblCaribbeanTours table individually to the design grid. In the Append To row of the No Tickets field, select Number—Access will generate new numbers for the new records. Preview the query results in Datasheet View, then return to Design View and run the query. Close the query without saving. Open the qryToursByName query and notice that records have been appended to it.
4. Select the **Current Database** or **Another Database** option.
   Now select the table.

5. Click the **Table Name** list arrow and select the table to which you want to add the results of the query. Click **OK**.
   The append query will add the results of its query to the table you just specified. Notice that an Append To row appears in the design grid. Now you have to specify the fields you want to append.

6. Add to the design grid the fields you want to append to another table.
   If the field(s) you added are present in the destination table, Access automatically fills in the Append To row. If the field is not present in both tables, you will have to select the name of the field to which you want to append.

7. If Access doesn’t automatically match a field, click the **Append To** row for that field and select the field in the destination table to which you want to append.

   **Trap:** As with any action query, you should always preview the results in Datasheet View first.

8. Click the **View** button in the Results group on the Design tab to display the append query in Datasheet View.
   The append query displays the records it will add or append. Let’s switch back to Design View.

9. Click the **View** button in the Views group on the Home tab to display the append query in Design View.
   Now run the append query to append the records.

10. Click the **Run** button in the Results group on the Design tab.
    Access asks you to confirm the addition of the records to the table.

11. Click **Yes**.
    Access adds the records.

12. Close the query without saving.
Make-Table Queries

Like all queries, a make-table query asks a question regarding the information in one or more tables and then retrieves the results. Instead of displaying the results, however, a make-table query creates a new table with the results of the query. Make-table queries are useful for:

- Exporting a table to another database or application.
- Creating a backup copy of a table.
- Creating an archive table that stores old records.
- Creating a table that includes information or fields from more than one table.

In this lesson you will create a make-table query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The query design window and Show Table dialog box both appear. Here you have to select the tables and/or queries containing the data you want to include in your new table.

2. Select the tables and queries you want to add and click Add. When you’re finished, click Close.

   Now add the fields you want to use in your new table.

3. Add to the design grid the fields you want to use to create the new table.

4. As desired, add any limiting criteria in the Criteria row.

   Now you need to change the query type to make it a make-table query.

5. Click the Design tab under Query Tools on the Ribbon and click the Make Table button in the Query Type group.

   Access displays the Make Table dialog box. Here you need to tell Access the name of the new table.

6. Enter a name in the Table Name box and click OK.

   **Tip:** In the Table Name box, you can also choose to replace an existing table instead of creating a new one. To do this, click the Table Name list arrow and select a table. If the table you’re replacing is in another database, first select the Another Database option and browse to the database.

---

**Exercise**

- **Exercise File:** Query.accdb
- **Exercise:** Create a make-table query to create a table containing information regarding all China tour records:
  Open the qryTourSales query in Design View. Add the following fields to the design grid:

    | tblTours  | tblCustomerTours | tblEmployees |
    |-----------|------------------|-------------|
    | TourName  | Number of Tickets| Date        |
    |           |                  | Cost        |
    |           |                  | LastName    |
    |           |                  | FirstName   |

    Enter the criteria “China” in the TourName column. Make the query a Make Table Query and enter tblChinaTours as the name of the new table. Preview the query results in Datasheet View, then return to Design View and run the query. Close the query without saving. Open the new tblChinaTours table to see the result.

---

**Figure 7-25:** The make-table query will create a table using the tables, fields, and criteria you specify.

**Figure 7-26:** Type the name of the table you’re creating in the Make Table dialog box.
Now you’re ready to have the make-table query create the new table. Preview the results of the query first.

7. Click the **View** button in the Results group on the Design tab to display the make-table query in Datasheet View.
   The make-table query displays the records it will use to create the new table.

8. Click the **View** button in the Views group on the Home tab to display the make-table query in Design View.
   Now let’s run the query to create the new table.

9. Click the **Run** button in the Results group on the Design tab.
   Access asks you to confirm the creation of the table.

10. Click **Yes**.
    Access creates the new table based on the results of the make-table query.

11. Close the query without saving.
    Now you can open and view the new table, which contains the results of the make-table query.
Update Queries

You can use an update query to change a bunch of records at the same time. For example, you could create an update query to lower prices by eight percent or to change the sales representative for all your clients in Oregon from “Ralph Potter” to “George Bailey.” Just like other action queries, you create an update query by first creating a select query and then converting the select query to an update query.

In this lesson you will create an update query.

1. **Click the Create tab on the Ribbon and click the Query Design button in the Queries group.**
   
   The query design window and Show Table dialog box both appear. Here you have to select the tables and/or queries you want to use in the update query.

2. **Select the tables and queries you want to add and click Add. When you’re finished, click Close.**
   
   Now you need to convert the select query to an update query.

3. **Click the Design tab under Query Tools on the Ribbon and click the Update button in the Query Type group.**
   
   Access converts the select query to an update query. Notice an Update To row appears in the design grid. Now you have to specify the fields you want to update.

4. **Add to the design grid the fields you want to update.**
   
   The next step is a little bit tricky—you have to tell Access which fields to update and how to update them. For example, if you wanted to raise the price of the Normal Price field by 10 percent you would write an expression—like `[Normal Price]+([Normal Price]*0.1)`—in the field’s Update To row to make this happen.

5. **Click the Update To row for the field you want to update and type an expression.**
   
   Next you need to specify any limiting criteria. For example, if you wanted to raise prices for only certain products, you would need to enter a limiting criterion, such as a product number, in the field that identifies the products.

6. **As desired, add any limiting criteria in the Criteria row.**
   
   Now let’s run the query.

---

**Exercise**

- **Exercise File:** Query.accdb
- **Exercise:** Create an update query to raise the prices of all trips to Europe by 10 percent: Create a new query in Design View using the tblTours table. Change the query to an Update Query. Add the TourID, Normal Price, and First Class Price fields from the tblTours table to the design grid. Enter “([Normal Price]+([Normal Price]*0.1))” in the Normal Price column’s Update To row and “[First Class Price]+([First Class Price]*0.1)” in the First Class Price column’s Update To row. In the TourID column, on separate criteria rows, enter “1”, “2”, “3”, and “9”, respectively. Run the query to update the records in the tblTours table. Close the query without saving changes.

---

**Figure 7-27:** An update query.
7. Click the **Run** button in the Results group on the Design tab.
   Access asks you to confirm the update.

8. Click **Yes**.
   Access updates the records.

9. Close the query without saving.
   Now you can open the updated table and view the update data.
Working with Queries Review

Quiz Questions

67. Which type of query makes it easy to read and compare information by summarizing data in a table format?
   A. A Crosstab Query
   B. A Union Query
   C. An Append Query
   D. A Parameter Query

68. Access will automatically join related tables when they are added to a query. (True or False?)

69. Which of the following expressions is NOT written in the correct syntax?
   A. [Order Total]*[Tax Rate]
   B. (Order Total)*0.1
   C. [tblCustomerTours][Cost][tblEmployees][Commission]
   D. 100+10

70. If you are having trouble remembering how to write expressions using the correct syntax, you can use the Expression Builder to help you create the expression. (True or False?)

71. Rebate: IIf([Age]>65,Senior,Adult) This expression is an example of:
   A. A conditional expression.
   B. Something I learned back in high school algebra and thought I would never see again.
   C. A financial expression.
   D. Something that belongs in Microsoft Excel training.

72. The field(s) you want to group by must appear first in the design grid and have Group By in their Total row. (True or False?)

73. A query must be ______ before you can display the top values.
   A. Filtered
   B. Saved
   C. Sorted
   D. Destroyed

74. A parameter query could prompt a user for a date and then display only records that contain the specified date. (True or False?)

75. To find duplicate records, use the Find Duplicates Query Wizard. (True or False?)

76. The find unmatched records query helps identify duplicate records in a table. (True or False?)

77. You can’t specify any limiting criteria when using the Crosstab Query Wizard. (True or False?)
78. You can restore the records a delete query erases by using the Undo command. (True or False?)

79. An append query can extract records from one table and copy them into another existing table. (True or False?)

80. Make-table queries are NOT useful for which one of the following tasks?
   A. Creating a backup copy of a table.
   B. Creating an archive table that stores old records.
   C. Creating a table with information from more than one table.
   D. Updating a bunch of table records at once.

81. You could use an update query to change all 612 area codes in a table to 952. (True or False?)

---

** Quiz Answers **

67. A. A Crosstab Query makes it easy to read and compare information by summarizing data in a table format.
68. True. Access automatically joins related tables when they are added to a query.
69. B. (Order Total)*0.1 is incorrect. Fields should be enclosed in [ ] brackets, not parentheses.
70. True. The Expression Builder helps you create expressions in your queries (and in forms, reports, and macros too!) 
71. A. This is a conditional expression.
72. True. The field(s) you want to group by must appear first in the design grid and have Group By in their Total row.
73. C. A query must be sorted before you can display the top values.
74. True. A parameter query could prompt a user for a date and then display only records that contain the specified date.
75. True. The Find Duplicates Query Wizard will help you find duplicate records.
76. False. The find unmatched records query helps find the records in one table that do not have matching records in another table.
77. True. In order to add criteria, you have to modify the query after creating it in the Wizard.
78. False. A delete query permanently deletes any records, so be careful!
79. True. An append query lets you copy records from one table and add them to another table.
80. D. Make-table queries are not useful for updating a bunch of table records at once.
81. True. An update query changes batches of records at the same time.
A form created in Access is similar to the ordinary paper forms that you fill out with a pen or pencil—only you don’t have to worry about trying to read poor penmanship. In Access, forms provide an easy way to enter and view data in a table. Here are just a few examples of how forms make working with data easier.

Easier to View and Use: Instead of scrolling back and forth in a table’s datasheet, a form lets you focus on one record at a time.

See Data Any Way You Want: You can design forms to present information any way you like.

Combine Data from Linked Tables: One form can display data from several related tables or queries—and your users will never know that they are working with two sources!

And that’s just for starters. No doubt about it—forms make your database easier to use. Just like a Windows dialog box (which is really what a form is), Access forms can include fill-in-the-blank fields, check boxes, drop-down lists, and more.

Let’s start working with forms.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Creating and Using a Form

A fast and easy way to create a form in Access is by using one of the AutoForm tools. Autoforms automatically create a form by arranging all the fields from a table or query.

The AutoForms are fast and easy to use, but limited—there are only a few kinds of them. Of course, you can always modify the forms once you’ve created them.

Create a form with AutoForms

1. In the Navigation Pane, click the table or query that contains the data you want the new form to use.
   Now you’re ready to select an AutoForm. Table 8-1: Forms describes the different types of AutoForms that are available.

2. Click the Create tab on the Ribbon and click the Form button in the Forms group.
   Access creates the form for you using the data from the table or query you specified.

Use a form

Once you create a form, you can use the buttons on the Record Navigation bar (First, Previous, Next, Last, or New) to display or add records.

1. Click a button on the Record Navigation bar to display or add a new record.

Other Ways to Display a Certain Form:
   Enter a keyword in the Search box to locate the record you want to display.

Table 8-1: Forms

<table>
<thead>
<tr>
<th>The Forms group on the Create tab under the Ribbon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form</td>
</tr>
<tr>
<td>Form Design</td>
</tr>
<tr>
<td>Blank Form</td>
</tr>
<tr>
<td>Form Wizard</td>
</tr>
</tbody>
</table>
## Working with Forms

<table>
<thead>
<tr>
<th><strong>Table 8-1: Forms</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Multiple Items</strong></td>
</tr>
<tr>
<td><strong>Datasheet</strong></td>
</tr>
<tr>
<td><strong>Split Form</strong></td>
</tr>
<tr>
<td><strong>Modal Dialog</strong></td>
</tr>
<tr>
<td><strong>PivotChart</strong></td>
</tr>
<tr>
<td><strong>PivotTable</strong></td>
</tr>
</tbody>
</table>
Understanding Form Views

Before modifying a form, you need to know that forms can be viewed several different ways in Access:

**Form View:** The normal view where you can view, add, and edit records. You can’t modify the form’s structure in this view.

**Layout View:** Layout View allows you to apply formatting and rearrange fields while also displaying data.

**Design View:** Use for in-depth modification and customization of your form. Live data is not visible—you’re only working with the structure of the form.

**Datasheet, Pivot Table, Pivot Chart:** These views are available only for certain types of forms.

**Print Preview:** Displays a form as it would look when printed, although you’ll rarely need to print a form—that’s why you have reports.

Change Form views

Make sure the form is displayed, then follow these instructions:

1. Click the **Home** tab on the Ribbon, click the **View** button list arrow and select a view option.

   **Other Ways to Change Views:**
   - Click a **view** button on the right side of the Status Bar.

   ![Figure 8-2: Selecting a form view.](image)

   ![Figure 8-3: A form displayed in different views.](image)
Modifying a Form in Layout View

You can modify forms in either Layout View—for simple modifications—or in Design View—for more complex changes where you want total control over form elements.

Unless you need to make detailed modifications, you'll want to use Layout View. Layout View is easy to use because, for the most part, you can simply click and drag items around the form, and you can see your live data while you work.

Tips

✓ The modifications in this lesson can also be performed in Design View, but using Layout View is easier.

Understand controls

Any graphic object that appears on forms and reports is called a control. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls.

Move a control

1. Click and drag a control to move it to a new location.

Resize a control

1. Select the control you want to resize, then click and drag the edge of the control to resize it.

Edit a label

1. Select the label you want to edit.

2. Select the text within the label control.
   A cursor appears in the label.

3. Edit the text as desired.

4. Click outside the label.
   The edit is confirmed.

Exercise

- Exercise File: Form.accdb
- Exercise: Display the frmCustomers form in Layout View. Delete the DOB text box and label. Then add the DOB field using the Field List pane. Move the Phone field after the ZipCode field and move the DOB field after the Phone field. Change the DOB label to BirthDate. Resize all the text boxes until they are half as wide. Save the changes.

Figure 8-4: Add a field using the Field List pane.
Delete a control

1. Select the control you want to delete, then press the <Delete> key.

Add a field

1. Make sure the Field List pane is displayed.
   
   ✔ Tip: If you don’t see the Field List pane, click the Design tab under Form Layout Tools on the Ribbon and click the Add Existing Fields button in the Tools group.
   
2. Click and drag the field you want to add from the Field List onto the form.
   
   The field is added to the form wherever you placed it, and Access automatically moves the other fields to accommodate it.
   
   ✔ Tip: The Field List pane can be used in either Layout or Design View.
Form Design View Basics

Don’t let Design View scare you. It looks more complicated than it really is. In some ways, Design View is similar to many Paint programs. Think of the form as your canvas and the control buttons as paintbrushes for adding fields, text boxes, and buttons to the form.

Any graphic object that appears on forms and reports is called a control. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls. Let’s look at how to add controls in Design View.

Add a control

1. In Design View, click the Design tab under Form Design Tools.
   
   Form controls are located in the Controls group. As you will notice, there are lots of different controls to choose from.

   Tip: Some controls, such as buttons or lists, have a wizard that helps you set them up. By default the Use Control Wizard button should be selected in the More button in the Controls group.

2. Click the control button you want to add.
   
   The cursor changes its look.

3. Click and drag on the form in the location where you want to place the control.
   
   If the control you added uses a Control Wizard, the wizard appears at this point. Or, if you added a label, you’ll need to enter text.

4. If necessary, enter text into a label or follow the Control Wizard to set up the control.

   Tip: You can copy, cut and paste controls using the buttons in the Clipboard group on the Home tab.

5. In the Property Sheet pane, change settings for the control as desired.

   For example, if the intent of a control is to display a database field’s value, you’d select the desired source from the Control Source box on the Property Sheet.

   Tip: If the Property Sheet pane isn’t already displayed, click the Property Sheet button in the Tools group on the Design Tab.

Table 8-2: Controls provides more information about controls.

Exercise

- Exercise File: Form.accdb
- Exercise: Add a Combo Box control to the frmCustomers form using the Control Wizard. Place the control on the right side of the form’s header, and make it 1 inch tall by 2 inches wide. Select the “Find a record on my form based on the value I select in my combo box” option. Add the CustomerID, LastName, and FirstName fields to the combo box. Give the combo box a label named “Lookup Name”. Save the changes, then try out the combo box in Form View.

Figure 8-5: A form in Design View.

Figure 8-6: A form with a combo box control.
Working with Forms

Resize the form area

Sometimes you may need to make the form area larger in order to fit a new control.

1. Click the top edge of the Detail divider or Form Footer divider and drag the divider to resize the desired form area.

Table 8-2: Controls

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the &lt;Shift&gt; key as you click each control, or drag a rectangle around all controls you want to select.</td>
</tr>
<tr>
<td>Text Box</td>
<td>Creates a text box that displays information from a table and query. You can also use text boxes to simply enter text.</td>
</tr>
<tr>
<td>Label</td>
<td>Creates a static text label that is the same for every record, such as a heading. Most controls already have a text label attached.</td>
</tr>
<tr>
<td>Button</td>
<td>Creates a button that runs a macro or Visual Basic function.</td>
</tr>
<tr>
<td>Tab Control</td>
<td>Enables you to create tabs (like the ones found in some dialog boxes) to include more than one page of controls on the form.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Inserts a link to a Web page or file.</td>
</tr>
<tr>
<td>Web Browser Control</td>
<td>Inserts a control that allows the database user to access the computer’s web browser.</td>
</tr>
<tr>
<td>Navigation Control</td>
<td>Creates a control that allows the form to be navigated.</td>
</tr>
<tr>
<td>Option Group</td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box.</td>
</tr>
<tr>
<td>Insert Page Break</td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td>Combo Box</td>
<td>Creates a drop-down box that lets the user enter text or select an item from a list of options.</td>
</tr>
<tr>
<td>Chart</td>
<td>Inserts a chart.</td>
</tr>
<tr>
<td>Line</td>
<td>Enables you to draw a line.</td>
</tr>
<tr>
<td>Toggle Button</td>
<td>Creates a toggle button that allows you to display and enter data from a Yes/No field.</td>
</tr>
<tr>
<td>List Box</td>
<td>Creates a box that lets the user select an item from a list of options.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Enables you to draw a rectangle.</td>
</tr>
<tr>
<td>Check Box</td>
<td>Creates a box that is checked or unchecked. Use to enter data from a Yes/No field.</td>
</tr>
<tr>
<td>Unbound Object Frame</td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td>Attachment</td>
<td>Provides the option to include an attachment.</td>
</tr>
<tr>
<td>Option Button</td>
<td>Creates an option button (or radio button) that allows the user to make a single selection from two or more choices. Option Buttons are normally used with the Option Group control.</td>
</tr>
<tr>
<td>Subform/Subreport</td>
<td>Inserts another form within the main form. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td>Bound Object Frame</td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database.</td>
</tr>
<tr>
<td>Image</td>
<td>Displays a picture or graphic file that you specify.</td>
</tr>
</tbody>
</table>
Changing Tab Order

If you add, remove, or move fields on a form, you'll want to change the form’s tab order. A form’s tab order determines the order in which you advance from one field to the next when you press the <Tab> key. When a form is first created, the order of the fields determines the initial tab order. Even when you reposition the fields on a form, the form’s tab order remains the same.

In this lesson, we’ll look at how to change the tab order.

**Tips**

- Tab order can only be changed in Design view.

**Change a form’s tab order**

1. In Design View, click the Design tab under Form Layout Tools on the Ribbon and click the Tab Order button in the Tools group.

   The Tab Order dialog box appears. The order of the fields in the list is the order in which you will advance from one field to the next when you press the <Tab> key. There are a couple of ways to change the tab order. The fast and easy way is to click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.

   **Tip:** If you don’t see the fields listed, you may need to click Detail in the Section area of the dialog box.

2. Click the Auto Order button. Click OK.

   Access looks at the order in which fields appear on the form and adjusts the tab order accordingly.

**Other Ways to Change Tab Order:**

In the Tab Order dialog box, click the row select for the field you want to move and drag it to the desired location. Repeat as necessary.

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in Form View. Press the <Tab> button to move the cursor through all the text boxes (notice that SSN is out of order). Change to Design View to change the tab order. Open the Tab Order dialog box and use the Auto Order feature to make the tab order match the physical order on the form. Save the changes.

---

**Figure 8-7:** The Tab Order dialog box.
Working with Control Properties

Every control on a form—every text box, every label, and every check box—has a set of properties that you can modify. A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, the properties of a house would be its color, square footage, and shape. A property for a field on a form might be the number of decimal places displayed or the default value for the field. Because you can almost always change an object’s properties, you can think of them as the object’s settings.

Different types of controls have different properties. For example, label controls have a Caption property that determines the text that is displayed in the label, while text box controls have a Control Source property that determines which field is displayed in the control. Most controls have several dozen different properties or settings. Fortunately, Access organizes these properties on different tabs, as shown in Table 8-3: Tabs in the Property Sheet.

This lesson explains how to view and change a control’s properties.

View and edit properties

1. Display the form in Design View.
   - Tip: You can also work with properties in Layout View.

   Properties are displayed and edited in the Property Sheet pane.

2. If the Property Sheet isn’t displayed, right-click the control and select Properties from the contextual menu.

   Other Ways to Display the Property Sheet:
   - In Design View, click the Design tab under Form Design Tools on the Ribbon and click the Property Sheet button in the Tools group.
   - In Layout View, click the Design tab under Form Layout Tools on the Ribbon and click the Property Sheet button in the Tools group.

3. Select a control.

   The Property Sheet displays the properties for the selected control.

   Other Ways to Select a Control:
   - Click the Selection type list arrow at the top of
the Property Sheet and select the control whose properties you want to view or edit.

**Tip:** To select multiple controls to edit at once, press and hold down the `<Shift>` key as you click each control that you want to select.

Now let’s look at how to edit a property.

4. In the Property Sheet pane, click the appropriate property box and make the changes. Some property boxes will display one of the following buttons when clicked:

- ![Icon] Click to display a list of options to change the settings for the selected property.

- ![Icon] Click to invoke a Wizard or display a dialog box that you use to change the settings for the selected property.

**Tip:** Most controls have dozens and dozens of properties. You will often have to click the appropriate tab and then do some scrolling to find the property box that you’re looking for.

### Table 8-3: Tabs in the Property Sheet

| Format | Properties that determine the object’s appearance, such as color, text formatting, line and border color/thickness, and special effects. The purpose of many Formatting properties should be pretty obvious—for example, Font Size determines the font size of the control. |
| Data   | Properties that determine where a control get its data, its default value (if any), and data validation rules for the control. |
| Event  | Actions to which you can assign a macro or Visual Basic procedure. For example, clicking a button or entering information in a particular field could trigger a macro to run. |
| Other  | Miscellaneous but important properties, such as the name of the control, if tabbing to the control is allowed, and if a message should appear in the Status bar when the control is selected. |
| All    | Displays all the properties for the control. |
Control Property Reference

Every control on a form or report has dozens of different control properties or settings—so how do you keep them all straight? Here’s how—this lesson is really a cheat sheet that you can use whenever you’re not sure what exactly a particular control property is or does. The most important properties are marked with a ★.

Table 8-4: Common Form and Report Control Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption for a form or text label.</td>
</tr>
<tr>
<td>Format ★</td>
<td>Format</td>
<td>Customizes the way numbers, dates, times, and text are displayed and printed.</td>
</tr>
<tr>
<td>Decimal Places ★</td>
<td>Format</td>
<td>Determines the number of decimal places displayed.</td>
</tr>
<tr>
<td>Visible ★</td>
<td>Format</td>
<td>Shows or hides a control. Useful if you want to use information on the form without it being visible. For example, you could use the value in a hidden control as the criteria for a query.</td>
</tr>
<tr>
<td>Display When</td>
<td>Format</td>
<td>Determines whether a section or control always appears or only appears when it is displayed on screen or printed.</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>Format</td>
<td>Determines whether scroll bars appear in the control.</td>
</tr>
<tr>
<td>Left ★</td>
<td>Format</td>
<td>Determines the horizontal position of the control.</td>
</tr>
<tr>
<td>Top ★</td>
<td>Format</td>
<td>Determines the vertical position of the control.</td>
</tr>
<tr>
<td>Width ★</td>
<td>Format</td>
<td>Determines the width of a control.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>Determines the height of a control.</td>
</tr>
<tr>
<td>Back Style</td>
<td>Format</td>
<td>Determines whether a control is transparent or not.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Format</td>
<td>Determines the color of a control. Click the [ ] button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Format</td>
<td>Applies a 3-D effect to a control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Format</td>
<td>Determines the line style of a control’s border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Format</td>
<td>Determines the color of a control’s border. Click the [ ] button to select a color from a palette.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Format</td>
<td>Determines the width of a control’s border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Format</td>
<td>Determines the color of text in a control or the fill color of an object. Click the [ ] button to select a color from a palette.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Format</td>
<td>Determines the font used in a control (such as Arial or Times New Roman).</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Format</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
<tr>
<td>Font Italic</td>
<td>Format</td>
<td>Determines whether the text in a control appears in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Format</td>
<td>Determines whether the text in a control is underlined.</td>
</tr>
<tr>
<td>Text Align</td>
<td>Format</td>
<td>Determines how text should be aligned in a control.</td>
</tr>
<tr>
<td>Control Source ★</td>
<td>Data</td>
<td>Determines the data that appears in the control.</td>
</tr>
<tr>
<td>Input Mask ★</td>
<td>Data</td>
<td>Limits the amount and type of information that can be entered in a field, such as (__<em>) <em><strong>-</strong></em></em> for a phone number. Click the [ ] button to create an input mask using the Input Mask Wizard.</td>
</tr>
<tr>
<td>Default Value ★</td>
<td>Data</td>
<td>Specifies a value that is automatically entered in this field for new records.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in Design View. Make sure the Property Sheet pane is displayed. Select different controls and explore the tabs and properties on the Property Sheet.
# Table 8-4: Common Form and Report Control Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation Rule ✰</td>
<td>Data</td>
<td>Allows you to enter an expression that is evaluated when data in the field is added or changed.</td>
</tr>
<tr>
<td>Validation Text ✰</td>
<td>Data</td>
<td>Allows you to enter a message that is displayed when data doesn’t meet the Validation Rule property.</td>
</tr>
<tr>
<td>Locked ✰</td>
<td>Data</td>
<td>Determines whether changes can be made to a field’s data.</td>
</tr>
<tr>
<td>Event Tab</td>
<td>Event</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Name ✰</td>
<td>Other</td>
<td>Specifies the name of the control that identifies it in expressions, macros, and Visual Basic procedures.</td>
</tr>
<tr>
<td>Status Bar Text</td>
<td>Other</td>
<td>Specifies a message to display in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>Enter Key Behavior</td>
<td>Other</td>
<td>Determines if pressing the &lt;Enter&gt; key adds a new line of text in a control or if it moves to the next field.</td>
</tr>
<tr>
<td>Allow AutoCorrect</td>
<td>Other</td>
<td>Determines if AutoCorrect (i.e., “teh” &gt; “the”) is used in a control.</td>
</tr>
<tr>
<td>AutoTab</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next field occurs when the last character permitted by a text box control’s input mask is entered.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Determines whether users are able to tab to the control.</td>
</tr>
<tr>
<td>Tab Index</td>
<td>Other</td>
<td>Determines the tab order.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specifies a user-created shortcut menu that appears when the control is right-clicked.</td>
</tr>
<tr>
<td>ControlTip Message</td>
<td>Other</td>
<td>Specifies a brief message that appears when a user points at the control for a couple of seconds.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specifies an identifier number for a user-created Help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Specifies extra, user-defined information that is stored in the object.</td>
</tr>
</tbody>
</table>
Working with Form Properties

In this lesson you will learn how to view and change the properties and settings not for controls, but for the form itself. That’s right—just like controls, forms also have their own set of properties that you can view and manipulate. So why would you want to change a form’s properties? Modifying a form’s properties can be especially important if you are creating a database that will be used by novice users. For example, by modifying a form’s properties you can:

- Allow users to edit exiting records in a table or query—but not add any additional records.
- Display one record at a time on each form or display many records at once.
- Determine the size and location of the form.

In this lesson you will learn how to work with a form’s properties.

Change form properties

1. Display the form in Design View. Double-click the Form Selector.

   Access displays the properties for the form.

   **Other Ways to View Form Properties:**
   You can also view and edit form properties in Layout View. Click the arrow button that runs along the left side of the form to select the entire form in Layout View.

2. Click the appropriate property tab and property box and make the desired changes.

Change the form’s Default View property

One of the most important form properties is the Default View property, which determines how many records a form can display at once. Let’s take a closer look at this property…

1. Click the Format tab, click the Default View box, and click the down arrow.

   Here you have six options. They are:

   - **Single Form:** Displays one record at a time on a form.
   - **Continuous Forms:** Displays multiple records on a form. The main difference between Datasheet and Continuous Forms is that a continuous form can be customized.

---

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in Design View. Make sure the Property Sheet pane is displayed. Change the form’s tab to read “Customers” instead of “frmCustomers”: Click the Form Selector to select the whole form. On the Format tab, enter “Customers” in the Caption box. Next change the form’s default view: On the Format tab, select “Split Form” as the Default View. Change to Form View and notice the effects of the two property changes you made. Close the form without saving.
Datasheet: Displays multiple records in a table, using one line per record. Tables and queries display information in datasheets.

PivotTable: Dynamically analyzes information and summarizes it into a datasheet-like table.

PivotChart: Dynamically analyzes information and summarizes it into a chart.

Split Form: Displays a single record on a form and multiple records on a datasheet at the same time.

2. Select a different Default View option, if desired.

You’re probably wondering how you are going to get a handle on all these form properties. Don’t worry—you will probably never touch 95 percent of them.
Form Property Reference

Here’s a “cheat sheet” that lists the various form properties. Some of the most important properties are marked with a ★.

Table 8-5: Important Form Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption in the form's title bar.</td>
</tr>
<tr>
<td>Default View ★</td>
<td>Format</td>
<td>Determines the view the form is in when opened.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Single Form: Displays one record at a time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Continuous Forms: Displays multiple records in a form.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Datasheet: Displays multiple records in a Datasheet.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PivotTable: Dynamically analyzes data, summarizes into a table.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PivotChart: Dynamically analyzes data, summarizes into a chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Split Form: Displays a single record on a form and multiple records on a datasheet at the same time.</td>
</tr>
<tr>
<td>Allow Form View</td>
<td>Format</td>
<td>Determines if users can switch to this view.</td>
</tr>
<tr>
<td>Allow Datasheet View</td>
<td>Format</td>
<td>Determines whether scroll bars appear on the form.</td>
</tr>
<tr>
<td>Allow PivotTable View</td>
<td>Format</td>
<td>Determines whether a form contains a record selector.</td>
</tr>
<tr>
<td>Allow PivotChart View</td>
<td>Format</td>
<td>Determines whether a form has navigation buttons.</td>
</tr>
<tr>
<td>Allow Layout View</td>
<td>Format</td>
<td>Determines if lines appear between records in continuous forms.</td>
</tr>
<tr>
<td>Scroll Bars ★</td>
<td>Format</td>
<td>Resizes the form automatically to display a complete record.</td>
</tr>
<tr>
<td>Record Selectors ★</td>
<td>Format</td>
<td>Determines whether a form contains a record selector.</td>
</tr>
<tr>
<td>Navigation Buttons ★</td>
<td>Format</td>
<td>Determines whether a form has navigation buttons.</td>
</tr>
<tr>
<td>Dividing Lines</td>
<td>Format</td>
<td>Determines the type of window the form appears in: None, Thin, Sizable, or Dialog.</td>
</tr>
<tr>
<td>Auto Resize</td>
<td>Format</td>
<td>Determines if a control menu appears in the form.</td>
</tr>
<tr>
<td>Control Box</td>
<td>Format</td>
<td>Determines if minimize and/or maximize buttons appear in the form.</td>
</tr>
<tr>
<td>Min Max Buttons</td>
<td>Format</td>
<td>Determines if a close button appears on the form.</td>
</tr>
<tr>
<td>Close Button</td>
<td>Format</td>
<td>Determines the width of the form.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>Determines the height of the form.</td>
</tr>
<tr>
<td>Picture</td>
<td>Format</td>
<td>Adds a graphic or picture for the form or report background. Click the Build button to browse for the folder and file.</td>
</tr>
<tr>
<td>Picture Type</td>
<td>Format</td>
<td>Determines if the picture is embedded or linked.</td>
</tr>
<tr>
<td>Picture Size Mode</td>
<td>Format</td>
<td>Determines how the contents of a picture frame are displayed: Clip, Stretch, or Zoom.</td>
</tr>
<tr>
<td>Picture Alignment</td>
<td>Format</td>
<td>Determines the alignment of a picture within a frame.</td>
</tr>
<tr>
<td>Picture Tiling</td>
<td>Format</td>
<td>Determines whether a picture is tiled within a frame.</td>
</tr>
<tr>
<td>Grid X</td>
<td>Format</td>
<td>Determines the number of subdivisions (horizontal) in a grid.</td>
</tr>
<tr>
<td>Grid Y</td>
<td>Format</td>
<td>Determines the number of subdivisions (vertical) in a grid.</td>
</tr>
<tr>
<td>Layout for Print</td>
<td>Format</td>
<td>Determines whether the form uses printer fonts.</td>
</tr>
<tr>
<td>Palette Source</td>
<td>Format</td>
<td>Specifies the path and file name for the graphic file used as a palette.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in Design View. Make sure the Property Sheet pane is displayed and the Form Selector is selected. Select different controls and explore the tabs and properties on the Property Sheet.
## Table 8-5: Important Form Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Source ★</td>
<td>Data</td>
<td>Specifies the table or query whose data will be used in the form.</td>
</tr>
<tr>
<td>Filter</td>
<td>Data</td>
<td>Specifies a filter that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Order By</td>
<td>Data</td>
<td>Specifies a sort order that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Allow Filters</td>
<td>Data</td>
<td>Determines whether filters may be applied to the form.</td>
</tr>
<tr>
<td>Allow Edits ★</td>
<td>Data</td>
<td>Determines whether records can be modified in the form.</td>
</tr>
<tr>
<td>Allow Deletions ★</td>
<td>Data</td>
<td>Determines whether records can be deleted in the form.</td>
</tr>
<tr>
<td>Allow Additions ★</td>
<td>Data</td>
<td>Determines whether records can be added in the form.</td>
</tr>
<tr>
<td>Data Entry ★</td>
<td>Data</td>
<td>Allows you to select “Yes” if you only want to use the form to add new records.</td>
</tr>
<tr>
<td>Event Tab</td>
<td>Event</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Pop Up</td>
<td>Other</td>
<td>Determines whether the form appears in a pop-up window that remains on top of all other windows.</td>
</tr>
<tr>
<td>Modal</td>
<td>Other</td>
<td>Determines whether the form keeps the focus (you can’t switch to any other windows or forms) until it is closed.</td>
</tr>
<tr>
<td>Cycle</td>
<td>Other</td>
<td>Determines how the tab key should cycle.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Other</td>
<td>Allows you to select a custom menu bar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Other</td>
<td>Allows you to select a custom toolbar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Shortcut Menu</td>
<td>Other</td>
<td>Determines if right mouse button contextual menus are permitted in the form.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specifies a user-created shortcut menu that appears when a user clicks the right-mouse button.</td>
</tr>
<tr>
<td>Help File</td>
<td>Other</td>
<td>Specifies the name of the custom Help file for the form.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specifies an identifier number for a user-created Help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Has Module</td>
<td>Other</td>
<td>Specifies if the form has Visual Basic code behind it.</td>
</tr>
<tr>
<td>Fast Laser Printing</td>
<td>Other</td>
<td>Print the form using optimized laser-printer formatting.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Specifies extra user-defined information that is stored in the form.</td>
</tr>
</tbody>
</table>
Changing a Control’s Data Source

There are three types of controls that you can add to your forms. They are:

- **Bound Controls**: Bound controls are bound or connected to an underlying field in a table or query. You use bound controls to display, enter, and update field values in your database. The fields that you can add to a form using the Field List are all examples of bound controls.

- **Unbound Controls**: Unbound controls are not bound or connected to an underlying field in a table or query. You use unbound controls to display information. Labels, text boxes, and buttons can all be inserted on a form as unbound controls.

- **Calculated Controls**: Calculated controls are based on an expression and are used to calculate values in a form, such as arithmetic problems. Technically, calculated controls are unbound controls because they do not update any table fields.

A control’s Control Source property determines what is displayed in a control:

- A bound control’s Control Source property contains the name of the underlying database field to which it is bound.

- An unbound control’s Control Source property does not contain the name of an underlying database field.

- A calculated control’s Control Source property contains an expression that calculates the values displayed in the control.

This lesson explains how you can change a control’s Control Source property.

1. Display the form in Design View or Layout View and make sure the Property Sheet is displayed.

2. Select the desired control.

   You can find the Control Source property on the Data tab on the Property Sheet.

3. Click the Data tab on the Property Sheet.

   Set the Control Source property to determine what is displayed in the control. You can bind the control to a field in the form’s underlying query or table by clicking the arrow button, or you can type text or an expression directly into the Control Source box.

4. Click the Control Source box and edit the source as desired.

---

**Exercise**

- **Exercise File**: Form.accdb
- **Exercise**: Delete the First Class label and text box. Add a check box control below the Smoker label. Bind the check box to the First Class database field using the Control Source box on the Data tab of the Property Sheet. Change the check box’s label so it reads “First Class”. View the form in Form View and try checking and unchecking the First Class box. Save and close the form.
Creating a Calculated Control

A calculated control is an unbound control that displays totals and other arithmetic computations on a form. You create calculated controls by entering an expression (or formula) to perform the calculation in the control’s Control Source property.

In forms, expressions start with the equal sign (=), which tells Access that you want to perform a calculation. After the equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Expressions can contain explicit values, such as the numbers “4” or “5” or can reference the values contained in database fields. For example, the formula =}[Cost]*}[Commission] would multiply the values in the Cost and Commissions fields. To enter fields in an expression, type the field name in brackets ([Order Total]). If a field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets ([Customer Tours]) followed by an exclamation mark (!) and then the field, such as [Order Total].

In this lesson we’ll look at how to create a calculated control.

1. Display the form in Design View or Layout View and make sure the Property Sheet is displayed.
2. Select the desired control.
3. Click the Data tab on the Property Sheet and click in the Control Source box.
4. Type the expression, using proper Access syntax.

Other Ways to Enter an Expression:
- Click the button in the Control Source box and use the Expression Builder to create the expression.

Tips
- You can also use expressions to create calculated controls and fields in queries and reports.
- If a database field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets, followed by an exclamation mark (!). For example, =}[tblTours]![Cost]*0.15.

Exercise
- Exercise File: Form.accdb
- Exercise: Display the frmTours form in Design View. Create a calculated control in the Total text box that finds the total cost of each tour by multiplying the Number of Tickets field by the Cost field: Display the Expression Builder in the Control Source box on the Data tab on the Property sheet. Enter the expression =}[Number of Tickets]*}[Cost]. View the form in Form View and click the Next Record button to scroll through records and see the Total calculation at work. Save the form.
Changing a Control’s Default Value

You can enter a default value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX.” When users add a record using a form, they can either accept the “TX” default value for the State field or enter their own value.

1. Display the form in Design View or Layout View and make sure the Property Sheet is displayed.

2. Select the desired control.
   For example, you could select the State text box to create a default value that enters the state.

3. Click the Data tab on the Property Sheet.

4. Click in the Default Value box and type the default value you want to appear for new records.
   Now when you add a new record to the form, the default value will appear automatically. You can always replace the default value with your own data if desired.

Tips

✓ Control properties in a form are inherited, or passed down, from the original properties in the underlying table or query. For example, if you set the Default Value property for a table’s State field to “TX,” the “TX” Default Value property will be passed on to a related State control on a form by default.

Exercise

- Exercise File: Form.accdb
- Exercise: Display the frmCustomers form in Design View. Enter the default value “MN” for the State text box. Change to Form View, add a new blank record, and notice that MN is already filled in. Save your changes.

Figure 8-14: Setting the Default Value property for a control.

Figure 8-15: The default value appears in the control when you add a new record with the form.
Creating a Subform

A subform is a form within a form. The primary form is called the main form, and the form within the form is called the subform. Subforms are especially useful when you want to show data from tables or queries with a one-to-many relationship. For example, a Customer form might have a subform that displays each customer’s Orders.

The main form and subform are linked so that the subform displays only records that are related to the current record in the main form. For example, when the main form displays a particular customer, the subform displays only orders for that customer.

Let’s look at how to create a subform.

1. Open the form you want to use in Design View. Usually you will want to have the Control Wizard assist you when you add a subform.

2. Make sure the Use Control Wizards button is selected under the More button in the Controls group on the Design tab on the Ribbon. Before you add a subform, make sure that you have enough room for it on the main form.

3. Resize the form if necessary. Now you’re ready to add the subform.

4. Click the Design tab under Form Design Tools on the Ribbon and click the Subform/Subreport button under the More button in the Controls group.

   The mouse pointer changes to a , indicating that you can click and drag the subform onto the main form.

5. In the form, click and drag where you want the subform to appear.

   The Subform Wizard appears and asks if you want to use an existing form for your subform or if you want to build a new form, using tables or queries. In this lesson, we will have the Wizard build us a new form using tables and queries to use as our subform.

6. Click Next.

   The next step of the Wizard appears. Here you have to select the table or query and fields that you want to display in your subform.

Exercise

• Exercise File: Form.accdb
• Exercise: Display the frmEmployees form in Design View. Make sure the Control Wizards button has been pressed.

   Add a subform to display the tours that each employee has sold. Resize the form area to add about 3 inches of space below the current data. Add the subform in this new space (make it about 2 inches tall by 5 inches wide. In the Wizard, select Query:qryCustomerTours as the source for the subform and select the EmployeeID, Date, TourID, CustomerID, and Number of Tickets fields to the Selected Fields list. Finish the Wizard. Save your changes and display the form in Form View.

Figure 8-16: Selecting the table or query and fields that you want to include on your subform.
7. Click the Tables/Queries list arrow and select the table or query you want to use for the subform.

Now you need to select the fields you want to appear in the subform. You must select the related field used to join the main form and subform. This related field must appear on both the main form (where it is called the parent field) and on the subform (where it is called the child field).

Tip: It’s very important that the underlying tables or queries of the main form and subform have a related field and that the related field appears somewhere on both forms.

8. Select the fields you want to appear in the subform and click Next.

The next step in the Wizard is to define the fields that link the main form and the subform. The Subform Wizard is often smart enough to recognize the field and use it to link the two forms. If not, you will have to click the Define my own option and select the two related fields.

9. If necessary, specify the parent and child fields that link the main form and subform.

10. Click Next, then click Finish.

Access creates the subform and adds it to the main form.

11. Save your changes to the form.

Subforms created with the Subform Wizard are usually a little rough around the edges and may require a little clean-up work.

Figure 8-17: Subforms are great for working with data in multiple tables with one-to-many relationships. Here the subform displays all the tours sold by each employee.
Modifying and Working with Subforms

Subforms rarely come out the way you want them to the first time: They may be too small or too large and must be resized so that the main form and subform fit together nicely. Or, if you’re using an existing form as a subform, you may need to change the subform layout.

This lesson covers the basics of modifying and working with subforms.

Modify a subform

1. Click anywhere in the subform.
   To edit the subform’s structure or size, you need to be in Design View.

2. Edit the subform as needed.

Tips

✓ The main form and sub form each have their own set of navigation buttons that you can use to add and move between records.

✓ If you have set referential integrity between two or more related fields in a subform’s underlying table or query, you will have to obey those referential integrity rules in order to add or edit a record in the subform. For example, you can’t enter a number in the TourID field unless that number exists in the qryCustomerTours query.

Display a subform’s properties

1. In Design View, double-click the subform’s Form Selector.
   The subform’s properties are displayed in the Property Sheet.

Exercise

- **Exercise File**: Form.accdb
- **Exercise**: Display the frmEmployees form that you modified in the previous lesson open in Form View. Practice clicking back and forth between the main and subforms. Then add a new record to the subform using the following information:

<table>
<thead>
<tr>
<th>EmployeeID</th>
<th>Date</th>
<th>TourID</th>
<th>CustomerID</th>
<th>Number of Tickets</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Current)</td>
<td>9/2/07</td>
<td>China</td>
<td>Ali</td>
<td>2</td>
</tr>
</tbody>
</table>

Change to Design View and delete the subform’s label. Select the subform’s Form Selector and view its properties on the Property Sheet. Change the subform’s Default View to Continuous Forms. View the form in Form View and save your changes.

Figure 8-18: Modifying a subform in Design View.
Working with Forms Review

Quiz Questions

82. Which of the following is not used to create a report?
   A. Report button
   B. Report Design button
   C. Report Wizard
   D. Report Add-in

83. You can resize report columns in Layout View. True or False?

84. You can only add one of Access’s three built-in logos to a report—you can’t add your own. (True or False?)

85. To display a report in Design View, right-click the report in the Navigation Pane and select Display Design. (True or False?)

86. In Layout View, the commands for adjusting page margins and orientation are found in the ________ group
   A. Page Setup
   B. Page Format
   C. Page Layout
   D. Adjust Page

87. You can place page numbers only at the top of a report page. (True or False?)

88. You can group and sort a report using the ________ pane.
   A. Group Report
   B. Group, Sort, and Total
   C. Group and Sort
   D. Summarize

89. The Total feature creates a calculated control for you. (True or False?)

90. Which of the following is NOT a report section?
   A. Report Header
   B. Report Title
   C. Detail
   D. Page Footer
### Quiz Answers

82. D. Using the Report Add-in is not a way to create a report.
83. True. You can resize columns and controls in Layout View.
84. False. You can add your own logo to a report.
85. False. Right-click the report in the Navigation Pane and select Design View.
86. C. They’re found in the Page Layout group of commands.
87. False. You can place page numbers at either the top or bottom of a report page.
88. B. You can group and sort a report using the Group, Sort, and Total pane.
89. True. The Total feature creates a calculated control that summarizes the field you specify.
90. B. Report Title is not a section in a report.
Working with Reports

Creating a Report ........................................... 188
   Create a report with the Report button .. 188

Working in Layout View ................................ 189
   Change report view................................. 189
   Understanding controls............................ 189
   Work with report layouts ....................... 189
   Resize, move, and delete controls or columns ........................................... 190
   Add a field........................................... 190
   Add a field........................................... 190

Adding a Logo ................................................. 191

Working in Design View ................................ 192
   Display a report in Design View............. 192
   Controls ............................................. 192

Adjusting Page Margins and Orientation ..... 194
   Adjust page margins.............................. 194
   Adjust orientation................................. 194

Adding Page Numbers and Dates ............. 195
   Add a page number............................... 195
   Add a date and time information............ 196

Grouping and Sorting ................................. 197
   Group or sort on a field....................... 197
   Work with the Group, Sort, and Total pane ........................................... 197

Summarize Data using Totals ................. 199
   Total a field....................................... 199

Understanding Report Sections ............... 201

It’s easy to print a simple list of records in a table or query. But if you want your printed hard copies to look professional, you’ll need to create a report. Reports present information from tables and queries in a format that looks great when printed.

Reports can also summarize and analyze the information in your database. For example, a report might tell you which of your employees has used the most sick days for the past year.

This chapter explains how to create and work with reports.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Creating a Report

There are two quick ways to create a report:

- **The Report Wizard** is a good choice if you want to create a report from more than one table, or if you want to influence the design of the report while you create it.
- **The Report button** instantly creates a report based on the currently selected table or query.

We’ve covered the Report Wizard in another lesson, so we’ll look at the Report button here.

Create a report with the Report button

You can instantly create a report with the Report button.

1. Select the table or query you want to base the report on.
   
   You can select the table or query either in the Navigation pane or, if the table or query is already open, in the database window.

2. Click the **Create** tab on the Ribbon and click the **Report** button in the Reports group.

   A report is instantly created based on the active table or query, and appears in Layout View.

Other Ways to Create a Report:

You can also create a blank report. Click the **Create** tab on the Ribbon and click either the **Blank Report** button (to create and display the report in Layout View) or the **Report Design** button (to create and display a blank report in Design View).

Exercise

- **Exercise File**: Report.accdb
- **Exercise**: Use the Report button to create a report based on the qryCustomers query. Save the report as “rptCustomers”.

Figure 9-1: Creating a report based on the qryCustomers query with the Report button.
Working with Reports

Working in Layout View

Much like with forms, you can modify reports in either Layout View (for simple changes) or Design View (for more complex changes). One advantage of Layout View is that it displays the report much as it will look when printed—unlike Design View, which displays all the messy, behind-the-scenes report structure. Layout View does still display field, row, column, header, footer, and page borders so you can easily work with the layout. In this lesson, we’ll look at some of the simple modifications you can make in Layout View.

Tips

✓ The modifications in this lesson can also be performed in Design View, but using Layout View is usually easier.

Change report view

1. Click Home tab on the Ribbon and click the View button list arrow in the View group.

Here you have view options such as Report View, Print Preview, Layout View, and Design View.

2. Select a view.

Other Ways Change Report View:

Click one of the view buttons on the Status bar.

Understanding controls

Just like with forms, any object that appears on a report is called a control. A text box, used to display record information (usually fields from a table or query), or a column label are both examples of controls.

Work with report layouts

You can easily change the layout of the report using the commands in the Table group and the Position group on the Arrange tab.

1. Click the Arrange tab on the Ribbon.

The Table group contains some quick and easy commands for changing your layout:

Tabular, Stacked: Click these buttons to change the way controls are arranged on your report—in a spreadsheet-like tabular format, or a vertically stacked arrangement. Experiment to find the best layout for your report.

The Position group contains commands for changing the format of the fields and the data within those fields.

Exercise File: Report.accdb

Exercise: Change the rptCustomers report to Report View, then back to Layout View. In the Position group on the Arrange tab, change the Control Padding to None. Change to a Stacked layout, then undo that action. Delete the CustomerID, ZipCode, DOB, SSN, Smoker, and First Class columns. Delete the Date and Time fields from the top of the report and the page number field from the bottom of the report. Add the DOB field back to the report as the last column. Manually resize each column to make the report one page wide (use the dotted page lines for guidance). Edit the “qryCustomer” title label so it reads “Customers”. Save.

Table 9-1: Report Views

<table>
<thead>
<tr>
<th>Report Views</th>
<th>Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report View</td>
<td>Layout View</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Design</td>
</tr>
</tbody>
</table>

Figure 9-2: The Arrange tab.
Control Margins, Control Padding: Click these buttons to change the location of data within fields, and also the distance between fields.

2. Click a command in the Control Layout group.

✓ Tip: If you decide you don’t like a change you’ve made to your report’s layout, you can always use the Undo feature to return to where you started.

Resize, move, and delete controls or columns

You can easily move and resize columns of data or individual controls such as labels or logos simply by clicking and dragging them with the mouse. You can also delete these items with the press of a key.

✓ Tips
✓ In Layout View, data is grouped together in columns and rows by Access so that it can be easily modified together.

Resize: Click and drag the right or left border of a column or control to make it larger or smaller.

Move: Click and drag a column’s heading to a new location to move a column, or simply click and drag a control to a new location.

Delete: Select a column or control and press the <Delete> key.

Add a field

If you create a form with the Report button, the report will already contain all the fields from the table or query on which you based the report. But if you’ve created your report with the Report Wizard, by using the Blank report option, or if you’ve deleted some fields, you may want to add more fields at some point. Here’s how:

1. Make sure the Field List pane is displayed.

✓ Tip: If you don’t see the Field List pane, click the Design tab under Report Layout Tools on the Ribbon and click the Add Existing Fields button in the Tools group.

2. Click and drag the field you want to add from the Field List onto the report.

The field is added to the report wherever you placed it, and Access automatically moves the other fields to accommodate it.

✓ Tip: To change a field label’s text, select the label, click inside the label, then edit or replace the text.
Adding a Logo

In this lesson, we’ll look at how you can easily add your logo to a report in Layout View.

Tips

✓ If you created your report using the Report button, a logo placeholder will already be inserted in the upper-left corner of the report. When you insert your own logo, it will replace it automatically.

✓ You can also add a logo in Design View.

1. Display the report in Layout View.

2. Click the Design tab under Report Layout Tools on the Ribbon and click the Logo button in the Header/Footer group.

   The Insert Picture dialog box appears.

3. Browse to the logo file and double-click it.

   The logo is added to the report’s header.

Tips

✓ Once you’ve added the logo, you can move it or resize it like any other field or control.

Exercise

- Exercise File: Report.accdb, Logo.jpg
- Exercise: Add a logo to the rptCustomers report (insert the Logo.jpg file). Save.

Figure 9-5: The Header/Footer group on the Design tab.

Figure 9-6: Selecting a logo file in the Insert Picture dialog box.

Figure 9-7: A logo inserted into a report.
Working with Reports

Working in Design View

To make more complex report modifications, you’ll want to work with your reports in Design View. If you have already worked with forms in Design View, you should be in familiar territory—Design View is remarkably similar for both forms and reports.

Display a report in Design View

1. Right-click the report in the Navigation Pane and select Design View.

   The report opens in Design View.

   Other Ways Display a Report in Design View:
   - If the report is already open in the database window, click the Home tab on the Ribbon, click the View button list arrow in the Views group, and select Design View.

Controls


   Control commands are found in the Controls group.

   Tips
   - For more details about controls, see the lesson about adding controls to forms.

   Table 8-2: Controls provides more information about controls.

<table>
<thead>
<tr>
<th>Table 9-2: Controls</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select</strong></td>
</tr>
<tr>
<td><strong>Text Box</strong></td>
</tr>
<tr>
<td><strong>Label</strong></td>
</tr>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td><strong>Tab Control</strong></td>
</tr>
<tr>
<td><strong>Hyperlink</strong></td>
</tr>
<tr>
<td><strong>Option Group</strong></td>
</tr>
<tr>
<td><strong>Insert Page Break</strong></td>
</tr>
<tr>
<td><strong>Combo Box</strong></td>
</tr>
<tr>
<td><strong>Chart</strong></td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Report.accdb
- **Exercise:** Display the rptCustomers report in Design View and familiarize yourself with the parts of the screen and the controls in the Controls group.
### Table 9-2: Controls

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Line</strong></td>
<td>Enables you to draw a line.</td>
</tr>
<tr>
<td><strong>Toggle Button</strong></td>
<td>Creates a toggle button that allows you to display and enter data from a Yes/No field. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>List Box</strong></td>
<td>Creates a box that lets the user select an item from a list of options. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>Rectangle</strong></td>
<td>Enables you to draw a rectangle.</td>
</tr>
<tr>
<td><strong>Check Box</strong></td>
<td>Creates a box that is checked or unchecked. Use to enter data from a Yes/No field. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>Unbound Object Frame</strong></td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td><strong>Attachment</strong></td>
<td>Displays any attachments linked to the record.</td>
</tr>
<tr>
<td><strong>Option Button</strong></td>
<td>Creates an option button (or radio button) that allows the user to make a single selection from two or more choices. Option Buttons are normally used with the Option Group control. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>Subform/Subreport</strong></td>
<td>Inserts another report within the main report. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td><strong>Bound Object Frame</strong></td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database.</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td>Displays a picture or graphic file that you specify.</td>
</tr>
</tbody>
</table>
Adjusting Page Margins and Orientation

You’re probably already aware that margins are the empty space between the text and the left, right, top, and bottom edges of a printed page. The default margins for a report are .25 inches at the top, bottom, left, and right. If you don’t already know how to adjust a page’s margins, you will after this lesson. You will also learn how to change the page orientation.

Adjust page margins

There are many reasons to change a report’s margins: To make room for more data, to add some extra space if you’re binding a document, or to leave a blank space to write in notes.

1. Display the report in Layout or Design View.

2. Click the Page Setup tab under Report Layout Tools on the Ribbon and click the Margins button in the Page Size group.

   Here you have a few choices for margin size: Normal, Wide, or Narrow (the default choice).

3. Select the option you want to use.

   Tip: If you want to fine-tune the margin size, click the Page Setup button in the Page Layout group, click the Print Options tab, and enter the exact top, bottom, left, and right margin sizes you want to use.

Adjust orientation

Everything you print uses one of two different types of paper orientations: portrait and landscape. In Portrait orientation (the default for Access reports), the paper is taller than it is wide—like a painting of a person’s portrait. In Landscape orientation, the paper is wider than it is tall—like a painting of a landscape.

1. Display the report in Layout or Design View.

2. Click the Page Setup tab under Report Layout Tools on the Ribbon and click the Landscape or Portrait button in the Page Layout group.

   The page’s orientation changes.

Tips

✓ You can also change the size of the page from the default Letter size. Click the Size button in the Page Size group and select a size.

---

Exercise

Exercise File: Report.accdb

Exercise: Display the rptCustomers report in Layout View. Change the page margins to Wide, then to Narrow. Change the page orientation to Landscape. View the report in Print Preview View. Change the orientation back to Portrait. Save.
Adding Page Numbers and Dates

Reports that are several pages long often have information such as the page number or the date located at the top (header) or bottom (footer) of every page. In this lesson you will learn how to use the Page Number command and Date and Time command to add page numbers and/or the current date to your report.

Tips

When you create a report based on a table or query using the Report button, Access automatically adds fields for the date, time and page number to the report. If you use the Report Wizard, only the date and page number are included by default.

**Add a page number**

1. In Layout View, click the **Design** tab under Report Layout Tools on the Ribbon and click the **Page Numbers** button in the Header/Footer group.

   The Page Numbers dialog box appears, giving you several choices for formatting the page numbers:

   - **Page N**: Prints only the page number (for example, “Page 5.”)
   - **Page N of M**: Prints the page number and the total number of pages (for example, “Page 5 of 15.”)

   **Other Ways to Add a Page Number:**

   You can add a page number or date the same way in Design View.

2. Select the option you want to use in the Format section.

   Next you need to specify where on the page you want the page number to appear—at the top or bottom of the page—and how you want the page numbers aligned.

3. Select the option you want to use in the Position section, then click the **Alignment** list arrow and select an alignment option. Click **OK**.

   The Page Numbers dialog box closes, and Access adds a text box with a page number expression.

---

**Exercise**

- **Exercise File**: Report.accdb
- **Exercise**: Display the rptCustomers report in Layout View. Add a page number in “Page N of M” format to the bottom of the page (center alignment). Add the date in “xx/xx/xxxx” format but don’t include the time. View the report in Print Preview to see the page number and date displayed. Save and close the rptCustomers report.
Add date and time information

1. In Layout View, click the **Design** tab under Report Layout Tools on the Ribbon and click the **Date and Time** button in the Header/Footer group.

   The Date and Time dialog box appears. You can specify to add the date, time, or both to your reports.

2. Check or uncheck the **Include Date** and **Include Time** check boxes as desired.

   Just like the Page Number dialog box, the Date and Time dialog box gives you several choices for how the date and/or time can be formatted.

3. Select desired formatting options, then click **OK**.

   The Date and Time dialog box closes and Access adds the date or time as you specified.

   ✔ **Tip:** Access may place the date, time, or page numbers on top of an existing control. If so, click and drag the text box to move the control to a new location on the report.

![Figure 9-13: The Date and Time dialog box.](image-url)
Grouping and Sorting

If you create a report using the Report Wizard, you specify which fields you want to use to group and/or sort your report by. If you’re modifying an existing report or creating a report from scratch, you’ll need to use the methods presented in this lesson.

There are two ways to group and sort:

- **Right-click fields in Layout View** and select an option from the contextual menu. This is the easier—and hence, preferred way—to group and sort.
- **Display the Group, Sort, and Total pane** in either Layout or Design View, and use the commands in the pane to make advanced adjustments to grouping and sorting.

**Group or sort on a field**

Organizing records into logical groups often makes them easier to read and understand. For example, you could group a sales report by the date field to quickly see how many sales occurred in a particular month.

1. In Layout View, right-click the field you want to group or sort on, and select **Group On** or a sort option from the contextual menu.

   A grouping level is added to the report and a group header is created—which you can see if you change to Design View.

   ✔ **Tip:** Sort options may include Sort A to Z or Sort Largest to Smallest, depending on the type of data you’re sorting.

**Work with the Group, Sort, and Total pane**

You can also group and sort your report data using the Group, Sort, and Total pane. Using the pane allows you to add multiple levels of grouping and sorts.

1. Display the report in Design or Layout View.

2. Click the **Design** tab on the Ribbon and click the **Group & Sort** button in the Grouping & Totals group.

   Access displays the Group, Sort and Total pane at the bottom of the screen. Here you’ll see any fields that are currently being used for sorting or grouping your report.

---

**Exercise**

- **Exercise File:** Report.accdb
- **Exercise:** Display the rptAnnualSales report in Layout View. Group the report on the TourName field. Use the Group, Sort, and Total pane to add a sort level that sorts by date from oldest to newest. View the report in Print Preview View. Save.

![Figure 9-14: A report grouped by the TourName field and sorted by date.](image)
3. Click the **Add a group** or **Add a sort** button in the Group, Sort and Total pane and select a field for grouping records.

The records are grouped or sorted, and each level of sorting or grouping that you add contains several options. These options allow you to change the sort order, create a group header or footer section, or add totals.

4. Select options you want to use by clicking on the option on the group or sort level.

   **Tip:** If you want to see even more options, click **More Options** on the desired level.

**Tips**

- You can set up to 10 grouping and sorting levels in a report.
Summarize Data using Totals

A calculated control displays totals and other arithmetic computations on a form or report. In this lesson, we’ll look at how to add use the Total feature to add calculated fields to summarize information on a report.

With the Total feature you could, for example, total the number of phone calls each telemarketer at your company made and the number of phone calls made by all your telemarketers.

Table 9-3: Common Total Operations describes the operations you will use most often to total your reports.

**Total a field**

With the Total feature, Access can calculate a sum, average, or count for a field.

1. In Layout View, right-click the field you want to total, point to Total [field name] on the contextual menu, and select an operation.

A grand total appears at the end of the report, and if you have created any groups in the report, group totals are added after each group as well.

**Tips**

✓ The operations that are available will vary depending on the type of data in the field.

✓ You can modify the totals using options found on the Group, Sort, and Total pane.
## Table 9-3: Common Total Operations

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Totals all the values listed in a field.</td>
<td>Sum([InvoiceTotal])</td>
</tr>
<tr>
<td>Average</td>
<td>Calculates the average of all the values listed in a field.</td>
<td>Avg([InvoiceTotal])</td>
</tr>
<tr>
<td>Count Records</td>
<td>Counts the number of records.</td>
<td>Count(*)</td>
</tr>
<tr>
<td>Count Values</td>
<td>Counts how many values are listed in a field.</td>
<td>Count([InvoiceTotal])</td>
</tr>
<tr>
<td>Max</td>
<td>Finds and displays the largest value listed in a field.</td>
<td>Max([InvoiceTotal])</td>
</tr>
<tr>
<td>Min</td>
<td>Finds and displays the smallest value listed in a field.</td>
<td>Min([InvoiceTotal])</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Finds and displays the amount of deviation from the average.</td>
<td>StDev([InvoiceTotal])</td>
</tr>
<tr>
<td>Variance</td>
<td>Finds and displays the variance of the data set.</td>
<td>Var([InvoiceTotal])</td>
</tr>
</tbody>
</table>
Understanding Report Sections

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report.

If you’ve worked with headers and footers in a word-processing program, you’re familiar with the section concept.

Table 9-4 describes each of the sections, which are most easily seen when you view the report in Design View.

**Tips**

✔ To change the size of a section, click and drag its section line up or down.

<table>
<thead>
<tr>
<th>Table 9-4: Report Sections</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Report Header</strong></td>
</tr>
<tr>
<td><strong>Page Header</strong></td>
</tr>
<tr>
<td><strong>Group Header</strong></td>
</tr>
<tr>
<td><strong>Detail</strong></td>
</tr>
<tr>
<td><strong>Group Footer</strong></td>
</tr>
<tr>
<td><strong>Page Footer</strong></td>
</tr>
<tr>
<td><strong>Report Footer</strong></td>
</tr>
</tbody>
</table>

![Figure 9-17: Report sections](image-url)
Working with Reports Review

Quiz Questions

91. Which of the following is not used to create a report?
   A. Report button
   B. Report Design button
   C. Report Wizard
   D. Report Add-in

92. You can resize report columns in Layout View. True or False?

93. You can only add one of Access’s three built-in logos to a report—you can’t add your own. (True or False?)

94. To display a report in Design View, right-click the report in the Navigation Pane and select Display Design. (True or False?)

95. In Layout View, the commands for adjusting page margins and orientation are found in the _______ group
   A. Page Setup
   B. Page Format
   C. Page Layout
   D. Adjust Page

96. You can place page numbers only at the top of a report page. (True or False?)

97. You can group and sort a report using the _______ pane.
   A. Group Report
   B. Group, Sort, and Total
   C. Group and Sort
   D. Summarize

98. The Total feature creates a calculated control for you. (True or False?)

99. Which of the following is NOT a report section?
   A. Report Header
   B. Report Title
   C. Detail
   D. Page Footer
Quiz Answers

91. D. Using the Report Add-in is not a way to create a report.
92. True. You can resize columns and controls in Layout View.
93. False. You can add your own logo to a report.
94. False. Right-click the report in the Navigation Pane and select Design View.
95. C. They’re found in the Page Layout group of commands.
96. False. You can place page numbers at either the top or bottom of a report page.
97. B. You can group and sort a report using the Group, Sort, and Total pane.
98. True. The Total feature creates a calculated control that summarizes the field you specify.
99. B. Report Title is not a section in a report.
Formatting Fonts .................................................. 205
  Change font size ........................................... 205
  Change font type .......................................... 205
  Format text with bold, italics, or underlining ......... 205
Changing Text Alignment .................................. 207
Changing Colors ............................................. 208
Using Conditional Formatting ......................... 209
Adding Pictures, Lines and Gridlines ............... 210
  Insert a graphic ........................................... 210
  Add gridlines ............................................. 210
  Draw a line ............................................... 211
Working with Number Formatting ..................... 212
Using AutoFormat .......................................... 213

This chapter guides you through the process of creating sharp-looking forms and reports that have colorful fonts, sharp-looking borders, and even controls with 3-D effects.

This chapter explains how to format your forms and reports to make them more visually attractive and easier to read. You will learn how to change the appearance, size, and color of fonts and how to align text inside a control. This chapter also describes how you can add pictures and graphics to your forms and reports.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Formatting Fonts

You can emphasize text on a form or report by making the text darker and heavier (bold), slanted (italics), larger, or in a different typeface (or font). The Font group of commands makes it easy to apply character formatting.

Tips

✓ You can format fonts in either Layout or Design View.

✓ Font formatting commands can be accessed through the Text Formatting group on the Home tab or the Font group on the Format tab under Report Layout Tools/Form Layout Tools.

Change font size

Font sizes are measured in points (pt.), which are 1/72 of an inch. The larger the number of points, the larger the font.

1. Click the control that contains the text you want to format.

2. Click the Format tab on the Ribbon under Report Layout Tools, click the Font Size list arrow in the Font group, and select the desired font size.

   The font size changes.

   Tip: When you change a control’s font size, you will often need to resize the control so that it can properly display its contents.

Change font type

1. Click the control that contains the text you want to format.

2. Click the Format tab on the Ribbon under Report Layout Tools, click the Font list arrow in the Font group, and select the desired font.

   The font type changes.

Format text with bold, italics, or underlining

1. Click the control that contains the text you want to format.

2. Click the Format tab on the Ribbon under Report Layout Tools and click the Bold, Italics, or Underline button in the Font group.

   The text is formatted as specified.

Exercise

Exercise File: Formatting.accdb

Exercise: Display the rptTourSales report in Layout View. Tip: Close the Property Sheet pane if it’s in your way. Change the “Tour Sales” title label to 22 pt Arial font. Bold each of the column headings (TourName, Date, Tickets, Cost). Save.

Figure 10-1: Font formatting commands in the Font group.

Figure 10-2: Changing font size in Layout View.
The Format Painter allows you to copy the formatting attributes from one control and then apply them to another. Click the control with the formatting you want to copy, click the Format Painter button in the Font group, then click a control to apply the formatting. Click the Format Painter button twice to apply formatting more than once.
Changing Text Alignment

This lesson explains how to align a control’s text to the left, center, or right. Alignment only affects what’s inside of a control: If you apply center formatting to a text box, Access will center the text inside the text box—it won’t center the text box control on the form or report.

Tips

✓ You can change text alignment in either Layout or Design View.

✓ Text alignment commands can be accessed through the Text Formatting group on the Home tab or the Font group on the Format tab under Report Layout Tools/Form Layout Tools.

1. Click the control that contains the text you want to align.

2. Click the Font tab on the Ribbon under Report Layout Tools and click the Align Text Left, Center, or Align Text Right button in the Font group.

The text is aligned as specified.

Tips

✓ Besides aligning text within a control, you can also align controls themselves within a form or report. Select the controls you want to align and use the commands in the Sizing & Ordering group on the Arrange tab.

Exercise

- Exercise File: Formatting.accdb
- Exercise: Display the rptTourSales report in Layout View. Apply center text formatting to the “Date” and “Cost” column labels. Save.

![Figure 10-3: Examples of text alignment.](image)

![Figure 10-4: Applying center formatting.](image)
Changing Colors

In this day of color printers and high-resolution monitors, choosing an appropriate color for your report or form is an important formatting decision. If used tastefully, colors can make your forms and reports look more visually attractive. You can add color to lines, text, or even the background of your headers and footers.

In this lesson, you will learn how to apply color to your reports and forms.

Tips

✓ You can change colors in either Layout or Design View.

✓ Color formatting commands can be accessed through the Text Formatting group on the Home tab or the Font group on the Format tab under Report Layout Tools/Form Layout Tools.

1. Click the control or area (like a Header) you want to color.

2. Click the Format tab on the Ribbon under Form Layout Tools, click the Font Color button list arrow you want to use in the Font group, and select a color.

The color is applied. It can be a little confusing to figure out which color button to use at first, so you can refer to Error! Reference source not found. until you get the hang of it.

Other Ways to Change Colors:

In Design View, right-click a field or area (such as a header area) of a form or report, point to Fill/Back Color or Font/Fore Color and select a color.

Exercise File: Formatting.accdb

Exercise: Display the frmCustomers form in Layout View. Change the Font color of the “Customers” title label to the color called “Highlight”, found under Access Theme Colors (it’s an orange color). Change the Fill/Back color of the form detail area to the color called “Tan, Background 2” (a light brown color). Save.

Table 10-1: Color Commands

<table>
<thead>
<tr>
<th>Color Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Color</td>
<td>Applies color to the text in the selected control(s).</td>
</tr>
<tr>
<td>Fill/Back Color</td>
<td>Applies color to the background of the selected control(s).</td>
</tr>
<tr>
<td>Alternate Fill/Back</td>
<td>Applies a complementary background color to set off alternate records or rows.</td>
</tr>
</tbody>
</table>
Using Conditional Formatting

Conditional Formatting allows you to set a condition for a field, and then specify formatting based on that condition. For example, you could tell Access to format a field’s text with red coloring if the field value is less than 0, or black if it’s greater than or equal to 0.

**Tips**

✓ You can apply conditional formatting in either Layout or Design View.

1. Click the field you want to format.

   You need to select a field that’s bound to an underlying value or text. For example, you can’t use conditional formatting on a label that contains text that has simply been typed in.

2. In Layout View, click the Format tab under Form Layout Tools on the Ribbon and click the Conditional Formatting button in the Control Formatting group.

   The Conditional Formatting Rules Manager dialog box appears. Here all the applied Conditional Formatting rules are displayed.

3. Click New Rule to enter in a new conditional formatting rule.

4. In the Select a rule type, choose whether the conditional formatting is based on the value of the field or the value in relation to the other records.

5. If you select *Check values in the current record or use an expression*, enter the conditions in the Format only cells where fields.

   Also select the formats that need to be applied to values that meet the conditions using the buttons to the right of the Preview field.

   For example, you could select “Field Value Is”, “less than”, enter “0”, and then select red formatting to format any value less than 0 with red text.

6. If you select *Compare to other records*, select the Type and Value in the Data Bar format settings.

   You can also select an alternative color from the Bar Color list arrow.

7. Click OK.

**Exercise**

- **Exercise File**: Formatting.accdb
- **Exercise**: Display the frmCustomers form in Layout View. Apply conditional formatting to the First Class field so that if the value is equal to 0, the font color is red, otherwise it’s black. View the form in Form View. Change Patricia Ventosa’s First Class status to –1 and notice the formatting change. Change it back to 0. Save.

**Figure 10-7**: The New Formatting Rule dialog box.

**Figure 10-8**: Conditional formatting applied so that 0 values appear in red.
Adding Pictures, Lines and Gridlines

Pictures and lines can make your reports and forms more professional looking. You can insert graphics and pictures created with graphics programs, scanned pictures, or graphics from a clip-art library. This lesson explains how to insert graphics and lines.

Insert a graphic

1. In Design View, click the Design tab under Form Design Tools on the Ribbon and click the Image button in the Controls group.
   The pointer changes.
2. Click and drag on the form or report where you want to place the graphic.
   The Insert Picture dialog box appears.
3. Browse to and select the graphic file you want to use and click OK.
   The graphic is inserted and can be modified like any other control.

Add gridlines

Forms and reports with lots of information can sometimes be difficult to read. You can quickly add vertical and/or horizontal gridlines to make them more organized.

Tips

✓ You can add gridlines to a form or report in either Layout or Design View.

1. Select the field(s) to which you want to add gridlines.
   Rows of records or heading rows often look good with gridlines.
2. In Layout View, click the Arrange tab under Form Layout Tools on the Ribbon and click the Gridlines button in the Table group.
   You have several gridline options: Both, Horizontal, Vertical, Cross Hatch, Top, Bottom, None.
3. Select the gridline option you want to use.
   Gridlines are added around the field(s).

   Tip: You can change the thickness, type, and color of gridlines using the buttons in the Gridlines group.

Exercise

- Exercise File: Formatting.accdb
- Exercise: Display the frmCustomers form in Design View. Insert the Plane graphic from your practice folder next to the Customers label in the Form Header. Draw a horizontal line across the entire form at the top of the Detail area. Change to Layout View. Add horizontal gridlines, then undo the action. Save.
Draw a line

Although gridlines are usually more useful and easier to use, you can also manually draw lines anywhere you want them in forms and reports.

1. In Design View, click the Design tab under Form Design Tools on the Ribbon and click the Line button in the Controls group.

   The pointer changes.

2. Click and drag on the form or report where you want to place the line.

   The line is added.

   Tip: You can change a line’s thickness, type, and color using the buttons in the Controls group.

Figure 10-11: A form with a line and a graphic.
Working with Number Formatting

You can quickly change the formatting of values in forms and reports to display dollar signs, percent signs, or to change the number of decimal places.

1. In Layout View, click the field you want to format.

2. Click the **Format** tab under Report Layout Tools on the Ribbon and click one of the buttons in the Number group.

   The formatting is applied.

   You can choose from the following formatting buttons:

   **Apply Currency Format**: Formats the value with a dollar sign and marks the thousands place with a comma.

   **Apply Percent Format**: Displays the value as a percentage with a percent symbol.

   **Apply Comma Number Format**: Similar to Currency format, but without the dollar sign.

   **Increase Decimals**: Increases the number of decimal places that are displayed.

   **Decrease Decimals**: Decreases the number of decimal places.

   **Other Ways to Apply Number Formatting**: Click the **Format** list arrow in the Number group and select a number format.

Exercise

- **Exercise File**: Formatting.accdb
- **Exercise**: Display the rptTourSales report in Layout View. Select the Cost field and apply the Comma number format, then decrease the decimal places by 2. Save.

![Figure 10-12: Number group.](image1)

![Figure 10-13: Values formatted in Comma format with no decimal places.](image2)
Using Themes

Themes are built-in collections of formats such as font sizes, colors, and alignments you can quickly apply to a form or report. This replaces the AutoFormat feature in previous versions of Access.

Themes are a great feature if you want your forms and reports to look sharp and professional but don’t have the time to format them yourself.

1. In Layout View, click the Design tab under Report Layout Tools on the Ribbon, click the Themes button in the Themes group, and select the Theme you want to use.

The Theme is applied to the form or report.

Exercise

• Exercise File: Formatting.accdb
• Exercise: In Layout View, apply the Apex Theme to the frmCustomers form. Save.

Figure 10-14: A form with Apex Theme applied.

Figure 10-15: Selecting a Theme.
Formatting Forms and Reports

Review

Quiz Questions

100. Fonts are measured in points. The larger the number of points, the smaller the size of the font. (True or False?)

101. Which of the following is NOT a type of text alignment found in Access forms and reports?
   A. Justified
   B. Center
   C. Left
   D. Right

102. You can change colors in either Layout or Design View. (True or False?)

103. Which of the following is not a conditional formatting option?
   A. Field Value Is
   B. Calculation Is
   C. Expression Is
   D. Field Has Focus

104. With gridlines, you can quickly add vertical and/or horizontal lines to make forms or reports easier to read. (True or False?)

105. Which of the following is not a number format button in the Formatting group?
   A. Currency
   B. Percent
   C. Comma
   D. Justified

106. AutoFormat automatically applies formatting options as you type. (True or False?)

Quiz Answers

100. False. It’s true that fonts are measured in points, but the larger the number of points, the larger the size of the font.

101. A. Justified is not a type of text alignment in Access forms and reports.

102. True. You can change colors in either view.

103. B. Calculation Is is not a conditional formatting option.
104. True. Gridlines allow you to quickly add lines to organize forms and reports.
105. D. Justified is not a number format button in the Formatting group.
106. False. AutoFormat lets you quickly format a form or report using a set of predefined formatting options.
If you find yourself doing the same routine task over and over again, you might want to consider creating a macro to complete the task for you. A macro helps you perform routine tasks by automating them. Instead of manually performing a series of time-consuming, repetitive actions, you can record a single macro that does the entire task all at once for you. For example, instead of finding and opening a specific report, printing it, and then closing it, you could create a macro to print the report with the click of a single button.

A macro is a set of one or more actions that perform a particular operation, such as opening a form or printing a report.

In a way, you can think of macros as a very simple introduction to programming because you can use them to create automated tasks and somewhat complex procedures. Best of all, you don’t have to know a single line of code—Access provides you with everything you need to write a macro.

**Using Exercise Files**
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Creating and Running a Macro

In some programs, such as Microsoft Excel or Word, you can create macros with a “macro recorder” to record your commands, keystrokes, and mouse clicks. Unfortunately, there isn’t a “macro recorder” or Macro Wizard to help you create a macro in Microsoft Access. Instead, you create macros by entering the actions and arguments directly in Macro Design view. Don’t worry—it’s not as difficult as it sounds. Working in Macro Design view really isn’t all that different from working in Table Design view—it’s where you define and edit your macro objects.

Macros that automate a single task, such as opening a form or report, are very simple to create. More complicated macros with several steps or procedures may require a little bit of planning. Before you create a complicated macro, think about what you want the macro to do and the individual actions that are required to complete the operation. Practice the steps needed to carry out the operation and write them down as you go—it will make writing the macro a lot easier.

Create a macro

1. Click the Create tab on the Ribbon and click the Macro button in the Macros & Codes group.

   The macro window appears. The Add New Action list arrow is where you tell Access what you want the macro to do.

2. Click the Add New Action list arrow.

   A list of actions appears. An action, or command, is the basic building block of a macro—it’s an instruction that tells Access what you want the macro to do. There are more than 50 different actions you can choose from. Refer to the Macro Action Reference lesson to see descriptions of common macro actions.

3. Select the action you want to perform.

   For example, you could select OpenForm to create a macro that opens a form.

   Most of the time you will have to give Access more information about how to execute each action—for example, if you are using the OpenForm action, you’d need to select a specific form so that Access knows which form to open. You use arguments to supply Microsoft Access with information about how to carry out the action. Each type of action has its own set of arguments, which appear in the Action Arguments panel, located at the bottom of the macro window.

Exercise

- Exercise File: Macros.accdb
- Exercise: Create a new macro that uses the OpenForm action to open the frmEmployees form. Save the macro as mcrEmployees. Run the macro.
4. Specify any required arguments for the action in the fields that appear, using the list arrows where possible.

For example, if you were using the OpenForm macro, you’d click the Form Name list arrow and select the form you want the macro to open.

5. Repeat Steps 2-4 for each additional action you want the macro to execute.

6. Save and close the macro.

**Run a macro**

Once you’ve created and saved a macro, it appears in the Navigation Pane in the Access window, ready to use.

1. Double-click the macro in the Navigation Pane.

   The macro runs and performs the desired action. If, for example, the macro is meant to open a specific form, Access will make that happen at this time.

   **Tip:** You can also run a macro from the Database Tools tab. Click the Run Macro button in the Macro group on the Database Tools tab. You will be prompted to select a macro from the Macro Name list arrow.

**Run the macro step by step**

You can choose to run a macro a single step at a time to identify any issues with the macro.

1. Right-click the macro in the Navigation pane and select Design View.

2. Click **Single Step** in the Tools group on the Design tab under Macro Tools.

3. Click **Run** in the Tools group on the Design tab under Macro Tools to run the macro a single step at a time.

   Each macro action will be executed and once complete, you will be prompted to go to the next step, stop the macro or continue to run the remainder of the actions at once.
Editing a Macro

Some Microsoft Access tasks require several steps. For example, a particular task might require you to (1) open a form, (2) select a specific record, (3) select a specific field in that record, and then (4) copy the information in that field to the Windows clipboard. Macros can contain as many actions as necessary to automate even the most complicated tasks. Each action appears in its own row and is evaluated and executed in the order in which it appears in the Macro window, from top to bottom.

Let’s look at how to edit a macro to change its arguments and add more steps or actions.

1. In the Navigation Pane, right-click the macro you want to open and select **Design View**.
   The macro appears in Design View.

2. Click the **Add New Action list arrow** at the end of the list of actions and add an additional action, then specify any required arguments for the action. Repeat as desired.
   Refer to the Macro Action Reference lesson to learn more about common macro actions.

3. If you wish to edit an action that already exists in the list, click it once to activate the fields and then adjust the settings.

4. Once you have finished editing the macro, save and close the macro.

### Exercise

- **Exercise File:** Macros.accdb
- **Exercise:** Open the mcrEmployees macro in Design View. Add the action Message Box below the OpenForm action. In the Message box, enter “Please make sure that you remember to add the employee’s phone number!” Select Information in the Type box and type “Notice” in the Title box. Save and close the macro. Run the mcrEmployees macro.

![Figure 11-3: Editing a macro.](image)
Working with Macro Groups

If you are creating lots of macros, you might want to consider organizing them into a macro group to help you manage them. A macro group stores several related macros together in a single macro object.

In this lesson you will learn how to group several related macros together in a macro group.

Create a macro group

1. Expand the Program Flow folder in the Action Catalog.
   
   Tip: If the Action Catalog is not visible, click the Action Catalog button in the Show/Hide group on the Design tab under Macro Tools.

2. Right-click the Group block and click Add Action.
   A group block appears in your action list.

3. Enter in name in the Group field to label this group of macros.

4. To add a new action to the group, click the Add New Action list arrow and add a macro as you normally would.

   If you would like to move existing macros into the group, click them and drag them into the Group block.

5. Repeat step 4 for any additional macros you wish to add or move.

8. Save the macro.

Exercise

- Exercise File: Macros.accdb
- Exercise: Create a macro group: Open the mcrEmployees macro in Design View. Display the Action Catalog and add a group to the Macro area. Name the group “Open Form”. Drag the OpenForm and MessageBox macros into the group. Save the macro. Use the Run Macro dialog box to run the mcrEmployees macro.
Assigning a Macro to an Event

Running macros from the Navigation Pane can be a pain in the neck. That’s why database developers often assign macros to controls—particularly, buttons—so that when a user clicks the button or control, a macro is activated.

1. Open the form or report in Design View to which you want to add an embedded macro.
   For example, you could open an Employees form so that you could add a command button to open a report that displays the sales for each employee.

2. Press <F4> to display the Property Sheet, if necessary.
   The Property Sheet pane appears. If the form or report doesn’t already have a control to assign the macro to, you’ll first need to add one using the Controls group on the Design tab.

3. Click the control (often a button or field) to which you want to assign the macro and click the Event tab in the Property Sheet pane.

4. Click in the box for the type of event you want to assign to the macro.
   A list arrow appears in the box.
   🔄 Tip: For example, you could select “On Click” (to run the macro with one click of the mouse) or “Db1 Click” (with two clicks).

5. Click the list arrow and select the macro you want to assign to the event.

6. Save the form or report.
   Now whenever you perform the event you specified (such as clicking a button in a form once) the macro will run. Table 11-1 describes the different types of events that can be used to run macros.

<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before Update</td>
<td>Macro or function that runs when data in a field or record is changed but before the changes are actually saved to the database. Often used to validate data.</td>
</tr>
<tr>
<td>After Update</td>
<td>Macro or function that runs when data in a field or record is changed and is saved to the database.</td>
</tr>
<tr>
<td>On Change</td>
<td>Macro or function that runs when the contents of a text box or combo box changes or when you move from one page to another page in a tab control.</td>
</tr>
<tr>
<td>On Enter</td>
<td>Macro or function that runs when a control first receives the focus (is selected). The Enter event occurs before the focus moves to a particular control (before the GotFocus event). You can use an Enter macro or event procedure to display instructions when a form or report first opens.</td>
</tr>
<tr>
<td>On Exit</td>
<td>Macro or function that runs when a control loses focus (is deselected) on the same form.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Macros.accdb
- **Exercise:** Create a button on the frmEmployees form that runs the mcrSales macro and displays a Sales Report for the current employee: Open the frmEmployees form in Design View. Add a button to the form’s detail area and click Cancel to close the Command Button Wizard. Edit the button’s label to read “Sales Report”. On the Property Sheet select mcrSales in the On Click box. Save the form and change to Form View. Click the Sales Report button.
### Table 11-1: Event Properties That Can Trigger Macros

<table>
<thead>
<tr>
<th>Event Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>On Got Focus</td>
<td>Macro or function that runs when a control receives the focus (is selected).</td>
</tr>
<tr>
<td>On Lost Focus</td>
<td>Macro or function that runs when a control loses the focus (is deselected).</td>
</tr>
<tr>
<td>On Click</td>
<td>Macro or function that runs when a control is clicked.</td>
</tr>
<tr>
<td>On Dbl Click</td>
<td>Macro or function that runs when a control is double-clicked.</td>
</tr>
<tr>
<td>On Mouse Down</td>
<td>Macro or function that runs when the user presses the mouse button.</td>
</tr>
<tr>
<td>On Mouse Move</td>
<td>Macro or function that runs when the user moves the mouse over a control.</td>
</tr>
<tr>
<td>On Mouse Up</td>
<td>Macro or function that runs when the user releases the mouse button.</td>
</tr>
<tr>
<td>On Key Down</td>
<td>Macro or function that runs when the user presses a key on the keyboard.</td>
</tr>
<tr>
<td>On Key Up</td>
<td>Macro or function that runs when the user releases a key on the keyboard.</td>
</tr>
<tr>
<td>On Key Press</td>
<td>Macro or function that runs when the user presses an ANSI key on the keyboard.</td>
</tr>
</tbody>
</table>
Creating Conditional Expressions

A condition takes action based on a certain condition. For example, if an employee’s weekly sales are more than $2,500, then a condition could calculate a 5-percent commission bonus for the employee; otherwise, it wouldn’t calculate a bonus. If you’re at all familiar with programming, a condition is similar to an If...Then statement.

You enter conditions in the Where Condition field in the macro. If a condition is true, Access executes the action in that row. If a condition is false, Access skips the action in that row and moves to the next action. Conditions often compare values in a specific control to a number, date, or constant. For example, an expression could evaluate the value in a City field that is not equal to “Minneapolis.” Make sure that you use proper Microsoft Access syntax when referring to controls in forms or reports. For multiple scenarios, it is often easier to use the If action, whereas the Where Condition filter is useful for a single criterion.

1. Create a new macro or open an existing one in Design View.

2. Expand the macro if necessary and click in the Where Condition field.

3. Enter the conditional expression in the Where Condition cell, using proper Access syntax. Remember that the condition should follow an If...Then type of format.

   Tip: To use the Expression Builder to help you create the expression, click the Click to invoke Builder button to the right of the Where Condition field. If you are not very familiar with Access syntax, this is the easiest way to enter macro conditions.

   The condition you enter only affects that specific action in the macro—the other actions in the macro will execute without being evaluated. If you want to evaluate the other actions, they must each have their own statement in the Where Condition field.

4. Repeat Step 3 for each action you want to evaluate.

5. Save the macro.

Exercise

- Exercise File: Macros.accdb
- Exercise: Modify the macro assigned to the Sales Report button so the report opens only if the employee selected in the form is not from Minneapolis:
  - Open the frmEmployees form in Design View, select the Sales Report button, click in the On Click box on the Property Sheet, and click the Macro Build button. Delete the existing macro, click the Add New Macro list arrow and select If. Include the following conditions and actions.
    - If: [Forms]![frmEmployees]![City]<>"Minneapolis"
      Then: OpenReport – rptEmployeeSales
      Then: MessageBox – “Sales from non-Minneapolis employees”
  - Add another If action and this time, use the following conditions and actions.
    - If: [Forms]![frmEmployees]![City]="Minneapolis"
      Then: MessageBox – “Call Linda Ross for Minneapolis Sales report”
  - Save the macro. View the form in Form View. Find a record whose City field is NOT “Minneapolis” and click the Sales Report button. Repeat with a record whose City field IS “Minneapolis”.

Figure 11-8: The Expression Builder.

Figure 11-9: Creating a conditional macro.
5. Add additional actions as desired in additional rows. These additional actions will also run when you use the keyboard shortcut.
Macro Action Reference

Following is an overview of common macro actions and their descriptions.

<table>
<thead>
<tr>
<th>Table 11-2: Macro Actions and Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AddMenu</strong></td>
</tr>
<tr>
<td><strong>ApplyFilter</strong></td>
</tr>
<tr>
<td><strong>Beep</strong></td>
</tr>
<tr>
<td><strong>CancelEvent</strong></td>
</tr>
<tr>
<td><strong>CloseWindow</strong></td>
</tr>
<tr>
<td><strong>DisplayHourglassPointer</strong></td>
</tr>
<tr>
<td><strong>EmailDatabaseObject</strong></td>
</tr>
<tr>
<td><strong>FindNextRecord</strong></td>
</tr>
<tr>
<td><strong>FindRecord</strong></td>
</tr>
<tr>
<td><strong>GoToControl</strong></td>
</tr>
<tr>
<td><strong>GoToPage</strong></td>
</tr>
<tr>
<td><strong>GoToRecord</strong></td>
</tr>
<tr>
<td><strong>LockNavigationPane</strong></td>
</tr>
<tr>
<td><strong>MaximizeWindow</strong></td>
</tr>
<tr>
<td><strong>MessageBox</strong></td>
</tr>
<tr>
<td><strong>MinimizeWindow</strong></td>
</tr>
<tr>
<td><strong>MoveAndSizeWindow</strong></td>
</tr>
<tr>
<td><strong>NavigateTo</strong></td>
</tr>
<tr>
<td><strong>OpenForm</strong></td>
</tr>
<tr>
<td><strong>OpenQuery</strong></td>
</tr>
<tr>
<td><strong>OpenReport</strong></td>
</tr>
<tr>
<td><strong>OpenTable</strong></td>
</tr>
<tr>
<td><strong>QuitAccess</strong></td>
</tr>
<tr>
<td><strong>Requery</strong></td>
</tr>
<tr>
<td><strong>RepaintObject</strong></td>
</tr>
<tr>
<td><strong>Requery</strong></td>
</tr>
<tr>
<td><strong>RestoreWindow</strong></td>
</tr>
<tr>
<td><strong>RunCode</strong></td>
</tr>
<tr>
<td><strong>RunMacro</strong></td>
</tr>
<tr>
<td><strong>RunMenuCommand</strong></td>
</tr>
<tr>
<td><strong>SearchForRecord</strong></td>
</tr>
<tr>
<td><strong>SelectObject</strong></td>
</tr>
</tbody>
</table>

Exercise

• **Exercise File:** None required.
• **Exercise:** Acquaint yourself with common macro actions.
## Working with Macros

### Table 11-2: Macro Actions and Descriptions

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SetMenuItem</td>
<td>Sets the state of menu items (enabled or disabled, checked or unchecked) on custom menus. Works only on custom menus created using menu bar macros.</td>
</tr>
<tr>
<td>SetProperty</td>
<td>Sets control property.</td>
</tr>
<tr>
<td>ShowAllRecords</td>
<td>Removes any applied filter from the active table, query, or form.</td>
</tr>
<tr>
<td>StopAllMacros</td>
<td>Stops all currently running macros.</td>
</tr>
<tr>
<td>StopMacro</td>
<td>Stops the currently running macro. Use to stop a macro when a certain condition is met.</td>
</tr>
</tbody>
</table>
Working with Macros Review

Quiz Questions

107. The fastest and easiest way to create a macro in Access is with the Macro Recorder. (True or False?)

108. A(n) ______, or command, is the basic building block of a macro.
   A. Expression
   B. Action
   C. Procedure
   D. Function

109. You can assign a macro to a button, so that when a user clicks the button or control, a macro is activated. (True or False?)

110. Conditions entered in an Action row in the macro affect all actions in the macro. (True or False?)

111. The ApplyFilter macro action applies a filter or query to a table, form or report. (True or False?)

Quiz Answers

107. False. Microsoft Excel and Word both have macro recorders you can use to create macros, but with Microsoft Access, you create macros in the Macro Design window.

108. B. An action is the basic building block of a macro.

109. True. You can assign a macro to a button.

110. False. Conditions only effect the corresponding Action row in the macro. If you want to evaluate the other actions, they must each have their own statement in the Condition column.

111. True. The ApplyFilter macro action applies a filter or query to a table, form or report.
### Advanced Topics

**Importing Information** .................................................... 229  
Import Access objects ................................................. 229  
Import Excel data ....................................................... 230  

**Exporting Information** ................................................. 231  

**Linking Information from an External Source**  
Link to another Access database ......................... 233  
Link to Excel data ................................................. 234  

**Using Hyperlink Fields** ............................................. 235  

**Displaying Database Object Dependencies** ........ 237  

**Setting a Password in Access** ................................. 238  
Set a password ..................................................... 238  
Remove a password ............................................... 238  

**Compacting and Repairing a Database** .............. 240  
Manually Compact and Repair ............................... 240  
Automatically Compact and Repair ................... 240  

With Microsoft Access, you can easily share information between different databases and even different programs. In this chapter, you’ll learn how to import and export data from external sources, and you’ll learn the difference between importing and linking to outside data.

You’ll also learn how to use Access to collect data from e-mails, how to repair a database, how to set a password to protect your data, and how to create a Switchboard to make navigating a database easier.

**Using Exercise Files**  
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Importing Information

You can import information into a database from other file formats, such as Excel, or from other Microsoft Access databases. You can quickly and easily import tables, forms, reports, queries, macros, and modules from one Access database into another Access database. This saves a lot of time: Instead of creating a new object (such as a form) from scratch, you can import an object from another database and then modify it as needed.

Import Access objects

1. Click the **External Data** tab on the Ribbon and click the **Access** button in the Import & Link group.

   The Get External Data dialog box appears. Here you need to specify the Microsoft Access database that contains the object(s) you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the database that contains the object(s) you want to import. Click **OK**.

   The Import Objects dialog box appears. Here you need to choose the type(s) of object(s) you want to import.

3. Click the tab that corresponds to the type of database object you want to import.

   You can import more than one database object at a time—simply click the appropriate object tab(s) and select the database objects you want to select.

4. Click **OK**.

   Access imports the selected objects into the current database.

5. Click **Close**.

   **Tip:** When you finish the Wizard, Access will ask if you want to save the import steps so you can repeat them in the future. Select the **Save import steps** option and click the **Save Import** button. To access the saved steps in the future, click the **Saved Imports** button in the Import & Link group.

   **Other Ways to Import Database Objects:**
   Open the database containing the object you want to import, copy the object, then paste the object in the current database. Or, right-click a table object in the Navigation Pane of the current database, point to **Import**, and select the type of data source you want to use.

---

**Exercise**

- **Exercise File:** Advanced.accdb, Promotions.accdb, America Expenses.xlsx, Europe Expenses.txt
- **Exercise:** Import the tblPromotions table from the Promotions database into the Advanced database (don’t save the import steps for any imports in this lesson). Import the data from the America Expenses Excel worksheet into a new table called “America Expenses” in the Advanced database. Import the data from the Europe Expenses text document into a new table called “Europe Expenses” in the Advanced database (be sure to select the First Row Contains Field Names check box in the Import Text Wizard).
Import Excel data

1. Click the **External Data** tab on the Ribbon and click the **Excel** button in the Import & Link group.
   
   The Get External Data dialog box appears. Here you need to specify the Microsoft Excel file that contains the data you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the Excel file that contains the data you want to import.
   
   Now you need to choose from a couple options:
   
   - Import the source data into a new table in the current database. Or…
   - Append a copy of the records to the table: [Table name].

3. Select an option for how you want to store the data in the current database and click **OK**.
   
   The Import Spreadsheet Wizard dialog box appears.

4. Follow the onscreen instructions to finish importing the Excel data.
   
   ✅ **Tip:** When you finish the Wizard, Access will ask if you want to save the import steps so you can repeat them in the future. Select the **Save import steps** option and click the **Save Import** button. To access the saved steps in the future, click the **Saved Imports** button in the Import & Link group.

**Tips**

- You can also import data from sources such as SharePoint Lists, text files, XML files, or ODBC databases such as SQL Server. Just click the desired button in the Import group.

- You can also create e-mails to gather information for your Access databases. Click the **Create E-mail button** in the Collect Data group and follow the Wizard’s instructions. Later, click the **Manage Replies** button to view replies from recipients and update Access with the collected data.
Exporting Information

When you export an Access database object, you can save its information in a different format so that it can be understood and opened by different programs. For example, you might export an Access table to an Excel worksheet.

1. Select the database object you want to export in the Navigation Pane or open a database table and select only the specific records you want to export.
   
   For example, you could export an entire table of customers or only the records for a few select customers.

   Next you need to select where you want to export the data: Choose from Excel, SharePoint List, PDF or XPS, Word, Text File, or more formats—such as another Access database.

2. Click the External Data tab on the Ribbon and in the Export group click the button for the type of file to which you want to export.

   The Export dialog box wizard appears. By default, Access will create a new file—named the same as the object you’re exporting—to hold the exported data.

3. Browse to the appropriate drive and/or folder where you want the new exported file to be saved.

   Tip: If desired, you can also edit the name of the new file by changing it at the end of the file path found in the File name box.

   Now you need to specify export options:

   - Export data with formatting and layout.
   - Open the destination file after the export operation is complete.
   - Export only the selected records.

4. Select desired export options and click OK.

   Access copies the data to the new location, but doesn’t delete it from the old database.

   Tip: When you finish exporting, Access will ask if you want to save the steps so you can repeat them in the future. Select the Save export steps option and click the Save Export button. To access the saved steps in the future, click the Saved Exports button in the Export group.

Exercise

- Exercise File: Advanced. accdb
- Exercise: Export the tblCustomers table to a new Excel workbook. Export data with formatting and layout and choose to open the destination file after the export operation is complete. Don’t save the export steps.
5. Click **Close**.

**Other Ways to Export Data:**
In the Navigation Pane, right-click the database object you want to export, point to **Export**, and select the type of file to which you want to export.
Linking Information from an External Source

Another way that you can access information from an outside source is by creating a linked table. Linking data may sound a lot like importing, but there are some very important differences between the two:

- **Imported**: When you import data, you copy data from an external data source and place it in a new table in your database.
- **Linked**: When you link to data, the data stays in its original location. If you link to another database, changes made in either Access or in the other database will flow back and forth. But if you link to an Excel source, changes made in Excel flow to Access, but not vice versa.

**Tips**

- Many databases use a front-end database file, which contains forms, reports, and queries. Front-end database files are linked to a back-end database file, which contains the actual tables. Such designs work great when you want several users on several front-end databases to be able to access the same information in a single back-end database.

**Link to another Access database**

1. Click the **External Data** tab on the Ribbon and click the **Access** button in the Import & Link group.

   The Get External Data dialog box appears. Here you need to specify the Microsoft Access database that contains the object(s) you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the database that contains the object(s) you want to import.

3. Select the **Link to the data source by creating a linked table** option. Click **OK**.

   The Link Tables dialog box appears. Here you need to choose the tables to which you want to link.

4. Select the tables you want to link to and click **OK**.

   The linked table appears in the Navigation Pane with an arrow icon, indicating that it is linked.

**Tip**: You can link to more than one table at a time—simply select all the tables you want to select.

---

**Exercise**

- **Exercise File**: Advanced.accdb, States.accdb
- **Exercise**: Link the tblStates table from the States database into the Advanced database. Add the data “Florida, FL” to the linked tblStates table in the Advanced database.
Link to Excel data

You can also link to non-Access data sources, such as an Excel worksheet.

1. Click the External Data tab on the Ribbon and click the Excel button in the Import & Link group.

   The Get External Data dialog box appears. Here you need to specify the Microsoft Excel file that contains the data you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the Excel file that contains the data you want to link.

   Now you need to create a linked table.

3. Select the Link to the data source by creating a linked table option and click OK.

   The Link Spreadsheet Wizard dialog box appears.

4. Follow the onscreen instructions to finish linking to the Excel data.

   The Excel data appears in Access as a linked table in the Navigation Pane.
Using Hyperlink Fields

In this lesson you will learn how to use hyperlinks in Microsoft Access. A hyperlink can point to any file on your computer, the network, or even a Web page on the Internet. Whenever you click on a hyperlink, you jump to the hyperlink’s destination (if it’s available). A hyperlink is usually indicated by colored and underlined text.

In this lesson you will learn how to use hyperlink fields in tables to create links that point to files on your network or the Internet.

Create a hyperlink

1. Display the table to which you want to add the hyperlink in Design View.
   First you need to create a column to hold the hyperlinks.

2. Click the first blank Field Name row and enter a name such as Link.

3. Click the Data Type list arrow and select Hyperlink. Return to Datasheet View.
   The hyperlink field is created. Now you can set up hyperlinks for certain records as desired.

4. Right-click in the Link field in the record for which you want to create a hyperlink, point to Hyperlink, and select Edit Hyperlink.
   The Insert Hyperlink dialog box appears. This is where you will specify the name and location of the file or Web page you want to add as a hyperlink.

5. Browse to a file on your computer or network, or enter a Web address in the Address box.
   The name of the file or Web site appears in the Text to display box. This is the text that will appear in the field on your table, and which you will click to activate the hyperlink.

6. Edit the text in the “Text to display box”, if desired, then click OK.
   The dialog box closes and you return to the datasheet, where hyperlink text now appears in the field.

Other Ways to Insert a Hyperlink:
   Type in a full email address or web address into the field with the Hyperlink data type.
Advanced Topics

Use a hyperlink

Once you’ve created a hyperlink, you simply click the hyperlink text in the field to go to the linked file or Web site.

1. Click the desired hyperlink text in the table field.
   The hyperlink opens the destination file or Web site.

   ✔ Tip: Depending on your computer’s security settings, you may have to click Yes to view it.

Edit a hyperlink

You can easily change either the hyperlink text that appears in the table or the hyperlink’s destination.

1. Right-click the hyperlink text, point to Hyperlink, and select Edit Hyperlink.
   The Edit Hyperlink dialog box appears, allowing you to make changes to the hyperlink.

✔ Tips

✔ To remove a hyperlink, right-click the linked text in the field, point to Hyperlink, and select Remove Hyperlink.

✔ Similar to hyperlink fields, you can also create OLE Object fields. These fields allow you to store files created in other programs—such as graphics, Excel worksheets, or Word documents. To create an OLE Object field in a table, select the OLE Object field type instead of Hyperlink in Design View. The rest of the process is very similar to inserting a hyperlink.
Displaying Database Object Dependencies

Databases can often be complicated and interconnected. For example, a form might be based on a query, which in turn is based on a table. So, how do you keep track of all these interconnected database objects? By viewing object dependencies.

That way, before you delete or rename a query, you can view every database object—every query, form, and report—that is dependent on that query. You can also do the reverse and view every database object that the query requires in order to function.

Here’s how to view object dependencies.

1. Open the database in which you want to view dependencies.
2. Click a database object in the Navigation Pane.
3. Click the Database Tools tab on the Ribbon and click the Object Dependencies button in the Relationships group.

The Object Dependencies pane appears.

Tip: You may need to click OK to update dependency information or to turn on the Track name AutoCorrect info option before the pane will appear.

You have a couple options for how to view objects in the pane:

- Objects that depend on me: Select this option to view objects that use the selected object.
- Objects that I depend on: Select this option to view objects that the selected object uses.

4. Click the expand icon next to an object in the pane to see that object’s dependencies.

Exercise

- Exercise File: Advanced.accdb
- Exercise: Select the tblCustomers table and display the Object Dependencies pane. Expand the table relationships in the pane, then select the “Objects that I depend on” option and expand the relationships again.
Setting a Password in Access

You can encrypt a database using a password to keep unauthorized users from opening the database.

Set a password

To encrypt a database, you first need to open it in Exclusive mode.

1. Start the Access program.
   The Getting Started with Microsoft Office Access screen appears.

2. Click the File tab and select Open.

3. Browse to and select the Access file you want to open. Click the Open list arrow and select Open Exclusive.
   The database opens in exclusive mode.

4. Click the File tab on the Ribbon and click the Encrypt with Password button in the Info group.
   The Set Database Password dialog box appears.

5. Type a password in the Password box, enter it again in the Verify box, and click OK.
   The password is set. In the future, whenever anyone tries to open the database, they will first be prompted to enter the password.

Trap: Make sure you remember the password—Microsoft can’t help you if you forget.

Remove a password

To remove a password, you once again need to open the database in Exclusive mode.

1. Start the Access program.
   The Getting Started with Microsoft Office Access screen appears.

2. Click the File tab and select Open.

3. Browse to and select the Access file you want to open. Click the Open list arrow and select Open Exclusive.
   The database opens in exclusive mode.

4. Click the File tab on the Ribbon and click the Decrypt Database button in the Info group.
   The Unset Database Password dialog box appears.

Exercise

- Exercise File: Advanced.accdb
- Exercise: Set a password to encrypt the file, then access the file and remove the password.
Advanced Topics

5. Type the password in the Password box and click OK.

The password is removed from the database.
Compact Database: When you delete a database object or record, it leaves behind an empty hole that the object previously occupied. This isn’t a big deal unless, over time, you have deleted lots of database objects and records. Compacting a database rearranges how the database is stored and reduces its file size.

Repair Database: Over time, normal wear and tear causes errors to appear in your database, thus affecting its performance. Usually these errors are very minor and can easily be fixed by repairing the database.

If you have been busy adding, editing, and deleting records for a while or if your database seems buggy, sluggish, or is generating error messages, it would be a good idea to run the Compact and Repair Database command.

**Tips**

Before using the Compact and Repair Database command, it’s a good idea to back up your database. To do this, click the File tab, click Save & Publish, click Save Database As and select Back Up Database under Advanced.

**Manually Compact and Repair**

1. Open the database you want to compact and repair.

2. Click the Database Tools tab and select Compact and Repair Database in the Tools group.

   Access compacts the database and repairs any errors it finds.

**Automatically Compact and Repair**

When you set up Access to automatically compact and repair a database, only the database that is currently open is affected. To set up others, you need to set up each database individually.
1. Open the database you want to set up to compact and repair automatically.

2. Click the **File** tab and select **Options**.
   The Access Options dialog box appears.

3. Click **Current Database**, then select the **Compact on Close** option in the Application Options area.
   Now Access will automatically compact and repair the database each time you close the database.

**Figure 12-21**: Setting up a database to automatically run the compact function when closing the database.
Advanced Topics Review

Quiz Questions

112. You can import data into Access from which of the following sources?
   A. Excel
   B. Another Access database
   C. Text file
   D. All of these.

113. To export from Access, use the commands found in the _______ group on the Ribbon.
   A. Import
   B. External
   C. Export
   D. Send

114. When you create a link to a table in an external database, Access imports the table into the current database. (True or False?)

115. A hyperlink can point to…
   A. A file on your computer.
   B. A file on a network.
   C. A Web page on the Internet.
   D. All of these.

116. The Object Dependencies command is found in the _______ group.
   A. Objects
   B. Panes
   C. Show/Hide
   D. Relationships

117. To set a password, you first need to open the database in _______ mode.
   A. Exclusive
   B. Password
   C. Sharing
   D. Read-Only

118. When you set up Access to automatically compact and repair, that setting applies to all Access databases. (True or False?)
**Quiz Answers**

113. D. You can import data into Access from any of these files.

114. C. Use the commands in the Export group to export data from Access.

115. False. When you link to a table, the data stays in its original location.

116. D. Hyperlinks can point to any of these items.

117. C. The Object Dependencies command is found in the Show/Hide group.

118. A. Open a database in Exclusive mode to set a password.

119. False. You need to set up the automatic feature individually for each database.